aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/xneur
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2015-10-20 19:24:34 +0800
committermadpilot <madpilot@FreeBSD.org>2015-10-20 19:24:34 +0800
commit3413b4f7eb8401cb87276e59945b633a9c35a94d (patch)
treef70ebc920849c1005d7d03320e52382e17b86f83 /deskutils/xneur
parentf7f77205ee34f6d80a5a6be9feab4ae786493c8f (diff)
downloadfreebsd-ports-gnome-3413b4f7eb8401cb87276e59945b633a9c35a94d.tar.gz
freebsd-ports-gnome-3413b4f7eb8401cb87276e59945b633a9c35a94d.tar.zst
freebsd-ports-gnome-3413b4f7eb8401cb87276e59945b633a9c35a94d.zip
- Update to 0.17.0
- Update MASTER_SITES and WWW in pkg-descr - Add LICENSE - Convert to USES localbase and use compiler USES due to nested functions requirement - Use option helpers - Regenerate some patches PR: 201041 Submitted by: mizhka at gmail.com Approved by: admin at lissyara.su (maintainer)
Diffstat (limited to 'deskutils/xneur')
-rw-r--r--deskutils/xneur/Makefile60
-rw-r--r--deskutils/xneur/distinfo4
-rw-r--r--deskutils/xneur/files/patch-etc-Makefile.in6
-rw-r--r--deskutils/xneur/files/patch-lib__config__xnconfig_memory.c10
-rw-r--r--deskutils/xneur/files/patch-lib_main_keymap.c10
-rw-r--r--deskutils/xneur/pkg-descr2
-rw-r--r--deskutils/xneur/pkg-plist60
7 files changed, 69 insertions, 83 deletions
diff --git a/deskutils/xneur/Makefile b/deskutils/xneur/Makefile
index 42826b29e1c0..f279ca460957 100644
--- a/deskutils/xneur/Makefile
+++ b/deskutils/xneur/Makefile
@@ -2,25 +2,26 @@
# $FreeBSD$
PORTNAME= xneur
-PORTVERSION= 0.15.0
-PORTREVISION= 6
+PORTVERSION= 0.17.0
+DISTVERSIONSUFFIX=.orig
CATEGORIES= deskutils
-MASTER_SITES= http://dists.xneur.ru/release-${DISTVERSION}/tgz/ \
- http://mirror.amdmi3.ru/distfiles/
+MASTER_SITES= https://launchpad.net/~andrew-crew-kuznetsov/+archive/xneur-stable/+files/
+DISTNAME= ${PORTNAME}_${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= admin@lissyara.su
COMMENT= Auto keyboard switcher
+LICENSE= GPLv2
+
LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify \
libpcre.so:${PORTSDIR}/devel/pcre
-USES= pathfix pkgconfig iconv tar:bzip2 libtool
+USES= compiler:nestedfct iconv libtool localbase pathfix pkgconfig
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --disable-static --libdir=${PREFIX}/lib/xneur
-USE_LDCONFIG= yes
+USE_LDCONFIG= ${PREFIX}/lib/xneur ${PREFIX}/lib/xneur/xneur
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
@@ -30,23 +31,22 @@ OPTIONS_RADIO= SOUND
OPTIONS_RADIO_SOUND= GSTREAMER OPENAL
XOSD_DESC= Xosd support
-.include <bsd.port.options.mk>
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
-.if ${PORT_OPTIONS:MX11}
-USE_XORG+= x11
-CONFIGURE_ARGS+= --with-x
-.else
-CONFIGURE_ARGS+= --without-x
-.endif
+X11_USE= XORG=x11
+X11_CONFIGURE_WITH= x
+
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
+ASPELL_CONFIGURE_ON= --with-spell=aspell
+ASPELL_CONFIGURE_OFF= --with-spell=no --without-aspell
+
+XOSD_LIB_DEPENDS= libxosd.so:${PORTSDIR}/misc/xosd
+XOSD_CONFIGURE_WITH= xosd
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGSTREAMER}
USE_GSTREAMER= yes
@@ -58,20 +58,6 @@ CONFIGURE_ARGS+= --with-sound=openal
CONFIGURE_ARGS+= --with-sound=no
.endif
-.if ${PORT_OPTIONS:MASPELL}
-LIB_DEPENDS+= libaspell.so:${PORTSDIR}/textproc/aspell
-CONFIGURE_ARGS+= --with-spell=aspell
-.else
-CONFIGURE_ARGS+= --with-spell=no --without-aspell
-.endif
-
-.if ${PORT_OPTIONS:MXOSD}
-LIB_DEPENDS+= libxosd.so:${PORTSDIR}/misc/xosd
-CONFIGURE_ARGS+= --with-xosd
-.else
-CONFIGURE_ARGS+= --without-xosd
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,-Werror,,g; s,-ldl,,g' ${WRKSRC}/configure
@${MV} ${WRKSRC}/etc/xneurrc ${WRKSRC}/etc/xneurrc.sample
diff --git a/deskutils/xneur/distinfo b/deskutils/xneur/distinfo
index ba42f35d18eb..62f6e27851de 100644
--- a/deskutils/xneur/distinfo
+++ b/deskutils/xneur/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xneur-0.15.0.tar.bz2) = ebedf81ac2c8510d60e235ca66c7ed73c306b22b5b3164981a628950b5cb3e70
-SIZE (xneur-0.15.0.tar.bz2) = 1136568
+SHA256 (xneur_0.17.0.orig.tar.gz) = b5243e401239505c449a6a2671a0d42c05deabac8ef7442d4a7ca8236137a8ab
+SIZE (xneur_0.17.0.orig.tar.gz) = 1669034
diff --git a/deskutils/xneur/files/patch-etc-Makefile.in b/deskutils/xneur/files/patch-etc-Makefile.in
index 9ee304088411..8613c5f35163 100644
--- a/deskutils/xneur/files/patch-etc-Makefile.in
+++ b/deskutils/xneur/files/patch-etc-Makefile.in
@@ -1,6 +1,6 @@
---- etc/Makefile.in.orig 2011-03-17 06:55:24.700517870 +0100
-+++ etc/Makefile.in 2011-03-17 06:57:38.716913390 +0100
-@@ -230,7 +230,7 @@
+--- etc/Makefile.in.orig 2015-06-22 10:21:10 UTC
++++ etc/Makefile.in
+@@ -259,7 +259,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
xneurrcdir = $(sysconfdir)/xneur
xneurrc_DATA = \
diff --git a/deskutils/xneur/files/patch-lib__config__xnconfig_memory.c b/deskutils/xneur/files/patch-lib__config__xnconfig_memory.c
deleted file mode 100644
index ffd68331c4b2..000000000000
--- a/deskutils/xneur/files/patch-lib__config__xnconfig_memory.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./lib/config/xnconfig_memory.c.orig Mon Jun 11 12:08:15 2007
-+++ ./lib/config/xnconfig_memory.c Mon Jun 11 12:08:29 2007
-@@ -17,6 +17,7 @@
- *
- */
-
-+#include <sys/_types.h>
- #include <sys/shm.h>
- #include <string.h>
-
diff --git a/deskutils/xneur/files/patch-lib_main_keymap.c b/deskutils/xneur/files/patch-lib_main_keymap.c
new file mode 100644
index 000000000000..3ffc42001f9c
--- /dev/null
+++ b/deskutils/xneur/files/patch-lib_main_keymap.c
@@ -0,0 +1,10 @@
+--- lib/main/keymap.c.orig 2013-10-24 10:26:35 UTC
++++ lib/main/keymap.c
+@@ -17,6 +17,7 @@
+ *
+ */
+
++#include <X11/Xlocale.h>
+ #include <X11/XKBlib.h>
+
+ #include <stdlib.h>
diff --git a/deskutils/xneur/pkg-descr b/deskutils/xneur/pkg-descr
index b5e46c6a9c76..c40868dfb406 100644
--- a/deskutils/xneur/pkg-descr
+++ b/deskutils/xneur/pkg-descr
@@ -9,4 +9,4 @@ English, Russian, Ukrainian, Belarusian, French, Romanian, Bulgarian, Czech,
Greek, Estonian, Armenian, Lithuanian, Latvian, Poland, Spanish and Uzbek
languages.
-WWW: http://xneur.ru/
+WWW: https://launchpad.net/xneur
diff --git a/deskutils/xneur/pkg-plist b/deskutils/xneur/pkg-plist
index 6b5c384c0902..e92777f5ec5a 100644
--- a/deskutils/xneur/pkg-plist
+++ b/deskutils/xneur/pkg-plist
@@ -1,10 +1,10 @@
bin/xneur
-@sample etc/xneur/xneurrc.sample
-lib/xneur/libxneur.so.15.0.0
-lib/xneur/libxneur.so.15
+@sample %%ETCDIR%%/xneurrc.sample
+lib/xneur/libxneur.so.17.0.0
+lib/xneur/libxneur.so.17
lib/xneur/libxneur.so
-lib/xneur/libxnconfig.so.15.0.0
-lib/xneur/libxnconfig.so.15
+lib/xneur/libxnconfig.so.17.0.0
+lib/xneur/libxnconfig.so.17
lib/xneur/libxnconfig.so
lib/xneur/xneur/libxntest.so.0.0.0
lib/xneur/xneur/libxntest.so.0
@@ -24,69 +24,69 @@ include/xneur/xnconfig.h
%%DATADIR%%/sounds/replace.wav
%%DATADIR%%/sounds/switch.wav
%%DATADIR%%/sounds/itemback.wav
+%%DATADIR%%/languages/am/dictionary
%%DATADIR%%/languages/am/proto
%%DATADIR%%/languages/am/proto3
-%%DATADIR%%/languages/am/dictionary
+%%DATADIR%%/languages/bg/dictionary
%%DATADIR%%/languages/bg/proto
%%DATADIR%%/languages/bg/proto3
-%%DATADIR%%/languages/bg/dictionary
+%%DATADIR%%/languages/by/dictionary
%%DATADIR%%/languages/by/proto
%%DATADIR%%/languages/by/proto3
-%%DATADIR%%/languages/by/dictionary
+%%DATADIR%%/languages/cz/dictionary
%%DATADIR%%/languages/cz/proto
%%DATADIR%%/languages/cz/proto3
-%%DATADIR%%/languages/cz/dictionary
+%%DATADIR%%/languages/de/dictionary
%%DATADIR%%/languages/de/proto
%%DATADIR%%/languages/de/proto3
-%%DATADIR%%/languages/de/dictionary
-%%DATADIR%%/languages/ge/proto
-%%DATADIR%%/languages/ge/proto3
-%%DATADIR%%/languages/ge/dictionary
-%%DATADIR%%/languages/gr/proto
-%%DATADIR%%/languages/gr/proto3
-%%DATADIR%%/languages/gr/dictionary
+%%DATADIR%%/languages/ee/dictionary
%%DATADIR%%/languages/ee/proto
%%DATADIR%%/languages/ee/proto3
-%%DATADIR%%/languages/ee/dictionary
+%%DATADIR%%/languages/en/dictionary
%%DATADIR%%/languages/en/proto
%%DATADIR%%/languages/en/proto3
-%%DATADIR%%/languages/en/dictionary
+%%DATADIR%%/languages/es/dictionary
%%DATADIR%%/languages/es/proto
%%DATADIR%%/languages/es/proto3
-%%DATADIR%%/languages/es/dictionary
+%%DATADIR%%/languages/fr/dictionary
%%DATADIR%%/languages/fr/proto
%%DATADIR%%/languages/fr/proto3
-%%DATADIR%%/languages/fr/dictionary
+%%DATADIR%%/languages/gb/dictionary
%%DATADIR%%/languages/gb/proto
%%DATADIR%%/languages/gb/proto3
-%%DATADIR%%/languages/gb/dictionary
+%%DATADIR%%/languages/ge/dictionary
+%%DATADIR%%/languages/ge/proto
+%%DATADIR%%/languages/ge/proto3
+%%DATADIR%%/languages/gr/dictionary
+%%DATADIR%%/languages/gr/proto
+%%DATADIR%%/languages/gr/proto3
+%%DATADIR%%/languages/kz/dictionary
%%DATADIR%%/languages/kz/proto
%%DATADIR%%/languages/kz/proto3
-%%DATADIR%%/languages/kz/dictionary
+%%DATADIR%%/languages/lt/dictionary
%%DATADIR%%/languages/lt/proto
%%DATADIR%%/languages/lt/proto3
-%%DATADIR%%/languages/lt/dictionary
+%%DATADIR%%/languages/lv/dictionary
%%DATADIR%%/languages/lv/proto
%%DATADIR%%/languages/lv/proto3
-%%DATADIR%%/languages/lv/dictionary
+%%DATADIR%%/languages/pl/dictionary
%%DATADIR%%/languages/pl/proto
%%DATADIR%%/languages/pl/proto3
-%%DATADIR%%/languages/pl/dictionary
+%%DATADIR%%/languages/ro/dictionary
%%DATADIR%%/languages/ro/proto
%%DATADIR%%/languages/ro/proto3
-%%DATADIR%%/languages/ro/dictionary
+%%DATADIR%%/languages/ru/dictionary
%%DATADIR%%/languages/ru/proto
%%DATADIR%%/languages/ru/proto3
-%%DATADIR%%/languages/ru/dictionary
+%%DATADIR%%/languages/ua/dictionary
%%DATADIR%%/languages/ua/proto
%%DATADIR%%/languages/ua/proto3
-%%DATADIR%%/languages/ua/dictionary
+%%DATADIR%%/languages/us/dictionary
%%DATADIR%%/languages/us/proto
%%DATADIR%%/languages/us/proto3
-%%DATADIR%%/languages/us/dictionary
+%%DATADIR%%/languages/uz/dictionary
%%DATADIR%%/languages/uz/proto
%%DATADIR%%/languages/uz/proto3
-%%DATADIR%%/languages/uz/dictionary
%%NLS%%share/locale/be/LC_MESSAGES/xneur.mo
%%NLS%%share/locale/de/LC_MESSAGES/xneur.mo
%%NLS%%share/locale/ro/LC_MESSAGES/xneur.mo