aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/xpad-current
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2011-11-21 04:53:34 +0800
committereadler <eadler@FreeBSD.org>2011-11-21 04:53:34 +0800
commit085ae99e8348464d9be5ea4408ce6c827d68664a (patch)
tree4ece1d138b1d2bb40fae952d2a62651612666d84 /deskutils/xpad-current
parent0cc68f1f30ec2203221d759da7f2c77ceca55258 (diff)
downloadfreebsd-ports-gnome-085ae99e8348464d9be5ea4408ce6c827d68664a.tar.gz
freebsd-ports-gnome-085ae99e8348464d9be5ea4408ce6c827d68664a.tar.zst
freebsd-ports-gnome-085ae99e8348464d9be5ea4408ce6c827d68664a.zip
xpad is a sticky note application written using GTK+ 2.0 that strives to be
simple, fault-tolerant, and customizable. xpad consists of independent pad windows; each is basically a text box in which notes can be written. Despite being called xpad, all that is needed to run or compile it is the GTK+ 2.0 libraries. Here is a list of major features in the current xpad current release: * GTK+ 2.0 powered text view. * Fault tolerant. All information is kept on the hard drive, not memory. * xpad is very customizable. The color scheme (text, background, and window borders) and the font can be changed. * A customizable toolbar puts the most frequently used commands at your fingertips. * Support for the X session management protocol. * Support for the www.freedesktop.org system tray proposal. WWW: https://launchpad.net/xpad PR: ports/162623 Submitted by: Jason Helfman <jhelfman@experts-exchange.com> Feature safe: yes
Diffstat (limited to 'deskutils/xpad-current')
-rw-r--r--deskutils/xpad-current/Makefile35
-rw-r--r--deskutils/xpad-current/distinfo2
-rw-r--r--deskutils/xpad-current/pkg-descr17
-rw-r--r--deskutils/xpad-current/pkg-plist33
4 files changed, 87 insertions, 0 deletions
diff --git a/deskutils/xpad-current/Makefile b/deskutils/xpad-current/Makefile
new file mode 100644
index 000000000000..1909172f2622
--- /dev/null
+++ b/deskutils/xpad-current/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xpad-current
+# Date created: 14 November 2011
+# Whom: Jason Helfman <jhelfman@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpad
+PORTVERSION= 4.1
+CATEGORIES= deskutils
+MASTER_SITES= http://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
+PKGNAMESUFFIX= -current
+
+MAINTAINER= jhelfman@experts-exchange.com
+COMMENT= A virtual note-pad system for your X11 desktop
+
+LICENSE= GPLv3
+
+CONFLICTS_INSTALL= xpad-[0-9]*
+FETCH_ARGS= -p
+USE_BZIP2= yes
+USE_XORG= x11 sm
+USE_GNOME= pkgconfig gtk20 gnomehier intltool
+INSTALLS_ICONS= yes
+CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+#code currently doesn't properly handle --disable-nls (in next upstream milestone)
+USE_GETTEXT= yes
+
+MAN1= xpad.1
+
+.include <bsd.port.mk>
diff --git a/deskutils/xpad-current/distinfo b/deskutils/xpad-current/distinfo
new file mode 100644
index 000000000000..e3df50d8acdd
--- /dev/null
+++ b/deskutils/xpad-current/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xpad-4.1.tar.bz2) = 0e36e5f45dd87ec54151f5fddcb78f5f0eec3d0056ae1c4b99b4bfc4eec1bbb9
+SIZE (xpad-4.1.tar.bz2) = 184750
diff --git a/deskutils/xpad-current/pkg-descr b/deskutils/xpad-current/pkg-descr
new file mode 100644
index 000000000000..61d7e6cb30f5
--- /dev/null
+++ b/deskutils/xpad-current/pkg-descr
@@ -0,0 +1,17 @@
+xpad is a sticky note application written using GTK+ 2.0 that strives to be
+simple, fault-tolerant, and customizable. xpad consists of independent pad
+windows; each is basically a text box in which notes can be written. Despite
+being called xpad, all that is needed to run or compile it is the GTK+ 2.0
+libraries. Here is a list of major features in the current xpad current
+release:
+
+ * GTK+ 2.0 powered text view.
+ * Fault tolerant. All information is kept on the hard drive, not memory.
+ * xpad is very customizable. The color scheme (text, background, and window
+ borders) and the font can be changed.
+ * A customizable toolbar puts the most frequently used commands at your
+ fingertips.
+ * Support for the X session management protocol.
+ * Support for the www.freedesktop.org system tray proposal.
+
+WWW: https://launchpad.net/xpad
diff --git a/deskutils/xpad-current/pkg-plist b/deskutils/xpad-current/pkg-plist
new file mode 100644
index 000000000000..d6b8a694cd62
--- /dev/null
+++ b/deskutils/xpad-current/pkg-plist
@@ -0,0 +1,33 @@
+bin/xpad
+share/applications/xpad.desktop
+share/icons/hicolor/icon-theme.cache
+share/icons/hicolor/scalable/apps/xpad.svg
+share/locale/af/LC_MESSAGES/xpad.mo
+share/locale/bg/LC_MESSAGES/xpad.mo
+share/locale/cs/LC_MESSAGES/xpad.mo
+share/locale/da/LC_MESSAGES/xpad.mo
+share/locale/de/LC_MESSAGES/xpad.mo
+share/locale/en_GB/LC_MESSAGES/xpad.mo
+share/locale/es/LC_MESSAGES/xpad.mo
+share/locale/et/LC_MESSAGES/xpad.mo
+share/locale/fi/LC_MESSAGES/xpad.mo
+share/locale/fr/LC_MESSAGES/xpad.mo
+share/locale/ga/LC_MESSAGES/xpad.mo
+share/locale/hr/LC_MESSAGES/xpad.mo
+share/locale/hu/LC_MESSAGES/xpad.mo
+share/locale/it/LC_MESSAGES/xpad.mo
+share/locale/ja/LC_MESSAGES/xpad.mo
+share/locale/ko/LC_MESSAGES/xpad.mo
+share/locale/lv/LC_MESSAGES/xpad.mo
+share/locale/nl/LC_MESSAGES/xpad.mo
+share/locale/pt/LC_MESSAGES/xpad.mo
+share/locale/ro/LC_MESSAGES/xpad.mo
+share/locale/ru/LC_MESSAGES/xpad.mo
+share/locale/rw/LC_MESSAGES/xpad.mo
+share/locale/sv/LC_MESSAGES/xpad.mo
+share/locale/th/LC_MESSAGES/xpad.mo
+share/locale/tr/LC_MESSAGES/xpad.mo
+share/locale/vi/LC_MESSAGES/xpad.mo
+share/locale/zh_CN/LC_MESSAGES/xpad.mo
+share/locale/zh_TW/LC_MESSAGES/xpad.mo
+@dirrmtry share/applications