aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-02 07:16:59 +0800
committerPav Lucistnik <pav@FreeBSD.org>2004-04-02 07:16:59 +0800
commit03c9298349833192a36ec004538392b998dc9d93 (patch)
treeb309d1021118df8592fb5f1409e9a8bdc60ba60c /deskutils
parenta0b833d3a4efd938c696665825721aaef5c750e2 (diff)
downloadfreebsd-ports-gnome-03c9298349833192a36ec004538392b998dc9d93.tar.gz
freebsd-ports-gnome-03c9298349833192a36ec004538392b998dc9d93.tar.zst
freebsd-ports-gnome-03c9298349833192a36ec004538392b998dc9d93.zip
Add pal, a command line calendar that can keep track of events. It has
similarities with the Unix cal command, the more complex GNU gcal program, and the calendar program distributed with the BSDs. PR: ports/64353 Submitted by: Herbert J. Skuhra <herbert.skuhra@gmx.at>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/pal/Makefile45
-rw-r--r--deskutils/pal/distinfo2
-rw-r--r--deskutils/pal/pkg-descr6
-rw-r--r--deskutils/pal/pkg-plist13
5 files changed, 67 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index bd891138b8f1..c911174d93f6 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -80,6 +80,7 @@
SUBDIR += narval
SUBDIR += notebook
SUBDIR += offix-trash
+ SUBDIR += pal
SUBDIR += phpgroupware
SUBDIR += plan
SUBDIR += planner
diff --git a/deskutils/pal/Makefile b/deskutils/pal/Makefile
new file mode 100644
index 000000000000..daf448a78e36
--- /dev/null
+++ b/deskutils/pal/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: pal
+# Date created: Mar 16, 2004
+# Whom: Herbert J. Skuhra <herbert.skuhra@gmx.at>
+#
+# $FreeBSD$
+
+PORTNAME= pal
+PORTVERSION= 0.3.3
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= palcal
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= herbert.skuhra@gmx.at
+COMMENT= A calendar application
+
+USE_GNOME= glib20
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ALL_TARGET=
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
+MAN1= pal.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= Needs readline 4.2 or newer
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,prefix = /usr,prefix = ${PREFIX},g" ${WRKSRC}/Makefile.defs
+
+post-build:
+ ${REINPLACE_CMD} -e "s,VERSION,${PORTVERSION},g" ${WRKDIR}/${PORTNAME}-${PORTVERSION}/pal.1.template
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pal ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/share/*.pal ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/share/*.conf ${DATADIR}
+ ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/pal.1.template ${PREFIX}/man/man1/pal.1
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/pal/distinfo b/deskutils/pal/distinfo
new file mode 100644
index 000000000000..f83c14b2d655
--- /dev/null
+++ b/deskutils/pal/distinfo
@@ -0,0 +1,2 @@
+MD5 (pal-0.3.3.tgz) = 3cf53e55ab18fa2655c5d2f58498c6d0
+SIZE (pal-0.3.3.tgz) = 85454
diff --git a/deskutils/pal/pkg-descr b/deskutils/pal/pkg-descr
new file mode 100644
index 000000000000..cca03bdb23d4
--- /dev/null
+++ b/deskutils/pal/pkg-descr
@@ -0,0 +1,6 @@
+Pal is a command-line calendar program for Unix/Linux systems that can
+keep track of events. It has similarities with the Unix cal command, the
+more complex GNU gcal program, and the calendar program distributed with
+the BSDs.
+
+WWW: http://palcal.sourceforge.net/
diff --git a/deskutils/pal/pkg-plist b/deskutils/pal/pkg-plist
new file mode 100644
index 000000000000..06bd9f7f592a
--- /dev/null
+++ b/deskutils/pal/pkg-plist
@@ -0,0 +1,13 @@
+bin/pal
+%%DATADIR%%/australia.pal
+%%DATADIR%%/birth-death.pal
+%%DATADIR%%/christian.pal
+%%DATADIR%%/computer.pal
+%%DATADIR%%/history.pal
+%%DATADIR%%/lotr.pal
+%%DATADIR%%/music.pal
+%%DATADIR%%/pagan.pal
+%%DATADIR%%/pal.conf
+%%DATADIR%%/us.pal
+%%DATADIR%%/world.pal
+@dirrm %%DATADIR%%