aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-07-17 14:36:25 +0800
committeryuri <yuri@FreeBSD.org>2019-07-17 14:36:25 +0800
commit049c64bba25fce5c5c5fa7fd47a9072861b66e64 (patch)
treec618df56e3b516851290920516aab3bc5e94e771 /deskutils
parent402b10b797814502ac1ba4ff422fd326e6e1b21d (diff)
downloadfreebsd-ports-gnome-049c64bba25fce5c5c5fa7fd47a9072861b66e64.tar.gz
freebsd-ports-gnome-049c64bba25fce5c5c5fa7fd47a9072861b66e64.tar.zst
freebsd-ports-gnome-049c64bba25fce5c5c5fa7fd47a9072861b66e64.zip
New port: deskutils/cfiles: Ncurses file manager written in C with vim-like keybindings
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/cfiles/Makefile39
-rw-r--r--deskutils/cfiles/distinfo3
-rw-r--r--deskutils/cfiles/pkg-descr8
4 files changed, 51 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index c895ec45dae2..f56b5afdd554 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -27,6 +27,7 @@
SUBDIR += calcurse
SUBDIR += calibre
SUBDIR += cartotheque
+ SUBDIR += cfiles
SUBDIR += charmtimetracker
SUBDIR += chart
SUBDIR += cherrytree
diff --git a/deskutils/cfiles/Makefile b/deskutils/cfiles/Makefile
new file mode 100644
index 000000000000..9e14e0568b2c
--- /dev/null
+++ b/deskutils/cfiles/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= cfiles
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7.2
+CATEGORIES= deskutils
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Ncurses file manager written in C with vim-like keybindings
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+#RUN_DEPENDS= ${LOCALBASE}/libexec/w3m/w3mimgdisplay:www/w3m # w3mimgdisplay is used from scripts/displayimg but www/w3m doesn't install it by default
+RUN_DEPENDS= bash:shells/bash
+
+USES= ncurses:port pkgconfig shebangfix
+SHEBANG_FILES= scripts/*
+USE_GITHUB= yes
+GH_ACCOUNT= mananapr
+
+MAKE_ARGS= CC=${CC}
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz \
+ ${DATADIR}/scripts/clearimg \
+ ${DATADIR}/scripts/clearimg_uberzug \
+ ${DATADIR}/scripts/displayimg \
+ ${DATADIR}/scripts/displayimg_uberzug
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/cfiles/scripts
+.for s in clearimg displayimg displayimg_uberzug clearimg_uberzug
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/${s} ${STAGEDIR}${PREFIX}/share/cfiles/scripts
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/cfiles.1 ${STAGEDIR}${MAN5PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/deskutils/cfiles/distinfo b/deskutils/cfiles/distinfo
new file mode 100644
index 000000000000..d019440db719
--- /dev/null
+++ b/deskutils/cfiles/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1563338623
+SHA256 (mananapr-cfiles-v1.7.2_GH0.tar.gz) = 65f141e1deef8fec0bd35264a3837d98fd59fcb993d117deeb0a0a4b9543e383
+SIZE (mananapr-cfiles-v1.7.2_GH0.tar.gz) = 237829
diff --git a/deskutils/cfiles/pkg-descr b/deskutils/cfiles/pkg-descr
new file mode 100644
index 000000000000..282e8a950455
--- /dev/null
+++ b/deskutils/cfiles/pkg-descr
@@ -0,0 +1,8 @@
+cfiles is a terminal file manager with vim like keybindings, written in C using
+the ncurses library. It aims to provide an interface like ranger while being
+lightweight, fast and minimal.
+
+Due to a missing libexec/w3m/w3mimgdisplay, not installed by www/w3m by default,
+the image display feature is broken.
+
+WWW: https://github.com/mananapr/cfiles