aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authortheraven <theraven@FreeBSD.org>2019-02-03 23:37:58 +0800
committertheraven <theraven@FreeBSD.org>2019-02-03 23:37:58 +0800
commit0699c59a70f510b71506ecb61199c2ee997c9c8a (patch)
tree8d55e3d4d3e216787ab6284b0e649a7a6d2f047d /deskutils
parent4b9483ae175d050dbe0859050aa4f4857a2d608b (diff)
downloadfreebsd-ports-gnome-0699c59a70f510b71506ecb61199c2ee997c9c8a.tar.gz
freebsd-ports-gnome-0699c59a70f510b71506ecb61199c2ee997c9c8a.tar.zst
freebsd-ports-gnome-0699c59a70f510b71506ecb61199c2ee997c9c8a.zip
Move Objective-C ports to the v2 GNUstep ABI.
* Bump the LLVM revision used for GNUstep to 7, the minimum to support the new ABI. * GNUstep-back does not work with lld, so mark it to use Gold (BFD LD doesn't seem able to link Objective-C things). * Turn off some annoying debug logs in GNUstep back, which generate several messages per second when you move the mouse. These should never have been enabled in a release build anyway. * Downgrade Cenon to 4.0.2. This was the last version to actually work with GNUstep (the later ones use XCode >= 5 .xib files, which GNUstep can't parse). * Update gorm to git head. The current release doesn't work with the new Objective-C ABI, but -head has the patches to fix it. * Update PikoPixel and add it to the gnustep-app meta-package. * Update the three core GNUstep packages to the latest release. * Update gnumail and pantomime to the latest release and fix a linking error with the new ABI. * Update GNUstep FTP to the latest version. Reviewed by: bapt (previous version)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/affiche/Makefile2
-rw-r--r--deskutils/appwrapper/Makefile2
-rw-r--r--deskutils/cartotheque/Makefile2
-rw-r--r--deskutils/gnustep-wrapper/Makefile2
-rw-r--r--deskutils/gworkspace-gwmetadata/Makefile2
-rw-r--r--deskutils/gworkspace/Makefile2
-rw-r--r--deskutils/helpviewer/Makefile2
-rw-r--r--deskutils/plopfolio/Makefile2
-rw-r--r--deskutils/preferences/Makefile2
-rw-r--r--deskutils/simpleagenda/Makefile2
-rw-r--r--deskutils/systempreferences/Makefile2
-rw-r--r--deskutils/toolboxkit/Makefile2
12 files changed, 12 insertions, 12 deletions
diff --git a/deskutils/affiche/Makefile b/deskutils/affiche/Makefile
index 008bca3061e7..8819b13dc98d 100644
--- a/deskutils/affiche/Makefile
+++ b/deskutils/affiche/Makefile
@@ -2,7 +2,7 @@
PORTNAME= affiche
PORTVERSION= 0.6.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= deskutils gnustep
MASTER_SITES= http://www.collaboration-world.com/affiche.data/releases/Stable/
DISTNAME= Affiche-${PORTVERSION}
diff --git a/deskutils/appwrapper/Makefile b/deskutils/appwrapper/Makefile
index 22ec247b419d..692097bc3c3d 100644
--- a/deskutils/appwrapper/Makefile
+++ b/deskutils/appwrapper/Makefile
@@ -2,7 +2,7 @@
PORTNAME= appwrapper
PORTVERSION= 0.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= deskutils gnustep
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/AppWrapper%20${PORTVERSION}
DISTNAME= AppWrapper.${PORTVERSION}
diff --git a/deskutils/cartotheque/Makefile b/deskutils/cartotheque/Makefile
index 8ec1c9b578a3..399fdff61b3d 100644
--- a/deskutils/cartotheque/Makefile
+++ b/deskutils/cartotheque/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cartotheque
PORTVERSION= 0.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= deskutils gnustep
MASTER_SITES= LOCAL/dinoex
DISTNAME= Cartotheque-${PORTVERSION}
diff --git a/deskutils/gnustep-wrapper/Makefile b/deskutils/gnustep-wrapper/Makefile
index 46ee4fd03c92..f0f13fe58ae1 100644
--- a/deskutils/gnustep-wrapper/Makefile
+++ b/deskutils/gnustep-wrapper/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wrapper
PORTVERSION= 0.1.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= deskutils gnustep
#MASTER_SITES= ftp://ftp.raffael.ch/software/GNUstepWrapper/
MASTER_SITES= LOCAL/dinoex
diff --git a/deskutils/gworkspace-gwmetadata/Makefile b/deskutils/gworkspace-gwmetadata/Makefile
index 579951574147..b0fa79bb8f76 100644
--- a/deskutils/gworkspace-gwmetadata/Makefile
+++ b/deskutils/gworkspace-gwmetadata/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gworkspace
PORTVERSION= 0.9.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils gnustep
#MASTER_SITES= http://www.gnustep.it/enrico/gworkspace/
MASTER_SITES= GNUSTEP/usr-apps
diff --git a/deskutils/gworkspace/Makefile b/deskutils/gworkspace/Makefile
index afb66c645681..ee993974b00a 100644
--- a/deskutils/gworkspace/Makefile
+++ b/deskutils/gworkspace/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gworkspace
PORTVERSION= 0.9.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils gnustep
#MASTER_SITES= http://www.gnustep.it/enrico/gworkspace/
MASTER_SITES= GNUSTEP/usr-apps
diff --git a/deskutils/helpviewer/Makefile b/deskutils/helpviewer/Makefile
index 36e85484db9c..9195003bab5c 100644
--- a/deskutils/helpviewer/Makefile
+++ b/deskutils/helpviewer/Makefile
@@ -2,7 +2,7 @@
PORTNAME= helpviewer
PORTVERSION= 0.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= deskutils gnustep
MASTER_SITES= http://www.roard.com/helpviewer/download/
DISTNAME= HelpViewer-${PORTVERSION}
diff --git a/deskutils/plopfolio/Makefile b/deskutils/plopfolio/Makefile
index 64f75f38a950..cb1ce0d8cbb9 100644
--- a/deskutils/plopfolio/Makefile
+++ b/deskutils/plopfolio/Makefile
@@ -2,7 +2,7 @@
PORTNAME= plopfolio
PORTVERSION= 0.1.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= deskutils gnustep
MASTER_SITES= GNUSTEP/usr-apps
diff --git a/deskutils/preferences/Makefile b/deskutils/preferences/Makefile
index f04bcade7887..f09a8b82617e 100644
--- a/deskutils/preferences/Makefile
+++ b/deskutils/preferences/Makefile
@@ -2,7 +2,7 @@
PORTNAME= preferences
PORTVERSION= 1.2.0
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= deskutils gnustep
MASTER_SITES= SF/prefsapp/prefsapp/${PORTVERSION}
DISTNAME= Preferences-${PORTVERSION}
diff --git a/deskutils/simpleagenda/Makefile b/deskutils/simpleagenda/Makefile
index 7c65f52fc500..7a3d38f4e41e 100644
--- a/deskutils/simpleagenda/Makefile
+++ b/deskutils/simpleagenda/Makefile
@@ -2,7 +2,7 @@
PORTNAME= simpleagenda
PORTVERSION= 0.43
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= deskutils gnustep
MASTER_SITES= http://coyote.octets.fr/pub/gnustep/
DISTNAME= SimpleAgenda-${PORTVERSION}
diff --git a/deskutils/systempreferences/Makefile b/deskutils/systempreferences/Makefile
index d4df1b69b1b4..28c544f00cea 100644
--- a/deskutils/systempreferences/Makefile
+++ b/deskutils/systempreferences/Makefile
@@ -2,7 +2,7 @@
PORTNAME= systempreferences
PORTVERSION= 1.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= deskutils gnustep
MASTER_SITES= GNUSTEP/usr-apps
DISTNAME= SystemPreferences-${PORTVERSION}
diff --git a/deskutils/toolboxkit/Makefile b/deskutils/toolboxkit/Makefile
index f3fd50fdecea..caecab59d7e2 100644
--- a/deskutils/toolboxkit/Makefile
+++ b/deskutils/toolboxkit/Makefile
@@ -2,7 +2,7 @@
PORTNAME= toolbox
PORTVERSION= 0.8
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= deskutils gnustep
MASTER_SITES= http://ftp.azc.uam.mx/mirrors/gnu/savannah/files/toolbox/Release.pkg/0.8/ \
LOCAL/dinoex