aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
committertcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
commit19b60f6341c1340c532b32ab42000f8ef533e37c (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /deskutils
parentcc28d78986356b14cfa92360db6e23f595431254 (diff)
downloadfreebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.gz
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.zst
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/kdeconnect/Makefile2
-rw-r--r--deskutils/kdepim4/Makefile2
-rw-r--r--deskutils/owncloudclient/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/deskutils/kdeconnect/Makefile b/deskutils/kdeconnect/Makefile
index e88828fcebe0..59e13050e6dc 100644
--- a/deskutils/kdeconnect/Makefile
+++ b/deskutils/kdeconnect/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= KDE/unstable/kdeconnect/${PORTVERSION}/src/
MAINTAINER= yurkis@gmail.com
COMMENT= Support for KDE to interface between your phone and your computer
-USES= cmake compiler:c++0x gettext kde:4 tar:xz
+USES= cmake:noninja compiler:c++0x gettext kde:4 tar:xz
USE_KDE= kdelibs automoc4 workspace runtime
USE_QT4= corelib gui moc_build qmake_build uic_build rcc_build
USE_LDCONFIG= yes
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index 1a1330bc654e..5d0f75566ba1 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -24,7 +24,7 @@ CONFLICTS_INSTALL= kdepim44-4.*
USE_GNOME= libxml2 libxslt:build
USE_KDE= kdelibs pimlibs kactivities \
akonadi automoc4 soprano nepomuk-widgets baloo
-USES= cmake:outsource gmake grantlee:4 iconv kde:4 shebangfix tar:xz
+USES= cmake:outsource grantlee:4 iconv kde:4 shebangfix tar:xz
SHEBANG_FILES= agents/mailfilteragent/kconf_update/migrate-kmail-filters.pl \
kalarm/*.pl kmail/kconf_update/*.pl \
libkpgp/kconf_update/kpgp-3.1-upgrade-address-data.pl
diff --git a/deskutils/owncloudclient/Makefile b/deskutils/owncloudclient/Makefile
index f601483aff42..b2ef38db8842 100644
--- a/deskutils/owncloudclient/Makefile
+++ b/deskutils/owncloudclient/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libinotify.so:devel/libinotify \
libqt5keychain.so:security/qtkeychain-qt5
-USES= cmake:outsource compiler:c++11-lib gmake iconv \
+USES= cmake:outsource,noninja compiler:c++11-lib gmake iconv \
localbase:ldflags pkgconfig sqlite ssl
USE_QT5= buildtools_build concurrent core dbus gui linguist_build network \
qmake_build sql webkit widgets xml