aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authoravl <avl@FreeBSD.org>2009-10-14 09:10:59 +0800
committeravl <avl@FreeBSD.org>2009-10-14 09:10:59 +0800
commit2155ffd320b73d8421f046f6ab228d7162d38666 (patch)
tree0e977bc7adea546f88f2f8a041dab9eb96e6b33e /deskutils
parent23414b2a621fd72fbbe6711a172e66ed6ca823da (diff)
downloadfreebsd-ports-gnome-2155ffd320b73d8421f046f6ab228d7162d38666.tar.gz
freebsd-ports-gnome-2155ffd320b73d8421f046f6ab228d7162d38666.tar.zst
freebsd-ports-gnome-2155ffd320b73d8421f046f6ab228d7162d38666.zip
- Update to 0.22.1
- Plugin in the SynCE project now, change MASTER_SITES to SF/synce and WWW
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/Makefile6
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/distinfo6
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/files/patch-src_synce_file.c55
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/pkg-descr2
4 files changed, 7 insertions, 62 deletions
diff --git a/deskutils/libopensync-plugin-synce-legacy/Makefile b/deskutils/libopensync-plugin-synce-legacy/Makefile
index 8b8366be41e2..33c41ab7e4d7 100644
--- a/deskutils/libopensync-plugin-synce-legacy/Makefile
+++ b/deskutils/libopensync-plugin-synce-legacy/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= libopensync-plugin-synce
-PORTVERSION= 0.22
+PORTVERSION= 0.22.1
CATEGORIES= deskutils palm
-MASTER_SITES= http://www.opensync.org/download/releases/${PORTVERSION}/
+MASTER_SITES= SF/synce/SynCE/0.14
PKGNAMESUFFIX= -legacy
+DISTNAME= ${PORTNAME}-rra-${PORTVERSION}
MAINTAINER= avl@FreeBSD.org
COMMENT= SynCE legacy plugin for the OpenSync framework
@@ -19,7 +20,6 @@ LIB_DEPENDS= opensync.0:${PORTSDIR}/devel/libopensync022 \
MAKE_JOBS_SAFE= yes
-USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= glib20 libxml2
diff --git a/deskutils/libopensync-plugin-synce-legacy/distinfo b/deskutils/libopensync-plugin-synce-legacy/distinfo
index 3eb4af3ca7e2..2155454580c3 100644
--- a/deskutils/libopensync-plugin-synce-legacy/distinfo
+++ b/deskutils/libopensync-plugin-synce-legacy/distinfo
@@ -1,3 +1,3 @@
-MD5 (libopensync-plugin-synce-0.22.tar.bz2) = f325b7dd9f273c46e77fb7b337325880
-SHA256 (libopensync-plugin-synce-0.22.tar.bz2) = 72166c8c6e2a45f38fa260a3eb4920b3f55b3cb4cd04c29d6889b9411e369b57
-SIZE (libopensync-plugin-synce-0.22.tar.bz2) = 240364
+MD5 (libopensync-plugin-synce-rra-0.22.1.tar.gz) = c7a0a63b689d8d49ac86948699f1b79d
+SHA256 (libopensync-plugin-synce-rra-0.22.1.tar.gz) = 09d9e3dd3efc61968692f50e5a4db1e00f7c7cd6cdaef7d260241cf6fce34387
+SIZE (libopensync-plugin-synce-rra-0.22.1.tar.gz) = 299588
diff --git a/deskutils/libopensync-plugin-synce-legacy/files/patch-src_synce_file.c b/deskutils/libopensync-plugin-synce-legacy/files/patch-src_synce_file.c
index 5ca648bbef2d..7a3e6cad300a 100644
--- a/deskutils/libopensync-plugin-synce-legacy/files/patch-src_synce_file.c
+++ b/deskutils/libopensync-plugin-synce-legacy/files/patch-src_synce_file.c
@@ -9,58 +9,3 @@
osync_change_set_hash(change, hash);
fprintf(stderr, "%s(%s) hash %s\n", __func__, path, hash);
g_free(hash);
-@@ -220,7 +220,8 @@
- fileFormat *ff;
- WCHAR *wfn;
- DWORD wr, e, opt;
-- char *p, *s, *fn, *lfn, *str;
-+ char *p, *fn, *lfn, *str;
-+ const char *s;
- OSyncChangeType ct;
-
- osync_debug("SYNCE-SYNC", 4, "start: %s", __func__);
-@@ -495,7 +496,7 @@
- if (r == 0) {
- /* Error */
- DWORD e = CeGetLastError();
-- char *s = synce_strerror(e);
-+ const char *s = synce_strerror(e);
- osync_context_report_error(ctx, 1, "Error from CeReadFile (%d:%s)",
- e, s);
- CeCloseHandle(h);
-@@ -672,7 +673,7 @@
- &cnt, &find_data) == 0) {
- /* FIX ME what does failure mean here ? */
- e = CeGetLastError();
-- s = synce_strerror(e);
-+ s = (char*)synce_strerror(e);
- fprintf(stderr,
- "CeFindAllFiles(%s) : %s",
- lfn, s);
-@@ -686,7 +687,7 @@
- fprintf(stderr, "Yow create(%s)\n", lfn);
- if (CeCreateDirectory(w, NULL) == 0) {
- e = CeGetLastError();
-- s = synce_strerror(e);
-+ s = (char*)synce_strerror(e);
- fprintf(stderr,
- "CeCreateDirectory(%s) : %s",
- lfn, s);
-@@ -707,7 +708,7 @@
- CREATE_NEW, FILE_ATTRIBUTE_NORMAL, 0);
- if (h == 0) {
- e = CeGetLastError();
-- s = synce_strerror(e);
-+ s = (char*)synce_strerror(e);
- fprintf(stderr, "CeCreateFile(%s) : %s", lfn, s);
- free(lfn);
- return FALSE;
-@@ -719,7 +720,7 @@
- DWORD wr;
- if (CeWriteFile(h, "Yow", 3, &wr, NULL) == 0) {
- e = CeGetLastError();
-- s = synce_strerror(e);
-+ s = (char*)synce_strerror(e);
- fprintf(stderr, "CeWriteFile(%s) : %s", lfn, s);
- free(lfn);
- return FALSE;
diff --git a/deskutils/libopensync-plugin-synce-legacy/pkg-descr b/deskutils/libopensync-plugin-synce-legacy/pkg-descr
index 08081862948a..13141a55f3f7 100644
--- a/deskutils/libopensync-plugin-synce-legacy/pkg-descr
+++ b/deskutils/libopensync-plugin-synce-legacy/pkg-descr
@@ -1,4 +1,4 @@
This plugin allows applications using OpenSync to synchronise to and from
Windows Mobile 2003 based devices.
-WWW: http://www.opensync.org/
+WWW: http://www.synce.org/moin/