aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-12-29 19:09:51 +0800
committermiwi <miwi@FreeBSD.org>2009-12-29 19:09:51 +0800
commit224558a15cd9199946e20d7298e7e92e6f217865 (patch)
tree2fa351994e9cb2a6ec09e8d46a3e31e1e292b138 /deskutils
parent692ae94054f2be0e4da17b5a7318bab550855d9b (diff)
downloadfreebsd-ports-gnome-224558a15cd9199946e20d7298e7e92e6f217865.tar.gz
freebsd-ports-gnome-224558a15cd9199946e20d7298e7e92e6f217865.tar.zst
freebsd-ports-gnome-224558a15cd9199946e20d7298e7e92e6f217865.zip
- Update to 0.11.1
PR: 142048 Submitted by: Ashish SHUKLA <wahjava@gmail.com> (maintainer)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/google-gadgets/Makefile87
-rw-r--r--deskutils/google-gadgets/distinfo6
-rw-r--r--deskutils/google-gadgets/files/patch-configure.ac49
-rw-r--r--deskutils/google-gadgets/pkg-plist31
4 files changed, 106 insertions, 67 deletions
diff --git a/deskutils/google-gadgets/Makefile b/deskutils/google-gadgets/Makefile
index 99349f43d921..e97a6979c189 100644
--- a/deskutils/google-gadgets/Makefile
+++ b/deskutils/google-gadgets/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= google-gadgets
-PORTVERSION= 0.10.5
-PORTREVISION= 2
+PORTVERSION= 0.11.1
CATEGORIES= deskutils
MASTER_SITES= http://google-gadgets-for-linux.googlecode.com/files/
DISTNAME= ${PORTNAME}-for-linux-${PORTVERSION}
@@ -16,20 +15,19 @@ MAINTAINER= wahjava@gmail.com
COMMENT= Google Desktop Gadgets
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus \
- ${LOCALBASE}/libdata/pkgconfig/firefox-js.pc:${PORTSDIR}/www/firefox \
${LOCALBASE}/libdata/pkgconfig/libcurl.pc:${PORTSDIR}/ftp/curl \
${LOCALBASE}/libdata/pkgconfig/libxml-2.0.pc:${PORTSDIR}/textproc/libxml2 \
- ${LOCALBASE}/libdata/pkgconfig/firefox-gtkmozembed.pc:${PORTSDIR}/www/firefox \
${LOCALBASE}/libdata/pkgconfig/cairo.pc:${PORTSDIR}/graphics/cairo \
${LOCALBASE}/libdata/pkgconfig/librsvg-2.0.pc:${PORTSDIR}/graphics/librsvg2 \
+ ${LOCALBASE}/libdata/pkgconfig/libstartup-notification-1.0.pc:${PORTSDIR}/x11/startup-notification \
zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
xml2.5:${PORTSDIR}/textproc/libxml2 \
dbus-1.3:${PORTSDIR}/devel/dbus \
curl.5:${PORTSDIR}/ftp/curl \
- rsvg-2.2:${PORTSDIR}/graphics/librsvg2
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/firefox-js.pc:${PORTSDIR}/www/firefox \
- ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
+ rsvg-2.2:${PORTSDIR}/graphics/librsvg2 \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
USE_BZIP2= yes
USE_LDCONFIG= yes
@@ -37,8 +35,8 @@ USE_GMAKE= yes
USE_GCC= 4.2+
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" CPPFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-ltdl-install=no
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -Wno-deprecated-declarations" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-ltdl-install=no --with-browser-plugins-dir=${LOCALBASE}/lib/browser_plugins
USE_AUTOTOOLS= libtool:22:env autoconf:262:env automake:110:env aclocal:110:env libltdl:22
WANT_GNOME= yes
USE_GNOME= gnomehack
@@ -46,12 +44,44 @@ INSTALLS_ICONS= yes
OPTIONS= DEBUGGING "Enable debug output on runtime" on\
GTK "Build GTK Host" on\
- QT "Build Qt Host" on
+ QT "Build Qt Host" on\
+ GTKWEBKIT "Build with GTK Webkit support" on\
+ MOZILLA "Build with Mozilla support" on
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_QT)
+USE_QT_VER= 4
+QT_COMPONENTS= webkit opengl gui corelib script network moc_build
+.endif
+
+.if defined(WITH_GTKWEBKIT)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/webkit-1.0.pc:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS+= webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+.endif
+
+.if defined(WITH_MOZILLA)
+USE_GECKO= libxul firefox mozilla seamonkey xulrunner
+.endif
+
+.if defined(WITHOUT_GTKWEBKIT) && defined(WITHOUT_MOZILLA) && defined(WITH_GTK)
+IGNORE= gtk host requires GTK Webkit or/and Mozilla support to be enabled. Please, rerun 'make config'
+.elif defined(WITH_GTKWEBKIT) && defined(WITHOUT_GTK)
+.undef WITHOUT_GTK
+WITH_GTK=yes
+
+pre-everything::
+ @${ECHO_MSG} "==> GTK Webkit or/and Mozilla support is enabled."
+ @${ECHO_MSG} "==> Enabling GTK support. If this is not desired,"
+ @${ECHO_MSG} "==> please rerun 'make config'."
+.endif
.include <bsd.port.pre.mk>
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -Wno-deprecated-declarations"
+
.if ${OSVERSION} < 700000
-IGNORE=This port needs 7.X or higher
+IGNORE= needs 7.X or higher
.endif
.if defined(WITH_DEBUGGING)
@@ -60,13 +90,36 @@ CONFIGURE_ARGS+= --enable-debug
.if defined(WITHOUT_GTK)
PLIST_SUB+= GTK="@comment "
-CONFIGURE_ARGS+= --disable-gtk-host --disable-libggadget-gtk --disable-gtkmoz-browser-element --disable-gtk-system-framework
+CONFIGURE_ARGS+= --disable-gtk-host \
+ --disable-libggadget-gtk \
+ --disable-gtkmoz-browser-element \
+ --disable-gtk-system-framework \
+ --disable-webkit-script-runtime \
+ --disable-gtkwebkit-browser-element \
+ --disable-soup-xml-http-request
.elif defined(WITH_GTK)
USE_GNOME= gtk20
PLIST_SUB+= GTK=""
-CONFIGURE_ARGS+= --enable-gtk-host --with-gtkmozembed=firefox-gtkmozembed
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libstartup-notification-1.0.pc:${PORTSDIR}/x11/startup-notification
-LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+CONFIGURE_ARGS+= --enable-gtk-host
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libsoup-2.4.pc:${PORTSDIR}/devel/libsoup
+LIB_DEPENDS+= soup-2.4.1:${PORTSDIR}/devel/libsoup
+RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+CONFIGURE_ARGS+= --with-ssl-ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
+
+.endif
+
+.if defined(WITHOUT_GTKWEBKIT)
+PLIST_SUB+= GTKWEBKIT="@comment "
+CONFIGURE_ARGS+= --disable-webkit-script-runtime --disable-gtkwebkit-browser-element
+.elif defined(WITH_GTKWEBKIT)
+PLIST_SUB+= GTKWEBKIT=""
+.endif
+
+.if defined(WITHOUT_MOZILLA)
+PLIST_SUB+= MOZILLA="@comment "
+CONFIGURE_ARGS+= --disable-smjs-script-runtime --disable-gtkmoz-browser-element
+.elif defined(WITH_MOZILLA)
+PLIST_SUB+= MOZILLA=""
.endif
.if defined(WITHOUT_QT)
@@ -74,14 +127,12 @@ PLIST_SUB+= QT="@comment "
CONFIGURE_ARGS+= --disable-qt-host --disable-libggadget-qt --disable-qt-system-framework\
--disable-qtwebkit-browser-element --disable-qt-script-runtime --disable-qt-xml-http-request
.else
-USE_QT_VER= 4
-QT_COMPONENTS= webkit opengl gui corelib script network moc
PLIST_SUB+= QT=""
CONFIGURE_ARGS+= --enable-qt-host
.endif
.if defined(WITHOUT_QT) && defined(WITHOUT_GTK)
-IGNORE=This port requires GTK or Qt host to be enabled
+IGNORE= requires GTK or/and Qt host to be enabled. Please, rerun 'make config'
.endif
post-patch:
diff --git a/deskutils/google-gadgets/distinfo b/deskutils/google-gadgets/distinfo
index 4e553a433311..248045f8e3b4 100644
--- a/deskutils/google-gadgets/distinfo
+++ b/deskutils/google-gadgets/distinfo
@@ -1,3 +1,3 @@
-MD5 (google-gadgets-for-linux-0.10.5.tar.bz2) = fdad6bd761b6c603e457b5d0d92ec2f9
-SHA256 (google-gadgets-for-linux-0.10.5.tar.bz2) = 944810df4b134542a1e675e6d9518503466ce9398e8bfca5e3637d994ef5038d
-SIZE (google-gadgets-for-linux-0.10.5.tar.bz2) = 2429875
+MD5 (google-gadgets-for-linux-0.11.1.tar.bz2) = 62fec129694e83d0de481667e3c785d8
+SHA256 (google-gadgets-for-linux-0.11.1.tar.bz2) = 353eccec0b10bea3ee7cac7594d9c20af606484ba71f2e04df09f4ad78ce7dbe
+SIZE (google-gadgets-for-linux-0.11.1.tar.bz2) = 2531591
diff --git a/deskutils/google-gadgets/files/patch-configure.ac b/deskutils/google-gadgets/files/patch-configure.ac
index 6f3c2890ddda..5ae92595a1bb 100644
--- a/deskutils/google-gadgets/files/patch-configure.ac
+++ b/deskutils/google-gadgets/files/patch-configure.ac
@@ -3,9 +3,9 @@ $FreeBSD$
--- configure.ac.orig
+++ configure.ac
-@@ -422,6 +422,13 @@
- GGL_PLATFORM_SHORT="\"linux\""
+@@ -501,6 +501,13 @@
GGL_PLATFORM="\"linux\""
+ build_linux_system_framework=yes
;;
+ *freebsd* )
+ ggl_host_type=freebsd
@@ -17,7 +17,7 @@ $FreeBSD$
*solaris* )
ggl_host_type=solaris
PREDEFINED_MACROS="$PREDEFINED_MACROS -DGGL_HOST_SOLARIS=1"
-@@ -442,6 +449,7 @@
+@@ -526,6 +533,7 @@
AM_CONDITIONAL([GGL_HOST_MACOSX], [test x$ggl_host_type = xmacosx])
AM_CONDITIONAL([GGL_HOST_LINUX], [test x$ggl_host_type = xlinux])
AM_CONDITIONAL([GGL_HOST_SOLARIS], [test x$ggl_host_type = xsolaris])
@@ -25,41 +25,12 @@ $FreeBSD$
AC_SUBST(PREDEFINED_MACROS)
AC_SUBST(DEFAULT_COMPILE_FLAGS)
-@@ -558,7 +566,7 @@
- has_qtnetwork=no
+@@ -651,7 +659,7 @@
has_qtwebkit=no
has_qtscript=no
--if test x$ggl_host_type = xlinux; then
-+if test x$ggl_host_type = xlinux -o x$ggl_host_type = xfreebsd; then
- PKG_CHECK_MODULES(QT4, [QtGui >= 4.3 QtCore >= 4.3 QtNetwork >= 4.3],
- [has_qt4=yes
- MOC=`$PKG_CONFIG --variable=moc_location QtCore`],
-@@ -749,12 +757,12 @@
- [has_gtkmozembed=xulrunner-gtkmozembed],
- [has_gtkmozembed=no])
- ;;
-- firefox2)
-+ firefox2-gtkmozembed)
- PKG_CHECK_MODULES(GTKMOZEMBED, [firefox2-gtkmozembed],
- [has_gtkmozembed=firefox2-gtkmozembed],
- [has_gtkmozembed=no])
- ;;
-- firefox)
-+ firefox-gtkmozembed)
- PKG_CHECK_MODULES(GTKMOZEMBED, [firefox-gtkmozembed],
- [has_gtkmozembed=firefox-gtkmozembed],
- [has_gtkmozembed=no])
-@@ -783,11 +791,11 @@
- PKG_CHECK_MODULES(LIBMOZJS, [xulrunner-js],
- [has_libmozjs=xulrunner-js],
- [has_gtkmozembed=no]) ;;
-- firefox2)
-+ firefox2-gtkmozembed)
- PKG_CHECK_MODULES(LIBMOZJS, [firefox2-js],
- [has_libmozjs=firefox2-js],
- [has_gtkmozembed=no]) ;;
-- firefox)
-+ firefox-gtkmozembed)
- PKG_CHECK_MODULES(LIBMOZJS, [firefox-js],
- [has_libmozjs=firefox-js],
- [has_gtkmozembed=no]) ;;
+ if test x$build_libggadget_qt = xyes; then
+- if test x$ggl_host_type = xlinux; then
++ if test x$ggl_host_type = xlinux -o x$ggl_host_type = xfreebsd; then
+ PKG_CHECK_MODULES(QT4, [QtGui >= 4.3 QtCore >= 4.3 QtNetwork >= 4.3],
+ [has_qt4=yes
+ MOC=`$PKG_CONFIG --variable=moc_location QtCore`],
diff --git a/deskutils/google-gadgets/pkg-plist b/deskutils/google-gadgets/pkg-plist
index 464300335392..e220c9d4b597 100644
--- a/deskutils/google-gadgets/pkg-plist
+++ b/deskutils/google-gadgets/pkg-plist
@@ -62,6 +62,7 @@ include/google-gadgets/ggadget/item_element.h
include/google-gadgets/ggadget/js/js_utils.h
include/google-gadgets/ggadget/js/jscript_massager.h
include/google-gadgets/ggadget/label_element.h
+include/google-gadgets/ggadget/light_map.h
include/google-gadgets/ggadget/listbox_element.h
include/google-gadgets/ggadget/locales.h
include/google-gadgets/ggadget/localized_file_manager.h
@@ -136,7 +137,7 @@ include/google-gadgets/ggadget/xml_http_request_utils.h
include/google-gadgets/ggadget/xml_parser_interface.h
include/google-gadgets/ggadget/xml_utils.h
include/google-gadgets/ggadget/zip_file_manager.h
-%%GTK%%lib/google-gadgets/gtkmoz-browser-child
+%%GTK%%%%MOZILLA%%lib/google-gadgets/gtkmoz-browser-child
lib/google-gadgets/include/ggadget/sysdeps.h
lib/google-gadgets/modules/analytics-usage-collector.a
lib/google-gadgets/modules/analytics-usage-collector.la
@@ -171,9 +172,15 @@ lib/google-gadgets/modules/gst-video-element.so
%%GTK%%lib/google-gadgets/modules/gtk-system-framework.a
%%GTK%%lib/google-gadgets/modules/gtk-system-framework.la
%%GTK%%lib/google-gadgets/modules/gtk-system-framework.so
-%%GTK%%lib/google-gadgets/modules/gtkmoz-browser-element.a
-%%GTK%%lib/google-gadgets/modules/gtkmoz-browser-element.la
-%%GTK%%lib/google-gadgets/modules/gtkmoz-browser-element.so
+%%GTK%%%%MOZILLA%%lib/google-gadgets/modules/gtkmoz-browser-element.a
+%%GTK%%%%MOZILLA%%lib/google-gadgets/modules/gtkmoz-browser-element.la
+%%GTK%%%%MOZILLA%%lib/google-gadgets/modules/gtkmoz-browser-element.so
+%%GTKWEBKIT%%lib/google-gadgets/modules/gtkwebkit-browser-element.a
+%%GTKWEBKIT%%lib/google-gadgets/modules/gtkwebkit-browser-element.la
+%%GTKWEBKIT%%lib/google-gadgets/modules/gtkwebkit-browser-element.so
+lib/google-gadgets/modules/html-flash-element.a
+lib/google-gadgets/modules/html-flash-element.la
+lib/google-gadgets/modules/html-flash-element.so
lib/google-gadgets/modules/libxml2-xml-parser.a
lib/google-gadgets/modules/libxml2-xml-parser.la
lib/google-gadgets/modules/libxml2-xml-parser.so
@@ -192,9 +199,15 @@ lib/google-gadgets/modules/libxml2-xml-parser.so
%%QT%%lib/google-gadgets/modules/qtwebkit-browser-element.a
%%QT%%lib/google-gadgets/modules/qtwebkit-browser-element.la
%%QT%%lib/google-gadgets/modules/qtwebkit-browser-element.so
-lib/google-gadgets/modules/smjs-script-runtime.a
-lib/google-gadgets/modules/smjs-script-runtime.la
-lib/google-gadgets/modules/smjs-script-runtime.so
+%%MOZILLA%%lib/google-gadgets/modules/smjs-script-runtime.a
+%%MOZILLA%%lib/google-gadgets/modules/smjs-script-runtime.la
+%%MOZILLA%%lib/google-gadgets/modules/smjs-script-runtime.so
+%%GTK%%lib/google-gadgets/modules/soup-xml-http-request.a
+%%GTK%%lib/google-gadgets/modules/soup-xml-http-request.la
+%%GTK%%lib/google-gadgets/modules/soup-xml-http-request.so
+%%GTKWEBKIT%%lib/google-gadgets/modules/webkit-script-runtime.a
+%%GTKWEBKIT%%lib/google-gadgets/modules/webkit-script-runtime.la
+%%GTKWEBKIT%%lib/google-gadgets/modules/webkit-script-runtime.so
lib/libggadget-1.0.a
lib/libggadget-1.0.la
lib/libggadget-1.0.so
@@ -219,6 +232,10 @@ lib/libggadget-npapi-1.0.so.0
%%QT%%lib/libggadget-qt-1.0.la
%%QT%%lib/libggadget-qt-1.0.so
%%QT%%lib/libggadget-qt-1.0.so.0
+%%GTKWEBKIT%%lib/libggadget-webkitjs-1.0.a
+%%GTKWEBKIT%%lib/libggadget-webkitjs-1.0.la
+%%GTKWEBKIT%%lib/libggadget-webkitjs-1.0.so
+%%GTKWEBKIT%%lib/libggadget-webkitjs-1.0.so.0
lib/libggadget-xdg-1.0.a
lib/libggadget-xdg-1.0.la
lib/libggadget-xdg-1.0.so