aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2016-09-07 17:06:22 +0800
committerehaupt <ehaupt@FreeBSD.org>2016-09-07 17:06:22 +0800
commit2ea836d9b852d34808c899223c62dadeccda1374 (patch)
tree10bde3c2cec3d3925655e541426eeb1807815f88 /deskutils
parent00380ba6d1edf7ba16304ac8979b86c2be78b8d1 (diff)
downloadfreebsd-ports-gnome-2ea836d9b852d34808c899223c62dadeccda1374.tar.gz
freebsd-ports-gnome-2ea836d9b852d34808c899223c62dadeccda1374.tar.zst
freebsd-ports-gnome-2ea836d9b852d34808c899223c62dadeccda1374.zip
- Update to 0.3.1
- Add patch for Gtk+ < 3.20 otherwise daemon is not launched PR: 212425 Submitted by: olivierd
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/xfce4-notifyd/Makefile5
-rw-r--r--deskutils/xfce4-notifyd/distinfo6
-rw-r--r--deskutils/xfce4-notifyd/files/patch-xfce4-notifyd_xfce-notify-daemon.c10
3 files changed, 15 insertions, 6 deletions
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index 07afbad5f358..62e90467b3bb 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -6,10 +6,9 @@
# Support of GTK+ is checked at compile time and themes directories too.
PORTNAME= xfce4-notifyd
-PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTVERSION= 0.3.1
CATEGORIES= deskutils xfce
-MASTER_SITES= http://errements.eu/distfiles/
+MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= ehaupt@FreeBSD.org
diff --git a/deskutils/xfce4-notifyd/distinfo b/deskutils/xfce4-notifyd/distinfo
index f4d7b5d7dfdc..8c50a43ab9e6 100644
--- a/deskutils/xfce4-notifyd/distinfo
+++ b/deskutils/xfce4-notifyd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1469828988
-SHA256 (xfce4/xfce4-notifyd-0.3.0.tar.bz2) = 7ea9b67cd3fa8426d67d39ee78a6ecd4f70353c73ba140a98b84a5d8a16c313f
-SIZE (xfce4/xfce4-notifyd-0.3.0.tar.bz2) = 419435
+TIMESTAMP = 1473189353
+SHA256 (xfce4/xfce4-notifyd-0.3.1.tar.bz2) = ef02b7e0101034df19ca5dddae387a2625e46380f0d2af3b4f4713c219d1f863
+SIZE (xfce4/xfce4-notifyd-0.3.1.tar.bz2) = 429056
diff --git a/deskutils/xfce4-notifyd/files/patch-xfce4-notifyd_xfce-notify-daemon.c b/deskutils/xfce4-notifyd/files/patch-xfce4-notifyd_xfce-notify-daemon.c
new file mode 100644
index 000000000000..79e554f94156
--- /dev/null
+++ b/deskutils/xfce4-notifyd/files/patch-xfce4-notifyd_xfce-notify-daemon.c
@@ -0,0 +1,10 @@
+--- xfce4-notifyd/xfce-notify-daemon.c.orig 2016-09-06 13:19:50 UTC
++++ xfce4-notifyd/xfce-notify-daemon.c
+@@ -706,6 +706,7 @@ xfce_notify_daemon_window_size_allocate(
+ widget_screen = gtk_widget_get_screen (widget);
+ display = gdk_screen_get_display (widget_screen);
+ device_manager = gdk_display_get_device_manager (display);
++ pointer = gdk_device_manager_get_client_pointer (device_manager);
+ #endif
+
+ gdk_device_get_position (pointer, &p_screen, &x, &y);