aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2015-09-21 20:29:36 +0800
committerjunovitch <junovitch@FreeBSD.org>2015-09-21 20:29:36 +0800
commit534d6ffff9daa0ad23421405c3f5a0b8c45756a2 (patch)
tree6625c0f9feeca51506c0a8e8c163c23cbc551214 /deskutils
parentdc7eb487f553be2d8b9126c1dbe1e17ad2016fc3 (diff)
downloadfreebsd-ports-gnome-534d6ffff9daa0ad23421405c3f5a0b8c45756a2.tar.gz
freebsd-ports-gnome-534d6ffff9daa0ad23421405c3f5a0b8c45756a2.tar.zst
freebsd-ports-gnome-534d6ffff9daa0ad23421405c3f5a0b8c45756a2.zip
deskutils/owncloudclient: update 1.8.4 -> 2.0.1
- Pass maintainer from ports@ to PR submitter - Regenerate a patch for 2.0.1 PR: 203167 Submitted by: Yonas Yanfa <yonas@fizk.net>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/owncloudclient/Makefile4
-rw-r--r--deskutils/owncloudclient/distinfo4
-rw-r--r--deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp10
3 files changed, 9 insertions, 9 deletions
diff --git a/deskutils/owncloudclient/Makefile b/deskutils/owncloudclient/Makefile
index 9e3c4a5899f2..4034450697df 100644
--- a/deskutils/owncloudclient/Makefile
+++ b/deskutils/owncloudclient/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= owncloudclient
-PORTVERSION= 1.8.4
+PORTVERSION= 2.0.1
CATEGORIES= deskutils
MASTER_SITES= http://download.owncloud.com/desktop/stable/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= yonas@fizk.net
COMMENT= OwnCloud Desktop Syncing Client
LICENSE= GPLv2
diff --git a/deskutils/owncloudclient/distinfo b/deskutils/owncloudclient/distinfo
index 68d8b1759338..7f24cd5630e5 100644
--- a/deskutils/owncloudclient/distinfo
+++ b/deskutils/owncloudclient/distinfo
@@ -1,2 +1,2 @@
-SHA256 (owncloudclient-1.8.4.tar.xz) = ebe5ec7e33de6f2072bcadcd2b316a09b9d583d7d41eb1caf467a48896d81cdb
-SIZE (owncloudclient-1.8.4.tar.xz) = 11371640
+SHA256 (owncloudclient-2.0.1.tar.xz) = 97e8fe888b8f59b0703fd9fbd54feecbf14c078ac14e9856bf0327f2b41bc287
+SIZE (owncloudclient-2.0.1.tar.xz) = 11737332
diff --git a/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp b/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
index 33e0851414aa..413d71f68946 100644
--- a/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
+++ b/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
@@ -1,14 +1,14 @@
---- src/gui/generalsettings.cpp.orig 2015-03-16 14:28:58 UTC
+--- src/gui/generalsettings.cpp.orig 2015-09-01 13:50:21 UTC
+++ src/gui/generalsettings.cpp
-@@ -85,6 +85,7 @@ void GeneralSettings::loadMiscSettings()
+@@ -105,6 +105,7 @@ void GeneralSettings::loadMiscSettings()
void GeneralSettings::slotUpdateInfo()
{
+#if 0
- if (OCUpdater *updater = dynamic_cast<OCUpdater*>(Updater::instance()))
- {
+ if (OCUpdater *updater = dynamic_cast<OCUpdater*>(Updater::instance())) {
connect(updater, SIGNAL(downloadStateChanged()), SLOT(slotUpdateInfo()), Qt::UniqueConnection);
-@@ -93,9 +94,12 @@ void GeneralSettings::slotUpdateInfo()
+ connect(_ui->restartButton, SIGNAL(clicked()), updater, SLOT(slotStartInstaller()), Qt::UniqueConnection);
+@@ -112,9 +113,12 @@ void GeneralSettings::slotUpdateInfo()
_ui->updateStateLabel->setText(updater->statusString());
_ui->restartButton->setVisible(updater->downloadState() == OCUpdater::DownloadComplete);
} else {