aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-01-13 02:05:12 +0800
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-01-13 02:05:12 +0800
commit5843946ac4b694035b04ca9af0cb8df85eb7cac2 (patch)
treeb8e63f0a05601d45876592f6bf4089537ec372a5 /deskutils
parent37d288db3aff5ee82e0cdfb5a55044e5dfa211d3 (diff)
downloadfreebsd-ports-gnome-5843946ac4b694035b04ca9af0cb8df85eb7cac2.tar.gz
freebsd-ports-gnome-5843946ac4b694035b04ca9af0cb8df85eb7cac2.tar.zst
freebsd-ports-gnome-5843946ac4b694035b04ca9af0cb8df85eb7cac2.zip
deskutils/ical: update to 2.3.1
PR: 242969 Submitted by: fbsd@opal.com (maintainer)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/ical/Makefile15
-rw-r--r--deskutils/ical/distinfo5
-rw-r--r--deskutils/ical/files/patch-cal_tcl.C9
-rw-r--r--deskutils/ical/files/patch-config.h.in36
-rw-r--r--deskutils/ical/files/patch-configure18
-rw-r--r--deskutils/ical/files/patch-dateeditor.C9
-rw-r--r--deskutils/ical/files/patch-dispatch.C2
-rw-r--r--deskutils/ical/files/patch-ical.h30
-rw-r--r--deskutils/ical/files/patch-item_tcl.C47
-rw-r--r--deskutils/ical/files/patch-pref.tcl19
-rw-r--r--deskutils/ical/files/pkg-message.in4
-rw-r--r--deskutils/ical/pkg-descr28
-rw-r--r--deskutils/ical/pkg-plist123
13 files changed, 144 insertions, 201 deletions
diff --git a/deskutils/ical/Makefile b/deskutils/ical/Makefile
index 9c08823271b8..c31a353ec161 100644
--- a/deskutils/ical/Makefile
+++ b/deskutils/ical/Makefile
@@ -2,18 +2,19 @@
# $FreeBSD$
PORTNAME= ical
-PORTVERSION= 2.2
-PORTREVISION= 5
+PORTVERSION= 2.3.1
CATEGORIES= deskutils tk
MASTER_SITES= http://opal.com/jr/ical/
-PATCH_SITES= http://www.isi.edu/~johnh/SOFTWARE/ICAL/
+PATCH_SITES= http://www.isi.edu/~johnh/SOFTWARE/ICAL/ \
+ http://opal.com/jr/ical/
PATCHFILES= ical-2.3.1-upvar.patch
MAINTAINER= fbsd@opal.com
COMMENT= Calendar application
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT.GNU
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
@@ -27,12 +28,18 @@ CONFIGURE_ARGS= --with-tclconfig=${TCL_LIBDIR} \
--with-tkconfig=${TK_LIBDIR} \
--with-tkhdir=${TK_INCLUDEDIR}
MAKE_ENV= STAGEDIR=${STAGEDIR}
+SUB_FILES= pkg-message
+SUB_LIST+= VERSION=${VERSION}
+
+USER_TCL= ${HOME}/.tk/${PORTNAME}/user.tcl
+VERSION= ${PORTVERSION:C/([0-9]+\.[0-9]+)(\.[0-9]+)*/\1/}
+DIST_VER= ${DISTNAME:S/${PORTVERSION}/${VERSION}/}
post-patch:
@${REINPLACE_CMD} -e 's,tcl->result,Tcl_GetStringResult(tcl),' \
${WRKSRC}/ical.C
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${DISTNAME}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${DIST_VER}
.include <bsd.port.mk>
diff --git a/deskutils/ical/distinfo b/deskutils/ical/distinfo
index f630c3af7491..58411cb72d02 100644
--- a/deskutils/ical/distinfo
+++ b/deskutils/ical/distinfo
@@ -1,4 +1,5 @@
-SHA256 (ical-2.2.tar.gz) = b0e4e7c82f98e1798e248c5df1ebd6970a257a774da3d5bee9ce0fd5a3f6734f
-SIZE (ical-2.2.tar.gz) = 284609
+TIMESTAMP = 1576875998
+SHA256 (ical-2.3.1.tar.gz) = eeb7c6b8a8a36e9fe4cc5fb30dc9bb504e84d11b24fa295870e149fd89f71abd
+SIZE (ical-2.3.1.tar.gz) = 264576
SHA256 (ical-2.3.1-upvar.patch) = 7b74f6f8011847e0cb1a0691674c0f89fe96b4296cd8891cf66867dc1627c0a0
SIZE (ical-2.3.1-upvar.patch) = 4533
diff --git a/deskutils/ical/files/patch-cal_tcl.C b/deskutils/ical/files/patch-cal_tcl.C
index 0407a6297d74..dfb62ad94262 100644
--- a/deskutils/ical/files/patch-cal_tcl.C
+++ b/deskutils/ical/files/patch-cal_tcl.C
@@ -49,15 +49,6 @@
{ 0, 0, 0, 0 }
};
-@@ -281,7 +281,7 @@ static int parse_items(Tcl_Interp* tcl, Calendar_Tcl*
-
- if ((argc >= 2) && (strcmp(argv[0], "-items") == 0)) {
- int count;
-- char** list;
-+ CONST84 char** list;
- if (Tcl_SplitList(tcl, argv[1], &count, &list) != TCL_OK) {
- TCL_Error(tcl, "invalid item list");
- }
@@ -516,7 +516,7 @@ static int cal_ronly(ClientData c, Tcl_Interp* tcl, in
TCL_Error(tcl, "no such calendar");
}
diff --git a/deskutils/ical/files/patch-config.h.in b/deskutils/ical/files/patch-config.h.in
index c420c5be8366..4f495bb2519b 100644
--- a/deskutils/ical/files/patch-config.h.in
+++ b/deskutils/ical/files/patch-config.h.in
@@ -1,43 +1,23 @@
---- config.h.in.orig 1995-07-02 22:12:55 UTC
+--- config.h.in.orig 2004-03-11 11:26:55 UTC
+++ config.h.in
-@@ -5,26 +5,26 @@
+@@ -5,14 +5,14 @@
#undef pid_t
#undef SIZEOF_LONG
-#undef HAVE_STRING_H
-#undef HAVE_LIMITS_H
-+#define HAVE_STRING_H 1
-+#define HAVE_LIMITS_H 1
++#define HAVE_STRING_H 1
++#define HAVE_LIMITS_H 1
-#undef HAVE_FSYNC
-+#define HAVE_FSYNC 1
++#define HAVE_FSYNC 1
-#undef HAVE_STRERROR
--#undef HAVE_STRERROR_PROTO
--#undef HAVE_SYS_ERRLIST_PROTO
-+#define HAVE_STRERROR 1
-+#define HAVE_STRERROR_PROTO 1
-+#define HAVE_SYS_ERRLIST_PROTO 1
-
--#undef HAVE_GETTIMEOFDAY_PROTO
-+#define HAVE_GETTIMEOFDAY_PROTO 1
-
--#undef HAVE_GETHOSTID
--#undef HAVE_GETHOSTID_PROTO
-+#define HAVE_GETHOSTID 1
-+#define HAVE_GETHOSTID_PROTO 1
++#define HAVE_STRERROR 1
-#undef HAVE_UNAME
-#undef HAVE_SYS_UTSNAME_H
--#undef HAVE_GETHOSTNAME_PROTO
-+#define HAVE_UNAME 1
-+#define HAVE_SYS_UTSNAME_H 1
-+#define HAVE_GETHOSTNAME_PROTO 1
-
--#undef HAVE_GETPID_PROTO
-+#define HAVE_GETPID_PROTO 1
-
--#undef HAVE_STRNCASECMP_PROTO
-+#define HAVE_STRNCASECMP_PROTO 1
++#define HAVE_UNAME 1
++#define HAVE_SYS_UTSNAME_H 1
#endif /* _CONFIG_H_IN */
diff --git a/deskutils/ical/files/patch-configure b/deskutils/ical/files/patch-configure
index d8350a9b153b..a1c2c1493cd9 100644
--- a/deskutils/ical/files/patch-configure
+++ b/deskutils/ical/files/patch-configure
@@ -1,17 +1,17 @@
---- configure.orig 1999-08-06 23:07:54 UTC
+--- configure.orig 2004-03-11 11:26:55 UTC
+++ configure
-@@ -1204,8 +1204,8 @@ fi
+@@ -1208,8 +1208,8 @@
echo "checking Tcl/Tk installation" 1>&6
- echo "configure:1207: checking Tcl/Tk installation" >&5
--legal_tk_versions="8.0 4.9 4.8 4.7 4.6 4.5 4.4 4.3 4.2 4.1"
--legal_tcl_versions="8.0 7.9 7.8 7.7 7.6 7.5"
-+legal_tk_versions="8.5 8.4 8.3 8.2 8.0 4.9 4.8 4.7 4.6 4.5 4.4 4.3 4.2 4.1"
-+legal_tcl_versions="8.5 8.4 8.3 8.2 8.0 7.9 7.8 7.7 7.6 7.5"
+ echo "configure:1211: checking Tcl/Tk installation" >&5
+-legal_tk_versions="8.4 8.3 8.2 8.0 4.9 4.8 4.7 4.6 4.5 4.4 4.3 4.2 4.1"
+-legal_tcl_versions="8.4 8.3 8.2 8.0 7.9 7.8 7.7 7.6 7.5"
++legal_tk_versions="8.6 8.5 8.4 8.3 8.2 8.0 4.9 4.8 4.7 4.6 4.5 4.4 4.3 4.2 4.1"
++legal_tcl_versions="8.6 8.5 8.4 8.3 8.2 8.0 7.9 7.8 7.7 7.6 7.5"
#### Find tclsh
# Check whether --with-tclsh or --without-tclsh was given.
-@@ -1327,6 +1327,8 @@ echo "$ac_t""$tkconfig/tkConfig.sh" 1>&6
+@@ -1331,6 +1331,8 @@
#### Load the Tcl/Tk configuration files
. $tclconfig/tclConfig.sh
. $tkconfig/tkConfig.sh
@@ -20,7 +20,7 @@
if test -z "$TCL_EXEC_PREFIX"; then TCL_EXEC_PREFIX="$TCL_PREFIX"; fi
if test -z "$TK_EXEC_PREFIX"; then TK_EXEC_PREFIX="$TK_PREFIX"; fi
-@@ -1517,8 +1519,7 @@ cat > conftest.$ac_ext <<EOF
+@@ -1521,8 +1523,7 @@
good_tk_version
#endif
EOF
diff --git a/deskutils/ical/files/patch-dateeditor.C b/deskutils/ical/files/patch-dateeditor.C
index 4b468612a8aa..8cfdbf1b1cfa 100644
--- a/deskutils/ical/files/patch-dateeditor.C
+++ b/deskutils/ical/files/patch-dateeditor.C
@@ -1,14 +1,5 @@
--- dateeditor.C.orig 1996-02-10 03:17:35 UTC
+++ dateeditor.C
-@@ -113,7 +113,7 @@ int Cmd_HiliteLoop(ClientData, Tcl_Interp* tcl, int ar
- }
-
- int count;
-- char** strlist;
-+ CONST84 char** strlist;
- if (Tcl_SplitList(tcl, argv[2], &count, &strlist) != TCL_OK) {
- return TCL_ERROR;
- }
@@ -146,14 +146,14 @@ int Cmd_HiliteLoop(ClientData, Tcl_Interp* tcl, int ar
if (!contains(hlist, hilite)) hilite = "always";
diff --git a/deskutils/ical/files/patch-dispatch.C b/deskutils/ical/files/patch-dispatch.C
index c17179d4a512..9f6fa7f97e37 100644
--- a/deskutils/ical/files/patch-dispatch.C
+++ b/deskutils/ical/files/patch-dispatch.C
@@ -5,7 +5,7 @@
TCL_Error(tcl, "too many arguments");
}
- return entry->handler(c, tcl, argc, argv);
-+ return entry->handler(c, tcl, argc, (CONST84 char **)argv);
++ return entry->handler(c, tcl, argc, (const char **)argv);
}
}
diff --git a/deskutils/ical/files/patch-ical.h b/deskutils/ical/files/patch-ical.h
deleted file mode 100644
index 00178e6f9835..000000000000
--- a/deskutils/ical/files/patch-ical.h
+++ /dev/null
@@ -1,30 +0,0 @@
---- ical.h.orig 1996-02-10 03:17:36 UTC
-+++ ical.h
-@@ -4,6 +4,11 @@
-
- #include <tcl.h>
-
-+// That was introduced in tcl8.4
-+#ifndef CONST84
-+#define CONST84
-+#endif
-+
- // Proc for triggering tcl code based on changes
- // to calendars/items.
-
-@@ -25,13 +30,13 @@ extern void trigger(Tcl_Interp*, char const* ttype, ch
-
- #define TCL_Return(tcl,str) \
- do { \
-- Tcl_SetResult(tcl, (str), TCL_STATIC); \
-+ Tcl_SetResult(tcl, ((char *)(str)), TCL_STATIC); \
- return TCL_OK; \
- } while (0)
-
- #define TCL_Error(tcl,str) \
- do { \
-- Tcl_SetResult(tcl, (str), TCL_STATIC); \
-+ Tcl_SetResult(tcl, ((char *)(str)), TCL_STATIC); \
- return TCL_ERROR; \
- } while (0)
-
diff --git a/deskutils/ical/files/patch-item_tcl.C b/deskutils/ical/files/patch-item_tcl.C
index 27fcf11db70c..5e86f35ee813 100644
--- a/deskutils/ical/files/patch-item_tcl.C
+++ b/deskutils/ical/files/patch-item_tcl.C
@@ -1,7 +1,7 @@
---- item_tcl.C.orig 1996-08-01 19:25:10 UTC
+--- item_tcl.C.orig 2004-03-11 11:26:56 UTC
+++ item_tcl.C
-@@ -106,52 +106,52 @@ static int item_mweekday (ClientData, Tcl_Interp*, int
- static int item_mlweekday (ClientData, Tcl_Interp*, int, char*[]);
+@@ -106,52 +106,52 @@
+ static int item_mlweekday (ClientData, Tcl_Interp*, int, const char*[]);
static Dispatch_Entry item_dispatch[] = {
- { "delete", 0, 0, item_delete },
@@ -93,40 +93,31 @@
{ 0, 0, 0, 0 }
};
-@@ -329,7 +329,7 @@ static int item_owner(ClientData c, Tcl_Interp* tcl, i
+@@ -329,7 +329,7 @@
- static int item_owned(ClientData c, Tcl_Interp* tcl, int argc, char* argv[]) {
+ static int item_owned(ClientData c, Tcl_Interp* tcl, int argc, const char* argv[]) {
Item_Tcl* item = (Item_Tcl*) c;
- TCL_Return(tcl, (item->value()->IsMine() ? "1" : "0"));
+ TCL_Return(tcl, (item->value()->IsMine() ? (char *)"1" : (char *)"0"));
}
- static int item_own(ClientData c, Tcl_Interp* tcl, int argc, char* argv[]) {
-@@ -431,7 +431,7 @@ static int item_alarms(ClientData c, Tcl_Interp* tcl,
- }
-
- int count;
-- char** list;
-+ CONST84 char** list;
- if (Tcl_SplitList(tcl, argv[0], &count, &list) != TCL_OK) {
- TCL_Error(tcl, "invalid alarm list");
- }
-@@ -492,12 +492,12 @@ static int item_doption(ClientData c, Tcl_Interp* tcl,
+ static int item_own(ClientData c, Tcl_Interp* tcl, int argc, const char* argv[]) {
+@@ -492,12 +492,12 @@
- static int item_empty(ClientData c, Tcl_Interp* tcl, int argc, char* argv[]) {
+ static int item_empty(ClientData c, Tcl_Interp* tcl, int argc, const char* argv[]) {
Item_Tcl* item = (Item_Tcl*) c;
- TCL_Return(tcl, (item->value()->empty()?"1":"0"));
-+ TCL_Return(tcl, (item->value()->empty() ? (char *)"1" : (char *)"0"));
++ TCL_Return(tcl, (item->value()->empty() ? (char *) "1" : (char *) "0"));
}
- static int item_repeat(ClientData c, Tcl_Interp* tcl, int argc, char* argv[]) {
+ static int item_repeat(ClientData c, Tcl_Interp* tcl, int argc, const char* argv[]) {
Item_Tcl* item = (Item_Tcl*) c;
- TCL_Return(tcl,(item->value()->repeats()?"1":"0"));
-+ TCL_Return(tcl,(item->value()->repeats() ? (char *)"1" : (char *)"0"));
++ TCL_Return(tcl,(item->value()->repeats() ? (char *) "1" : (char *) "0"));
}
- static int item_first(ClientData c, Tcl_Interp* tcl, int argc, char* argv[]) {
-@@ -508,7 +508,7 @@ static int item_first(ClientData c, Tcl_Interp* tcl, i
+ static int item_first(ClientData c, Tcl_Interp* tcl, int argc, const char* argv[]) {
+@@ -508,7 +508,7 @@
}
char buffer[100];
@@ -135,7 +126,7 @@
Tcl_SetResult(tcl, buffer, TCL_VOLATILE);
return TCL_OK;
}
-@@ -518,43 +518,43 @@ static int item_type(ClientData c, Tcl_Interp* tcl, in
+@@ -518,43 +518,43 @@
char* result;
switch (item->value()->repeat_type()) {
case DateSet::None:
@@ -192,7 +183,7 @@
break;
}
TCL_Return(tcl, result);
-@@ -576,7 +576,7 @@ static int item_cont(ClientData c, Tcl_Interp* tcl, in
+@@ -576,7 +576,7 @@
TCL_Error(tcl, "invalid date");
}
Date date(dateDays);
@@ -200,8 +191,8 @@
+ TCL_Return(tcl, (item->value()->contains(date) ? (char *)"1" : (char *)"0"));
}
- static int item_next(ClientData c, Tcl_Interp* tcl, int argc, char* argv[]) {
-@@ -592,7 +592,7 @@ static int item_next(ClientData c, Tcl_Interp* tcl, in
+ static int item_next(ClientData c, Tcl_Interp* tcl, int argc, const char* argv[]) {
+@@ -592,7 +592,7 @@
}
char buffer[100];
@@ -210,7 +201,7 @@
Tcl_SetResult(tcl, buffer, TCL_VOLATILE);
return TCL_OK;
}
-@@ -603,10 +603,10 @@ static int item_range(ClientData c, Tcl_Interp* tcl, i
+@@ -603,10 +603,10 @@
Date s, f;
if (item->value()->range(s, f)) {
char buffer[100];
@@ -223,7 +214,7 @@
if (Tcl_SetVar(tcl, argv[1], buffer, 0) == NULL)
TCL_Error(tcl, "could not set range finish variable");
TCL_Return(tcl, "1");
-@@ -886,7 +886,7 @@ static int check_permission(Tcl_Interp* tcl, Item_Tcl*
+@@ -886,7 +886,7 @@
if (file == 0) return 1;
if (file->GetCalendar()->ReadOnly()) {
diff --git a/deskutils/ical/files/patch-pref.tcl b/deskutils/ical/files/patch-pref.tcl
index 401744d734a3..207decfd57d6 100644
--- a/deskutils/ical/files/patch-pref.tcl
+++ b/deskutils/ical/files/patch-pref.tcl
@@ -1,16 +1,23 @@
---- pref.tcl.orig 1997-06-12 22:50:36 UTC
+--- pref.tcl.orig 2004-03-11 11:26:56 UTC
+++ pref.tcl
-@@ -118,7 +118,12 @@ proc pref_init {} {
+@@ -116,10 +116,16 @@
+ }
+
# XXX People do not seem to like the motif-style popup behavior
- global tk_strictMotif
- if {!$tk_strictMotif} {
-- bind Menubutton <Any-ButtonRelease-1> {tkMenuUnpost {}}
+-# global tk_strictMotif
+-# if {!$tk_strictMotif} {
+-# bind Menubutton <Any-ButtonRelease-1> {tkMenuUnpost {}}
+-# }
++ global tk_strictMotif
++ if {!$tk_strictMotif} {
++ bind Menubutton <Any-ButtonRelease-1> {tkMenuUnpost {}}
+ set tv [info tclversion]
+ if {[package vcompare $tv 8.4] >= 0} {
+ bind Menubutton <Any-ButtonRelease-1> {::tk::MenuUnpost {}}
+ } else {
+ bind Menubutton <Any-ButtonRelease-1> {tkMenuUnpost {}}
+ }
- }
++ }
# Handle command line preferences
+ global ical
diff --git a/deskutils/ical/files/pkg-message.in b/deskutils/ical/files/pkg-message.in
new file mode 100644
index 000000000000..beed912d8bd6
--- /dev/null
+++ b/deskutils/ical/files/pkg-message.in
@@ -0,0 +1,4 @@
+Ical has been updated to version %%VERSION%%.
+
+Any users who source Ical code in their ~/.tk/ical/user.tcl file
+should update the file paths to "%%PREFIX%%/lib/ical/v%%VERSION%%/".
diff --git a/deskutils/ical/pkg-descr b/deskutils/ical/pkg-descr
index 661be14aacfc..938c2b898e1d 100644
--- a/deskutils/ical/pkg-descr
+++ b/deskutils/ical/pkg-descr
@@ -1,17 +1,17 @@
-Copyright (c) 1993-1997 by Sanjay Ghemawat
+Ical is an X based calendar program.
- * Ical is an X based calendar program
- * Calendar items can be created edited and deleted easily.
- * Items can be made to repeat in various ways.
- * Ical will post reminders for upcoming appointments.
- * Ical can print and list item occurrences.
- * An ical calendar can include other calendars.
- * Ical calendars can be shared by different users.
+* Calendar items can be created edited and deleted easily.
+* Items can be made to repeat in various ways.
+* Ical will post reminders for upcoming appointments.
+* Ical can print and list item occurrences.
+* An ical calendar can include other calendars.
+* Ical calendars can be shared by different users.
-Copyrights
-==========
+This software was developed by the original author, Sanjay Ghemawat
+from 1993-1997. His last version was v2.2. As system developments
+warranted it, other folks published patches and maintenance releases
+in order to keep Ical working. Version v2.3.1 is such a release.
-Most of the files are covered by the copyright in the file COPYRIGHT.
-
-The configure script is covered by the GNU Public License (see
-COPYRIGHT.GNU).
+WWW: http://opal.com/jr/ical/
+WWW: http://www.isi.edu/~johnh/SOFTWARE/ICAL/
+#WWW: ftp://ftp.sunet.se/pub/vendor/sco/skunkware/src/shellutil/
diff --git a/deskutils/ical/pkg-plist b/deskutils/ical/pkg-plist
index 4f7116d40d95..c5d707c8ef41 100644
--- a/deskutils/ical/pkg-plist
+++ b/deskutils/ical/pkg-plist
@@ -1,63 +1,64 @@
bin/ical
-bin/ical-2.2
+bin/ical-2.3
+lib/ical/v2.3/actions.tcl
+lib/ical/v2.3/alarm.tcl
+lib/ical/v2.3/apptlist.tcl
+lib/ical/v2.3/canvsup.tcl
+lib/ical/v2.3/contrib/README
+lib/ical/v2.3/contrib/ical.spec
+lib/ical/v2.3/contrib/ical.xbm
+lib/ical/v2.3/contrib/ical.xpm
+lib/ical/v2.3/contrib/ical2calendar
+lib/ical/v2.3/contrib/ical2html
+lib/ical/v2.3/contrib/ical2zsh
+lib/ical/v2.3/contrib/icaladd
+lib/ical/v2.3/contrib/icaladdlines
+lib/ical/v2.3/contrib/icalexpire
+lib/ical/v2.3/contrib/icalweekly
+lib/ical/v2.3/contrib/iconwindow.tcl
+lib/ical/v2.3/contrib/timeofday.tcl
+lib/ical/v2.3/contrib/weeknumber.tcl
+lib/ical/v2.3/dateeditor.tcl
+lib/ical/v2.3/dayview.tcl
+lib/ical/v2.3/dg_alarms.tcl
+lib/ical/v2.3/dg_item.tcl
+lib/ical/v2.3/dg_key.tcl
+lib/ical/v2.3/dg_monthr.tcl
+lib/ical/v2.3/dg_print.tcl
+lib/ical/v2.3/dg_range.tcl
+lib/ical/v2.3/dg_wdays.tcl
+lib/ical/v2.3/help.tcl
+lib/ical/v2.3/ical_text.tcl
+lib/ical/v2.3/ical_x.tcl
+lib/ical/v2.3/io.tcl
+lib/ical/v2.3/itemlist.tcl
+lib/ical/v2.3/itemwindow.tcl
+lib/ical/v2.3/link.tcl
+lib/ical/v2.3/listing.tcl
+lib/ical/v2.3/notelist.tcl
+lib/ical/v2.3/parse.tcl
+lib/ical/v2.3/pref.tcl
+lib/ical/v2.3/print.tcl
+lib/ical/v2.3/support.tcl
+lib/ical/v2.3/tclIndex
+lib/ical/v2.3/tcllib/canvas.tcl
+lib/ical/v2.3/tcllib/class.tcl
+lib/ical/v2.3/tcllib/dg_bug.tcl
+lib/ical/v2.3/tcllib/dg_error.tcl
+lib/ical/v2.3/tcllib/dg_file.tcl
+lib/ical/v2.3/tcllib/dg_num.tcl
+lib/ical/v2.3/tcllib/dg_string.tcl
+lib/ical/v2.3/tcllib/dg_yn.tcl
+lib/ical/v2.3/tcllib/dg_ync.tcl
+lib/ical/v2.3/tcllib/filesel.tcl
+lib/ical/v2.3/tcllib/hooks.tcl
+lib/ical/v2.3/tcllib/key.tcl
+lib/ical/v2.3/tcllib/label.tcl
+lib/ical/v2.3/tcllib/menus.tcl
+lib/ical/v2.3/tcllib/ruler.tcl
+lib/ical/v2.3/tcllib/support.tcl
+lib/ical/v2.3/tcllib/tclIndex
+lib/ical/v2.3/tcllib/textwin.tcl
+lib/ical/v2.3/timerange.tcl
+lib/ical/v2.3/trigger.tcl
man/man1/ical.1.gz
-lib/ical/v2.2/actions.tcl
-lib/ical/v2.2/alarm.tcl
-lib/ical/v2.2/apptlist.tcl
-lib/ical/v2.2/canvsup.tcl
-lib/ical/v2.2/contrib/README
-lib/ical/v2.2/contrib/ical.xbm
-lib/ical/v2.2/contrib/ical.xpm
-lib/ical/v2.2/contrib/ical2calendar
-lib/ical/v2.2/contrib/ical2html
-lib/ical/v2.2/contrib/ical2zsh
-lib/ical/v2.2/contrib/icaladd
-lib/ical/v2.2/contrib/icaladdlines
-lib/ical/v2.2/contrib/icalexpire
-lib/ical/v2.2/contrib/icalweekly
-lib/ical/v2.2/contrib/iconwindow.tcl
-lib/ical/v2.2/contrib/timeofday.tcl
-lib/ical/v2.2/contrib/weeknumber.tcl
-lib/ical/v2.2/dateeditor.tcl
-lib/ical/v2.2/dayview.tcl
-lib/ical/v2.2/dg_alarms.tcl
-lib/ical/v2.2/dg_item.tcl
-lib/ical/v2.2/dg_key.tcl
-lib/ical/v2.2/dg_monthr.tcl
-lib/ical/v2.2/dg_print.tcl
-lib/ical/v2.2/dg_range.tcl
-lib/ical/v2.2/dg_wdays.tcl
-lib/ical/v2.2/help.tcl
-lib/ical/v2.2/ical_text.tcl
-lib/ical/v2.2/ical_x.tcl
-lib/ical/v2.2/io.tcl
-lib/ical/v2.2/itemlist.tcl
-lib/ical/v2.2/itemwindow.tcl
-lib/ical/v2.2/link.tcl
-lib/ical/v2.2/listing.tcl
-lib/ical/v2.2/notelist.tcl
-lib/ical/v2.2/parse.tcl
-lib/ical/v2.2/pref.tcl
-lib/ical/v2.2/print.tcl
-lib/ical/v2.2/support.tcl
-lib/ical/v2.2/tclIndex
-lib/ical/v2.2/tcllib/canvas.tcl
-lib/ical/v2.2/tcllib/class.tcl
-lib/ical/v2.2/tcllib/dg_bug.tcl
-lib/ical/v2.2/tcllib/dg_error.tcl
-lib/ical/v2.2/tcllib/dg_file.tcl
-lib/ical/v2.2/tcllib/dg_num.tcl
-lib/ical/v2.2/tcllib/dg_string.tcl
-lib/ical/v2.2/tcllib/dg_yn.tcl
-lib/ical/v2.2/tcllib/dg_ync.tcl
-lib/ical/v2.2/tcllib/filesel.tcl
-lib/ical/v2.2/tcllib/hooks.tcl
-lib/ical/v2.2/tcllib/key.tcl
-lib/ical/v2.2/tcllib/label.tcl
-lib/ical/v2.2/tcllib/menus.tcl
-lib/ical/v2.2/tcllib/ruler.tcl
-lib/ical/v2.2/tcllib/support.tcl
-lib/ical/v2.2/tcllib/tclIndex
-lib/ical/v2.2/tcllib/textwin.tcl
-lib/ical/v2.2/timerange.tcl
-lib/ical/v2.2/trigger.tcl