aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-05-26 09:23:15 +0800
committeryuri <yuri@FreeBSD.org>2019-05-26 09:23:15 +0800
commit6408daa1001a5914a5545a18ea489b0685711708 (patch)
tree6d65d87af8b4fc4ae147d9a2db4f8cea74f358fc /deskutils
parent01c53554069c5bf6952158ec4d8c967de0f71a87 (diff)
downloadfreebsd-ports-gnome-6408daa1001a5914a5545a18ea489b0685711708.tar.gz
freebsd-ports-gnome-6408daa1001a5914a5545a18ea489b0685711708.tar.zst
freebsd-ports-gnome-6408daa1001a5914a5545a18ea489b0685711708.zip
New port: deskutils/goesimage: Wallpapers from NOAA Geostationary Operational Environment Satellite
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/goesimage/Makefile40
-rw-r--r--deskutils/goesimage/distinfo3
-rw-r--r--deskutils/goesimage/files/crontab.in1
-rw-r--r--deskutils/goesimage/pkg-descr5
-rw-r--r--deskutils/goesimage/pkg-message19
-rw-r--r--deskutils/goesimage/pkg-plist4
7 files changed, 73 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index b2f7a8935b0c..1b45d205f361 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -95,6 +95,7 @@
SUBDIR += gnote
SUBDIR += gnustep-wrapper
SUBDIR += go-for-it
+ SUBDIR += goesimage
SUBDIR += gourmet
SUBDIR += gpicker
SUBDIR += grantlee-editor
diff --git a/deskutils/goesimage/Makefile b/deskutils/goesimage/Makefile
new file mode 100644
index 000000000000..f635c561a620
--- /dev/null
+++ b/deskutils/goesimage/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= goesimage
+DISTVERSION= 0.1.1
+CATEGORIES= deskutils
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Wallpapers from NOAA Geostationary Operational Environment Satellite
+
+RUN_DEPENDS= bash:shells/bash \
+ curl:ftp/curl \
+ feh:graphics/feh \
+ convert:graphics/ImageMagick6
+
+USES= shebangfix
+SHEBANG_FILES= goesimage
+USE_GITHUB= yes
+GH_ACCOUNT= pigmonkey
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+SUB_LIST= PORTNAME=${PORTNAME}
+SUB_FILES= crontab
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/libexec/
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/crontab ${STAGEDIR}${DATADIR}
+ @(echo "#!/bin/sh"; \
+ echo ""; \
+ echo "crontab -l | ${GREP} -v '${PREFIX}/libexec/${PORTNAME}' | (cat ; cat ${DATADIR}/crontab) | crontab -;"; \
+ ) > ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-enable
+ @(echo "#!/bin/sh"; \
+ echo ""; \
+ echo "crontab -l | ${GREP} -v '${PREFIX}/libexec/${PORTNAME}' | crontab -"; \
+ ) > ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-disable
+ @cd ${STAGEDIR}${PREFIX}/bin && ${CHMOD} +x ${PORTNAME}-enable ${PORTNAME}-disable
+
+.include <bsd.port.mk>
diff --git a/deskutils/goesimage/distinfo b/deskutils/goesimage/distinfo
new file mode 100644
index 000000000000..b3e641f4caf1
--- /dev/null
+++ b/deskutils/goesimage/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1558824744
+SHA256 (pigmonkey-goesimage-0.1.1_GH0.tar.gz) = 616c3501625ebb96dcfc0ff7e7ac79bc1c74f0e75efda422ebbd88364432ec04
+SIZE (pigmonkey-goesimage-0.1.1_GH0.tar.gz) = 4098974
diff --git a/deskutils/goesimage/files/crontab.in b/deskutils/goesimage/files/crontab.in
new file mode 100644
index 000000000000..1320d4b1accd
--- /dev/null
+++ b/deskutils/goesimage/files/crontab.in
@@ -0,0 +1 @@
+01,16,31,46 * * * * env DISPLAY=:0 %%PREFIX%%/libexec/%%PORTNAME%% -w -e
diff --git a/deskutils/goesimage/pkg-descr b/deskutils/goesimage/pkg-descr
new file mode 100644
index 000000000000..f754b268caf6
--- /dev/null
+++ b/deskutils/goesimage/pkg-descr
@@ -0,0 +1,5 @@
+goesimage downloads beautiful images of planet Earth from the NOAA Geostationary
+Operational Environment Satellite (https://www.goes.noaa.gov/) and makes them
+your wallpaper.
+
+WWW: https://github.com/pigmonkey
diff --git a/deskutils/goesimage/pkg-message b/deskutils/goesimage/pkg-message
new file mode 100644
index 000000000000..fbb652b1bb43
--- /dev/null
+++ b/deskutils/goesimage/pkg-message
@@ -0,0 +1,19 @@
+======================================================================
+You installed goesimage, the program that downloads images from
+NOAA Geostationary Operational Environment Satellite and makes them
+your wallpaper.
+
+It only makes sense to install goesimage if you are running some
+graphical desktop environment.
+
+You need to enable goesimage by running this command:
+$ goesimage-enable
+
+This will install the crontab procedure for your current user.
+
+Images will be saved in your ~/.cache/goesimage/ directory, and will
+be set as a wallpaper on the Xorg server running on DISPLAY=:0
+
+Before uninstalling, you need to disable it:
+$ goesimage-disable
+======================================================================
diff --git a/deskutils/goesimage/pkg-plist b/deskutils/goesimage/pkg-plist
new file mode 100644
index 000000000000..73cb6fd9f3a3
--- /dev/null
+++ b/deskutils/goesimage/pkg-plist
@@ -0,0 +1,4 @@
+bin/goesimage-disable
+bin/goesimage-enable
+libexec/goesimage
+%%DATADIR%%/crontab