aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-08-08 23:38:31 +0800
committerpat <pat@FreeBSD.org>2002-08-08 23:38:31 +0800
commit694083e0a0e4cb3b12e39d10f9f01e5273687e76 (patch)
tree45112ba854f43551e983be5a2ab02a6cf71dc2dd /deskutils
parentd4fc6a8b559ea08be1d472eed3685a452be2021f (diff)
downloadfreebsd-ports-gnome-694083e0a0e4cb3b12e39d10f9f01e5273687e76.tar.gz
freebsd-ports-gnome-694083e0a0e4cb3b12e39d10f9f01e5273687e76.tar.zst
freebsd-ports-gnome-694083e0a0e4cb3b12e39d10f9f01e5273687e76.zip
PERL -> REINPLACE_CMD
PR: ports/41442 Submitted by: maintainer
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/tuxcards/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/deskutils/tuxcards/Makefile b/deskutils/tuxcards/Makefile
index 4197b8cdc780..84fdcf338187 100644
--- a/deskutils/tuxcards/Makefile
+++ b/deskutils/tuxcards/Makefile
@@ -19,13 +19,14 @@ USE_GMAKE= yes
USE_QT_VER= 2
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
+USE_REINPLACE= yes
pre-patch:
- @${PERL} -pi -e 's|\$$\(prefix\)/doc|\$$\(prefix\)/share/doc|' \
+ @${REINPLACE_CMD} -e 's|[$$](prefix)/doc|\$$\(prefix\)/share/doc|' \
${WRKSRC}/tuxcards/docs/en/Makefile.in
- @${PERL} -pi -e 's|-O2||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
.ifdef(NOPORTDOCS)
- @${PERL} -pi -e 's|install-data-am\: install-data-local||' \
+ @${REINPLACE_CMD} -e 's|install-data-am\: install-data-local||' \
${WRKSRC}/tuxcards/docs/en/Makefile.in
.endif #NOPORTDOCS