aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-12-24 17:30:23 +0800
committerantoine <antoine@FreeBSD.org>2013-12-24 17:30:23 +0800
commit6d2018acc0d610595e233301deb18cbffd4cbb37 (patch)
treeb2770551cec34b67ba79d8639a9f081e41655181 /deskutils
parent73ec8f535246323718c83fe7c750b948c25572d0 (diff)
downloadfreebsd-ports-gnome-6d2018acc0d610595e233301deb18cbffd4cbb37.tar.gz
freebsd-ports-gnome-6d2018acc0d610595e233301deb18cbffd4cbb37.tar.zst
freebsd-ports-gnome-6d2018acc0d610595e233301deb18cbffd4cbb37.zip
- Fix build
- Do not reinplace binary files (*.wav, *.jpg...) - Stage support PR: ports/184944 Submitted by: Ivan Klymenko (maintainer)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/cairo-dock-plugins/Makefile13
-rw-r--r--deskutils/cairo-dock-plugins/files/patch-CMakeLists.txt11
-rw-r--r--deskutils/cairo-dock-plugins/files/patch-Dbus__interfaces__vala__CMakeLists.txt8
-rw-r--r--deskutils/cairo-dock-plugins/pkg-plist3
4 files changed, 26 insertions, 9 deletions
diff --git a/deskutils/cairo-dock-plugins/Makefile b/deskutils/cairo-dock-plugins/Makefile
index 779773295d03..1c7da7046bcf 100644
--- a/deskutils/cairo-dock-plugins/Makefile
+++ b/deskutils/cairo-dock-plugins/Makefile
@@ -18,16 +18,14 @@ DATADIR= ${PREFIX}/share/cairo-dock
ICONS_PACKAGE= cairo-dock-plugins-png-icons
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 gtk20 librsvg2 libxml2
+USE_GNOME= glib20 gtk20 librsvg2 libxml2
USE_LDCONFIG= yes
USE_PYTHON= yes
USE_XORG= xrender
-USE_DOS2UNIX= YES
USES= cmake gettext pkgconfig
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB+= PYVER="${PYTHON_VERSION:S/thon//}"
-CMAKE_ARGS+= -Dinstall-pc-path:STRING="${LOCALBASE}/libdata/pkgconfig"
+CMAKE_ARGS+= -DROOT_PREFIX:PATH=${STAGEDIR}
OPTIONS_DEFINE= XFCE_INTEGRATION ALSA_MIXER GMENU \
KEYBOARD_INDICATOR IMPULSE \
@@ -44,14 +42,15 @@ WEBLETS_DESC= Weblets applet
OPTIONS_SUB= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@${CP} -R ${WRKDIR}/${ICONS_PACKAGE}/* ${WRKSRC}
- @${FIND} ${WRKSRC} -type f -name "*" | ${XARGS} ${REINPLACE_CMD} -i.orig -e \
+ @${FIND} ${WRKSRC} -type f \( -name "*.c" -o -name "*.conf" \
+ -o -name netspeed -o -name nvidia-config -o -name "*.sh" \
+ -o -name "*.rb" \) | ${XARGS} ${REINPLACE_CMD} -i.orig -e \
's|/bin/bash|${LOCALBASE}/bin/bash|g; \
- s|/usr/bin/python|${LOCALBASE}/bin/python|g; \
+ s|/usr/bin/python|${PYTHON_CMD}|g; \
s|/usr/bin/ruby|${LOCALBASE}/bin/ruby|g; \
s|/usr/share/applications|${LOCALBASE}/share/applications|g; \
s|/usr/share/cairo-dock|${LOCALBASE}/share/cairo-dock|g'
diff --git a/deskutils/cairo-dock-plugins/files/patch-CMakeLists.txt b/deskutils/cairo-dock-plugins/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d0feb6023933
--- /dev/null
+++ b/deskutils/cairo-dock-plugins/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./CMakeLists.txt.orig 2013-04-04 21:40:14.000000000 +0000
++++ ./CMakeLists.txt 2013-12-24 08:11:07.000000000 +0000
+@@ -717,7 +717,7 @@
+ enable_if_not_defined (enable-gmenu)
+ if (enable-gmenu)
+ set (GMENU_MODULE "libgnome-menu-3.0")
+- set (GMENU_MODULE_OLD "libgnome-menu")
++ set (GMENU_MODULE_OLD "libgnome-menu gio-unix-2.0")
+ pkg_check_modules (GMENU_PACKAGE ${GMENU_MODULE})
+ if (NOT GMENU_PACKAGE_FOUND)
+ message (STATUS "Could not find ${GMENU_MODULE}; trying with an old version...")
diff --git a/deskutils/cairo-dock-plugins/files/patch-Dbus__interfaces__vala__CMakeLists.txt b/deskutils/cairo-dock-plugins/files/patch-Dbus__interfaces__vala__CMakeLists.txt
new file mode 100644
index 000000000000..aa5bfdc0a8f5
--- /dev/null
+++ b/deskutils/cairo-dock-plugins/files/patch-Dbus__interfaces__vala__CMakeLists.txt
@@ -0,0 +1,8 @@
+--- ./Dbus/interfaces/vala/CMakeLists.txt.orig 2013-03-23 15:55:27.000000000 +0000
++++ ./Dbus/interfaces/vala/CMakeLists.txt 2013-12-24 08:04:37.000000000 +0000
+@@ -62,4 +62,4 @@
+ add_subdirectory(src)
+ # .pc goes with others
+ configure_file (${CMAKE_CURRENT_SOURCE_DIR}/${CDAPPLET}.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${CDAPPLET}.pc)
+-install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${CDAPPLET}.pc DESTINATION ${libdir}/pkgconfig)
++install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${CDAPPLET}.pc DESTINATION libdata/pkgconfig)
diff --git a/deskutils/cairo-dock-plugins/pkg-plist b/deskutils/cairo-dock-plugins/pkg-plist
index a87f24489bc3..e1ebcb2715c7 100644
--- a/deskutils/cairo-dock-plugins/pkg-plist
+++ b/deskutils/cairo-dock-plugins/pkg-plist
@@ -45,7 +45,6 @@ lib/cairo-dock/libcd-weather.so
lib/cairo-dock/libcd-wifi.so
lib/cairo-dock/libcd_gnome-integration.so
lib/libCDApplet.so
-lib/pkgconfig/CDApplet.pc
%%XFCE_INTEGRATION%%lib/cairo-dock/libcd_xfce-integration.so
%%PYTHON_SITELIBDIR%%/CDApplet.py
%%PYTHON_SITELIBDIR%%/CDApplet.pyc
@@ -55,6 +54,7 @@ lib/pkgconfig/CDApplet.pc
%%PYTHON_SITELIBDIR%%/CDBashApplet-1.0-%%PYVER%%.egg-info
%%PYTHON_SITELIBDIR%%/CairoDock.py
%%PYTHON_SITELIBDIR%%/CairoDock.pyc
+libdata/pkgconfig/CDApplet.pc
share/locale/he/LC_MESSAGES/cairo-dock-plugins.mo
share/locale/hr/LC_MESSAGES/cairo-dock-plugins.mo
share/locale/fr/LC_MESSAGES/cairo-dock-plugins.mo
@@ -485,7 +485,6 @@ share/cairo-dock/plug-ins/Xgamma/icon.png
share/cairo-dock/plug-ins/Xgamma/preview.jpg
share/vala/vapi/CDApplet.vapi
share/vala/vapi/CDApplet.deps
-@dirrmtry lib/pkgconfig
@dirrm share/cairo-dock/plug-ins/clock/digital/default
@dirrm share/cairo-dock/plug-ins/clock/digital
@dirrm share/cairo-dock/plug-ins/clock/themes/default