aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-02-20 17:07:00 +0800
committerThierry Thomas <thierry@FreeBSD.org>2021-02-20 17:07:00 +0800
commit8b2c129ab73115bdc58eafe0094f2be08dd63bd2 (patch)
tree00766582d5518a50f79354c0b70f514081101f7a /deskutils
parent29797d0752e8d5c7e46825d1cd1fa2edbe0f73e1 (diff)
downloadfreebsd-ports-gnome-8b2c129ab73115bdc58eafe0094f2be08dd63bd2.tar.gz
freebsd-ports-gnome-8b2c129ab73115bdc58eafe0094f2be08dd63bd2.tar.zst
freebsd-ports-gnome-8b2c129ab73115bdc58eafe0094f2be08dd63bd2.zip
Adding py-term-background, a Python module to figure out if a terminal has a
dark or light background.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/py-term-background/Makefile32
-rw-r--r--deskutils/py-term-background/distinfo3
-rw-r--r--deskutils/py-term-background/pkg-descr5
-rw-r--r--deskutils/py-term-background/pkg-plist12
5 files changed, 53 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 0fc842790566..961940822c9a 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -206,6 +206,7 @@
SUBDIR += py-pystash
SUBDIR += py-send2trash
SUBDIR += py-taskw
+ SUBDIR += py-term-background
SUBDIR += py-todoman
SUBDIR += py-vdirsyncer
SUBDIR += py-vobject
diff --git a/deskutils/py-term-background/Makefile b/deskutils/py-term-background/Makefile
new file mode 100644
index 000000000000..ee86ff488f50
--- /dev/null
+++ b/deskutils/py-term-background/Makefile
@@ -0,0 +1,32 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= term-background
+PORTVERSION= 1.0.1
+CATEGORIES= deskutils python shells
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Shell scripts and Python module to figure out terminal background
+
+LICENSE= GPLv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= rocky
+GH_PROJECT= shell-term-background
+
+USES= python:3.7+ shebangfix
+USE_PYTHON= distutils
+SHEBANG_FILES= term-background.*
+
+NO_ARCH= yes
+MAKE_ENV+= PYTHON=${PYTHON_CMD}
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/term-background.* ${STAGEDIR}${DATADIR}
+
+do-test: install
+ (cd ${WRKSRC} && py.test)
+
+.include <bsd.port.mk>
diff --git a/deskutils/py-term-background/distinfo b/deskutils/py-term-background/distinfo
new file mode 100644
index 000000000000..bea06106ea83
--- /dev/null
+++ b/deskutils/py-term-background/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613386752
+SHA256 (rocky-shell-term-background-1.0.1_GH0.tar.gz) = c59081defac311e078657b0e7e933970a57fc89a4ba152d159436ccc3b6477a8
+SIZE (rocky-shell-term-background-1.0.1_GH0.tar.gz) = 20302
diff --git a/deskutils/py-term-background/pkg-descr b/deskutils/py-term-background/pkg-descr
new file mode 100644
index 000000000000..ee21c19ef4f0
--- /dev/null
+++ b/deskutils/py-term-background/pkg-descr
@@ -0,0 +1,5 @@
+POSIX shell scripts to figure out if a terminal has a dark or light background.
+
+The Python module contained is part of a broader set of scripts.
+
+WWW: https://github.com/rocky/shell-term-background
diff --git a/deskutils/py-term-background/pkg-plist b/deskutils/py-term-background/pkg-plist
new file mode 100644
index 000000000000..507bc5765c85
--- /dev/null
+++ b/deskutils/py-term-background/pkg-plist
@@ -0,0 +1,12 @@
+%%PYTHON_SITELIBDIR%%/term_background/__init__.py
+%%PYTHON_SITELIBDIR%%/term_background/__main__.py
+%%PYTHON_SITELIBDIR%%/term_background/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/term_background/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/term_background/__pycache__/__main__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/term_background/__pycache__/__main__.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/term_background/__pycache__/version.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/term_background/__pycache__/version.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/term_background/version.py
+%%DATADIR%%/term-background.bash
+%%DATADIR%%/term-background.ksh
+%%DATADIR%%/term-background.zsh