aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-07-12 09:57:57 +0800
committerMark Linimon <linimon@FreeBSD.org>2019-07-12 09:57:57 +0800
commit92e22122e819280ea0c18de3ddd7a8b8a25a3ead (patch)
tree8ec4f270012859c295f1f26a9f1f67e45039dbda /deskutils
parentc6af2b4296e16b30986b47c1129527e969af06e2 (diff)
downloadfreebsd-ports-gnome-92e22122e819280ea0c18de3ddd7a8b8a25a3ead.tar.gz
freebsd-ports-gnome-92e22122e819280ea0c18de3ddd7a8b8a25a3ead.tar.zst
freebsd-ports-gnome-92e22122e819280ea0c18de3ddd7a8b8a25a3ead.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for libstdc++.so
as a stand-in for "are we running on gcc". These 4 cases are outliers because they set compiler:nestedfct which currently hardwires gcc. So the real test for including -fnested-functions into CFLAGS is "are we on the ancient base gcc". Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/growl-for-linux/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index 4b44c20bb0c0..0637e72acaeb 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -41,7 +41,9 @@ USE_GNOME= cairo gdkpixbuf2 gtk20 libxml2
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}/display \
${PREFIX}/lib/${PORTNAME}/subscribe
-.if exists(/usr/lib/libstdc++.so)
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
CFLAGS+= -fnested-functions
.endif
@@ -52,4 +54,4 @@ post-patch:
post-install:
${RM} ${STAGEDIR}${PREFIX}/lib/libgolplug.a
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>