aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-01-16 17:08:55 +0800
committergahr <gahr@FreeBSD.org>2014-01-16 17:08:55 +0800
commit94eed056a8ed1d8fbf257260329370808ee0d5e2 (patch)
tree465c871d26223bf06e686e396f62945a00293afd /deskutils
parent5222365530ddd7f5e639f1a095555ff3406afdeb (diff)
downloadfreebsd-ports-gnome-94eed056a8ed1d8fbf257260329370808ee0d5e2.tar.gz
freebsd-ports-gnome-94eed056a8ed1d8fbf257260329370808ee0d5e2.tar.zst
freebsd-ports-gnome-94eed056a8ed1d8fbf257260329370808ee0d5e2.zip
- New port: deskutils/taskd
The taskd server provides a multi-user, multi-client repository for taskwarrior (deskutils/taskwarrior) 2.3.0 (and later) and any other clients. It runs continuously as a daemon process, and provides several services, primarily the synchronization of tasks between the clients.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/taskd/Makefile26
-rw-r--r--deskutils/taskd/distinfo2
-rw-r--r--deskutils/taskd/files/patch-src_Nibbler.h10
-rw-r--r--deskutils/taskd/pkg-descr6
5 files changed, 45 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 70b7efc5b777..29fe46dc2edf 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -229,6 +229,7 @@
SUBDIR += systempreferences
SUBDIR += tagutils
SUBDIR += taskcoach
+ SUBDIR += taskd
SUBDIR += taskwarrior
SUBDIR += teapot
SUBDIR += tel
diff --git a/deskutils/taskd/Makefile b/deskutils/taskd/Makefile
new file mode 100644
index 000000000000..b9268d33c538
--- /dev/null
+++ b/deskutils/taskd/Makefile
@@ -0,0 +1,26 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= taskd
+PORTVERSION= 1.0.0
+CATEGORIES= deskutils
+MASTER_SITES= http://taskwarrior.org/download/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Multi-user server for taskwarrior
+
+LICENSE= MIT
+
+LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+
+USES= cmake:outsource
+CFLAGS+= -g -O0
+
+PLIST_FILES= bin/taskd \
+ bin/taskdctl \
+ man/man1/taskd.1.gz \
+ man/man5/taskdrc.5.gz
+
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/deskutils/taskd/distinfo b/deskutils/taskd/distinfo
new file mode 100644
index 000000000000..9db5da3220d3
--- /dev/null
+++ b/deskutils/taskd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (taskd-1.0.0.tar.gz) = 162ef1eec48f8145870ef0dbe0121b78a6da99815bc18af77de07fbb0abe02d0
+SIZE (taskd-1.0.0.tar.gz) = 128191
diff --git a/deskutils/taskd/files/patch-src_Nibbler.h b/deskutils/taskd/files/patch-src_Nibbler.h
new file mode 100644
index 000000000000..e5c27abdb36c
--- /dev/null
+++ b/deskutils/taskd/files/patch-src_Nibbler.h
@@ -0,0 +1,10 @@
+--- src/Nibbler.h.orig 2013-09-17 10:58:23.000000000 +0200
++++ src/Nibbler.h 2013-09-17 10:58:33.000000000 +0200
+@@ -37,6 +37,7 @@
+
+ #include <string>
+ #include <vector>
++#include <sys/time.h>
+
+ class Nibbler
+ {
diff --git a/deskutils/taskd/pkg-descr b/deskutils/taskd/pkg-descr
new file mode 100644
index 000000000000..ce789c38547f
--- /dev/null
+++ b/deskutils/taskd/pkg-descr
@@ -0,0 +1,6 @@
+The task server provides a multi-user, multi-client repository for Taskwarrior
+2.3.0 (and later) and any other clients. It runs continuously as a daemon
+process, and provides several services, primarily the synchronization of tasks
+between the clients.
+
+WWW: http://taskwarrior.org