aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-04 21:19:55 +0800
committerbapt <bapt@FreeBSD.org>2014-04-04 21:19:55 +0800
commit9d085f7c9a4a6e3211b111c8cbdf0a0c6ab9ef6c (patch)
tree9cde3fcfe7d680dd530db6c4bfd28469b0e65840 /deskutils
parent88abad2b1c12853420d5e4337e337f7a2274048c (diff)
downloadfreebsd-ports-gnome-9d085f7c9a4a6e3211b111c8cbdf0a0c6ab9ef6c.tar.gz
freebsd-ports-gnome-9d085f7c9a4a6e3211b111c8cbdf0a0c6ab9ef6c.tar.zst
freebsd-ports-gnome-9d085f7c9a4a6e3211b111c8cbdf0a0c6ab9ef6c.zip
Use options helpers
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/xpad-current/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/deskutils/xpad-current/Makefile b/deskutils/xpad-current/Makefile
index d4f6c65f7100..b5b44f5fb335 100644
--- a/deskutils/xpad-current/Makefile
+++ b/deskutils/xpad-current/Makefile
@@ -14,29 +14,23 @@ COMMENT= Virtual note-pad system for your X11 desktop
LICENSE= GPLv3
OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
CONFLICTS_INSTALL= xpad-[0-9]*
-USE_BZIP2= yes
USE_XORG= x11 sm
USE_GNOME= gtk20 gnomehier intltool
-USES= pkgconfig gmake
+USES= pkgconfig gmake tar:bzip2
INSTALLS_ICONS= yes
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-.include <bsd.port.options.mk>
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
-#code currently doesn't properly handle --disable-nls (in next upstream milestone)
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+.include <bsd.port.options.mk>
-post-patch-script:
+post-patch:
.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's|SUBDIRS = autopackage doc src images po|SUBDIRS = autopackage doc src images|' \
${WRKSRC}/Makefile.in