aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-02-08 14:36:43 +0800
committeradamw <adamw@FreeBSD.org>2004-02-08 14:36:43 +0800
commitaeabb684f97aa13ea2ecf1fc771962dcd01f0594 (patch)
tree8d03a7a1ac6b62dea41d0f397ae8aa3a5d03847c /deskutils
parentbd2b0687e74056758113c584334439bf1806e33c (diff)
downloadfreebsd-ports-gnome-aeabb684f97aa13ea2ecf1fc771962dcd01f0594.tar.gz
freebsd-ports-gnome-aeabb684f97aa13ea2ecf1fc771962dcd01f0594.tar.zst
freebsd-ports-gnome-aeabb684f97aa13ea2ecf1fc771962dcd01f0594.zip
Add gtkjournal.
Gtk+ Journal is a Journal/Diary application written using the C++ bindings for Gtk+-2 (gtkmm). It uses SQlite to store your entries, and the OpenSSL implementations of the BlowFish and SHA-1 algorithms to keep your data safe.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/gtkjournal/Makefile35
-rw-r--r--deskutils/gtkjournal/distinfo2
-rw-r--r--deskutils/gtkjournal/files/patch-Makefile18
-rw-r--r--deskutils/gtkjournal/files/patch-gjournal::journalwindow.hpp10
-rw-r--r--deskutils/gtkjournal/pkg-descr5
6 files changed, 71 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index dafc3eb9a08f..7be25d01acfc 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -39,6 +39,7 @@
SUBDIR += gnotime
SUBDIR += goats
SUBDIR += gtimer
+ SUBDIR += gtkjournal
SUBDIR += gtodo
SUBDIR += gucharmap
SUBDIR += gworkspace
diff --git a/deskutils/gtkjournal/Makefile b/deskutils/gtkjournal/Makefile
new file mode 100644
index 000000000000..6a171072d5b7
--- /dev/null
+++ b/deskutils/gtkjournal/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gtkjournal
+# Date created: 08 February 2004
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkjournal
+PORTVERSION= 0.3.4.pre1
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://linuxhelp.homeunix.com/gtkjournal/files/
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Gtk+-2 journal/diary
+
+LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2 \
+ sqlite:${PORTSDIR}/databases/sqlite
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_OPENSSL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e "54,\$$d" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/deskutils/gtkjournal/distinfo b/deskutils/gtkjournal/distinfo
new file mode 100644
index 000000000000..ac162f1aef86
--- /dev/null
+++ b/deskutils/gtkjournal/distinfo
@@ -0,0 +1,2 @@
+MD5 (gtkjournal-0.3.4pre1.tar.bz2) = c0b349138de08c64bca3387300d37a12
+SIZE (gtkjournal-0.3.4pre1.tar.bz2) = 24045
diff --git a/deskutils/gtkjournal/files/patch-Makefile b/deskutils/gtkjournal/files/patch-Makefile
new file mode 100644
index 000000000000..b5ef449d7fbe
--- /dev/null
+++ b/deskutils/gtkjournal/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Wed Feb 4 18:17:43 2004
++++ Makefile Sun Feb 8 01:06:06 2004
+@@ -4,11 +4,11 @@
+ ## @version: 1.0
+ ##
+
+-CXX = g++
+-PREFIX = /usr
++#CXX = g++
++#PREFIX = /usr
+ INCLUDE = `pkg-config gtkmm-2.0 --cflags` -I./
+-LIBS = `pkg-config gtkmm-2.0 --libs` -lcrypto -lsqlite
+-CXXFLAGS = -pipe -ansi -pedantic
++LIBS = ${LDFLAGS} `pkg-config gtkmm-2.0 --libs` -lcrypto -lsqlite
++CXXFLAGS = ${CFLAGS} -pipe
+ SRCS = gjournal/journalfile.cpp aolib/gui/informationdialog.cpp aolib/bfcryptfile.cpp sqlitem/sqlitemanager.cpp \
+ sqlitem/sqliteresult.cpp aolib/gui/logindialog.cpp gjournal/globals.cpp gjournal/journalwindow.cpp aolib/datefuncs.cpp main.cpp
+ OBJS = gjournal/journalfile.o aolib/gui/informationdialog.o aolib/bfcryptfile.o sqlitem/sqlitemanager.o \
diff --git a/deskutils/gtkjournal/files/patch-gjournal::journalwindow.hpp b/deskutils/gtkjournal/files/patch-gjournal::journalwindow.hpp
new file mode 100644
index 000000000000..e3af3e959cf2
--- /dev/null
+++ b/deskutils/gtkjournal/files/patch-gjournal::journalwindow.hpp
@@ -0,0 +1,10 @@
+--- gjournal/journalwindow.hpp.orig Sun Feb 8 00:09:23 2004
++++ gjournal/journalwindow.hpp Sun Feb 8 00:09:41 2004
+@@ -19,6 +19,7 @@
+ #ifndef JOURNAL_WINDOW_HPP
+ #define JOURNAL_WINDOW_HPP
+
++#include <libgen.h>
+ #include <gtkmm.h>
+ #include <iostream>
+ #include <map>
diff --git a/deskutils/gtkjournal/pkg-descr b/deskutils/gtkjournal/pkg-descr
new file mode 100644
index 000000000000..95311c995be3
--- /dev/null
+++ b/deskutils/gtkjournal/pkg-descr
@@ -0,0 +1,5 @@
+Gtk+ Journal is a Journal/Diary application written using the C++ bindings for
+Gtk+-2 (gtkmm). It uses SQlite to store your entries, and the OpenSSL
+implementations of the BlowFish and SHA-1 algorithms to keep your data safe.
+
+WWW: http://linuxhelp.homeunix.com/cgi-bin/rblh/index.rb?handler=downloads&d=GtkJournal