aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
commitba5181b4c873c984e4559cfddf3b6ce79362a9a2 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /deskutils
parent39c24b55b95207275ceec7228fd4470225c94152 (diff)
downloadfreebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.gz
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.zst
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/xmdiary/Makefile4
-rw-r--r--deskutils/xrolo/Makefile8
2 files changed, 4 insertions, 8 deletions
diff --git a/deskutils/xmdiary/Makefile b/deskutils/xmdiary/Makefile
index 79118bc9bff6..b02651bc0f2a 100644
--- a/deskutils/xmdiary/Makefile
+++ b/deskutils/xmdiary/Makefile
@@ -15,12 +15,12 @@ COMMENT= Personal and group calendar utility
NO_CDROM= Don't sell for profit
EXTRACT_ONLY= ${DISTNAME}.tar.gz
USE_MOTIF= yes
-USE_IMAKE= yes
+USES= imake
+USE_GCC= any
USE_XORG= x11 xext xp xpm xt
MAN1= xdaclunix.1 xdalarm.1 xdcustom.1 xddump.1 xdiary.1 xdinitdb.1 \
xdlight.1 xdnotify.1 xdprformat.1 xdremind.1 xdremove.1 \
xdrestore.1
-CFLAGS+= -Werror
MAKE_JOBS_SAFE= yes
post-patch:
diff --git a/deskutils/xrolo/Makefile b/deskutils/xrolo/Makefile
index 6cfbfd5208c7..86895359a832 100644
--- a/deskutils/xrolo/Makefile
+++ b/deskutils/xrolo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xrolo
-# Date created: 17 January 1999
-# Whom: Lars Koeller <Lars.Koeller@Uni-Bielefeld.DE>
-#
+# Created by: Lars Koeller <Lars.Koeller@Uni-Bielefeld.DE>
# $FreeBSD$
-#
PORTNAME= xrolo
PORTVERSION= 2.6
@@ -21,7 +17,7 @@ LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
WRKSRC= ${WRKDIR}/xrolo
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11 xext
MAN1= xrolo.1
PLIST_FILES= bin/xrolo