aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-26 21:48:06 +0800
committerantoine <antoine@FreeBSD.org>2014-01-26 21:48:06 +0800
commitbb3ac2ed45464c74091fdd1c123c257649845d07 (patch)
tree5b0df1941314198e0ec7315c3240b787076080da /deskutils
parentf8de49ed1fb57feb107a8214c386309233691609 (diff)
downloadfreebsd-ports-gnome-bb3ac2ed45464c74091fdd1c123c257649845d07.tar.gz
freebsd-ports-gnome-bb3ac2ed45464c74091fdd1c123c257649845d07.tar.zst
freebsd-ports-gnome-bb3ac2ed45464c74091fdd1c123c257649845d07.zip
- Fix LIB_DEPENDS syntax
While here: - Remove USE_GCC=any, it builds and runs fine with clang (tested on 10-amd64) - Add stage support
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/easystroke/Makefile18
-rw-r--r--deskutils/easystroke/pkg-plist1
2 files changed, 8 insertions, 11 deletions
diff --git a/deskutils/easystroke/Makefile b/deskutils/easystroke/Makefile
index f9fc676c92b7..527441c65b66 100644
--- a/deskutils/easystroke/Makefile
+++ b/deskutils/easystroke/Makefile
@@ -13,20 +13,16 @@ LICENSE= ISCL
BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man \
${LOCALBASE}/include/xorg/xserver-properties.h:${PORTSDIR}/x11-servers/xorg-server
-LIB_DEPENDS= libgtkmm-3.so:${PORTSDIR}/x11-toolkits/gtkmm30 \
- libdbus-glib.so:${PORTSDIR}/devel/dbus-glib \
+LIB_DEPENDS= libgtkmm-3.0.so:${PORTSDIR}/x11-toolkits/gtkmm30 \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libboost_serialization.so:${PORTSDIR}/devel/boost-libs
-MAN1= easystroke.1
-
-USE_GCC= any
USE_XORG= x11 xtst
USES= gettext gmake pkgconfig
INSTALLS_ICONS= yes
OPTIONS_DEFINE= NLS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -44,14 +40,14 @@ pre-build:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications/
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.svg ${PREFIX}/share/pixmaps/
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.svg ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MNLS}
(cd ${WRKSRC}/po/ && \
- ${COPYTREE_SHARE} \* ${PREFIX}/share/locale/ "-name *.mo")
+ ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/locale/ "-name *.mo")
.endif
.include <bsd.port.mk>
diff --git a/deskutils/easystroke/pkg-plist b/deskutils/easystroke/pkg-plist
index 569c8a884ee4..4e07bcd400d5 100644
--- a/deskutils/easystroke/pkg-plist
+++ b/deskutils/easystroke/pkg-plist
@@ -1,3 +1,4 @@
+man/man1/easystroke.1.gz
share/pixmaps/easystroke.svg
%%NLS%%share/locale/ru/LC_MESSAGES/easystroke.mo
%%NLS%%share/locale/ko/LC_MESSAGES/easystroke.mo