aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-18 11:49:09 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-18 11:49:09 +0800
commitc0440bda6b4b10acfc2e9dcd34f689807f39e66e (patch)
tree011ecedd5c814f5703e586c87086601a7a0634a4 /deskutils
parentfef3d02fc15ae16547472eb1f71f009a47f998c0 (diff)
downloadfreebsd-ports-gnome-c0440bda6b4b10acfc2e9dcd34f689807f39e66e.tar.gz
freebsd-ports-gnome-c0440bda6b4b10acfc2e9dcd34f689807f39e66e.tar.zst
freebsd-ports-gnome-c0440bda6b4b10acfc2e9dcd34f689807f39e66e.zip
Mark ports broken on powerpc64, categories d-f.
While here, pet portlint and do some other cleanup. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/easystroke/Makefile4
-rw-r--r--deskutils/gnome-clocks/Makefile2
-rw-r--r--deskutils/showdown/Makefile2
-rw-r--r--deskutils/xneur/Makefile4
4 files changed, 10 insertions, 2 deletions
diff --git a/deskutils/easystroke/Makefile b/deskutils/easystroke/Makefile
index 69e500216127..8062399443b8 100644
--- a/deskutils/easystroke/Makefile
+++ b/deskutils/easystroke/Makefile
@@ -13,15 +13,17 @@ COMMENT= Easystroke is a gesture-recognition application for X11
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to build: handler.cc:560:27: call of overloaded 'abs(float&)' is ambiguous
+
BUILD_DEPENDS= help2man:misc/help2man \
${LOCALBASE}/include/xorg/xserver-properties.h:x11-servers/xorg-server
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib \
libboost_serialization.so:devel/boost-libs
+USES= compiler:c++11-lang gettext gmake pkgconfig
USE_GNOME= gtkmm30
USE_XORG= x11 xext xfixes xi xtst
-USES= compiler:c++11-lang gettext gmake pkgconfig
USE_CXXSTD= c++11
INSTALLS_ICONS= yes
diff --git a/deskutils/gnome-clocks/Makefile b/deskutils/gnome-clocks/Makefile
index 18384bb2dceb..1103e5e2c01d 100644
--- a/deskutils/gnome-clocks/Makefile
+++ b/deskutils/gnome-clocks/Makefile
@@ -13,6 +13,8 @@ COMMENT= Clocks for GNOME 3
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-unused-but-set-variable"
+
BUILD_DEPENDS= itstool:textproc/itstool \
vala:lang/vala
LIB_DEPENDS= libgeoclue-2.so:net/geoclue \
diff --git a/deskutils/showdown/Makefile b/deskutils/showdown/Makefile
index 8282681522cf..c7e1102518fd 100644
--- a/deskutils/showdown/Makefile
+++ b/deskutils/showdown/Makefile
@@ -10,6 +10,8 @@ COMMENT= Simple markdown viewer, written in Vala and GTK 3
LICENSE= GPLv3
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-incompatible-pointer-types"
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libmarkdown.a:textproc/discount \
valac:lang/vala
LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
diff --git a/deskutils/xneur/Makefile b/deskutils/xneur/Makefile
index 8bd31e1b7fbb..6180149f3499 100644
--- a/deskutils/xneur/Makefile
+++ b/deskutils/xneur/Makefile
@@ -3,8 +3,8 @@
PORTNAME= xneur
PORTVERSION= 0.17.0
-PORTREVISION= 4
DISTVERSIONSUFFIX=.orig
+PORTREVISION= 4
CATEGORIES= deskutils
MASTER_SITES= https://launchpad.net/~andrew-crew-kuznetsov/+archive/xneur-stable/+files/
DISTNAME= ${PORTNAME}_${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
@@ -14,6 +14,8 @@ COMMENT= Auto keyboard switcher
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: text.c:272: nested functions are disabled, use -fnested-functions to re-enable
+
LIB_DEPENDS= libnotify.so:devel/libnotify \
libpcre.so:devel/pcre