aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-12-28 19:03:19 +0800
committerpawel <pawel@FreeBSD.org>2014-12-28 19:03:19 +0800
commitda3dae95e39e8f9c02c4aebb2714db8a15908fe8 (patch)
treed983846a5b646565607d489b2e9c4b78e62a46e8 /deskutils
parente971be3fe1be0499be4a8bc91142a6decea90873 (diff)
downloadfreebsd-ports-gnome-da3dae95e39e8f9c02c4aebb2714db8a15908fe8.tar.gz
freebsd-ports-gnome-da3dae95e39e8f9c02c4aebb2714db8a15908fe8.tar.zst
freebsd-ports-gnome-da3dae95e39e8f9c02c4aebb2714db8a15908fe8.zip
- Update to version 3.4.0
- Now hosted on github, new homepage - Add LICENSE PR: 193232 Submitted by: maintainer
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/cairo-dock/Makefile23
-rw-r--r--deskutils/cairo-dock/distinfo4
-rw-r--r--deskutils/cairo-dock/files/patch-CMakeLists.txt33
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock-applet-facility.c23
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock-file-manager.c14
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock-package-theme.sh11
-rw-r--r--deskutils/cairo-dock/files/patch-src_gldit_gldi-config.h.in11
-rw-r--r--deskutils/cairo-dock/pkg-descr2
-rw-r--r--deskutils/cairo-dock/pkg-plist30
9 files changed, 51 insertions, 100 deletions
diff --git a/deskutils/cairo-dock/Makefile b/deskutils/cairo-dock/Makefile
index bcf31f0a239f..d082d2b50cd2 100644
--- a/deskutils/cairo-dock/Makefile
+++ b/deskutils/cairo-dock/Makefile
@@ -1,15 +1,16 @@
# $FreeBSD$
PORTNAME= cairo-dock
-DISTVERSION= 3.2.1
-PORTREVISION= 5
+PORTVERSION= 3.4.0
CATEGORIES= deskutils
-MASTER_SITES= https://launchpadlibrarian.net/137290048/ \
- http://pazzle.otdux.com.ua/
+DISTNAME= ${PORTNAME}-core-${PORTVERSION}.git20141115
MAINTAINER= fidaj@ukr.net
COMMENT= Cairo-Dock is a light and eye-candy dock
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
libcurl.so:${PORTSDIR}/ftp/curl \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
@@ -17,16 +18,23 @@ LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
sox:${PORTSDIR}/audio/sox
-WRKSRC= ${WRKDIR}/${PORTNAME}-3.2.1
+USE_GITHUB= yes
+GH_ACCOUNT= Cairo-Dock
+GH_PROJECT= ${PORTNAME}-core
+GH_COMMIT= 18df440
+GH_TAGNAME= 18df440
+
+WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${PORTNAME}-core-${GH_COMMIT}
GNU_CONFIGURE= yes
-USE_GNOME= glib20 gtk20 librsvg2 libxml2
+USE_GNOME= glib20 gtk30 librsvg2 libxml2
USE_LDCONFIG= yes
USE_XORG= xrender xtst
USES= cmake gettext pathfix pkgconfig
LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS+= -Dinstall-pc-path:STRING="${LOCALBASE}/libdata/pkgconfig"
CMAKE_ARGS+= -DROOT_PREFIX:PATH=${STAGEDIR}
+CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR:PATH=man
post-patch:
@${FIND} ${WRKSRC} -type f -name "*" | ${XARGS} ${REINPLACE_CMD} -e \
@@ -37,4 +45,7 @@ post-patch:
s|/usr/share/icons|${LOCALBASE}/share/icons|g; \
s|%%LOCALBASE%%|${LOCALBASE}|g;'
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgldi.so.3.4.0
+
.include <bsd.port.mk>
diff --git a/deskutils/cairo-dock/distinfo b/deskutils/cairo-dock/distinfo
index a5314e7fe81c..6fafe6394752 100644
--- a/deskutils/cairo-dock/distinfo
+++ b/deskutils/cairo-dock/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cairo-dock-3.2.1.tar.gz) = 441e407f92138dc604c796b0455777b765e298ecb8f3120104f521d0e0b34543
-SIZE (cairo-dock-3.2.1.tar.gz) = 2593954
+SHA256 (cairo-dock-core-3.4.0.git20141115.tar.gz) = 68185ce5f25b8621c7ce1f252ce2710eb9239d9204ab9329d14ff0671f05b675
+SIZE (cairo-dock-core-3.4.0.git20141115.tar.gz) = 2895775
diff --git a/deskutils/cairo-dock/files/patch-CMakeLists.txt b/deskutils/cairo-dock/files/patch-CMakeLists.txt
deleted file mode 100644
index b2addfaf75cd..000000000000
--- a/deskutils/cairo-dock/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,33 +0,0 @@
---- ./CMakeLists.txt.orig 2013-04-05 00:40:07.000000000 +0300
-+++ ./CMakeLists.txt 2013-05-04 16:34:01.000000000 +0300
-@@ -69,7 +69,7 @@
- set (exec_prefix ${prefix})
- set (datadir "${prefix}/${CMAKE_INSTALL_DATAROOTDIR}") # (...)/share
- set (pkgdatadir "${datadir}/${CMAKE_PROJECT_NAME}") # (...)/cairo-dock
--set (mandir "${prefix}/${CMAKE_INSTALL_MANDIR}") # (...)/man
-+set (mandir "${prefix}/man") # (...)/man
-
- if( CMAKE_SIZEOF_VOID_P EQUAL 8 AND (force-lib64 OR "${FORCE_LIB64}" STREQUAL "yes")) # 64bits and force install in lib64
- set (libdir "${prefix}/lib64")
-@@ -90,7 +90,8 @@
-
- ########### dependencies ###############
-
--set (packages_required "glib-2.0 gthread-2.0 cairo librsvg-2.0 dbus-1 dbus-glib-1 libxml-2.0 xrender gl glu libcurl") # for the .pc and to have details
-+set (packages_required "glib-2.0 cairo librsvg-2.0 dbus-1 dbus-glib-1 libxml-2.0 xrender gl glu libcurl") # for the .pc and to have details
-+find_library (GTHREAD "gthread-2.0")
- STRING (REGEX REPLACE " " ";" packages_required_semicolon ${packages_required}) # replace blank space by semicolon => to have more details if a package is missing
- pkg_check_modules ("PACKAGE" REQUIRED "${packages_required_semicolon}")
-
-@@ -143,9 +144,9 @@
- endif()
-
- check_include_files ("dlfcn.h" HAVE_DLFCN_H)
--check_library_exists (dl dlopen "" HAVE_LIBDL)
-+check_library_exists (c dlopen "" HAVE_LIBDL)
- if (HAVE_LIBDL) # dlopen might be in libc directly as in FreeBSD
-- set (LIBDL_LIBRARIES "dl")
-+ set (LIBDL_LIBRARIES "c")
- endif()
- if (NOT HAVE_DLFCN_H)
- message(FATAL_ERROR "Cairo-Dock requires dlfcn.h")
diff --git a/deskutils/cairo-dock/files/patch-cairo-dock-applet-facility.c b/deskutils/cairo-dock/files/patch-cairo-dock-applet-facility.c
deleted file mode 100644
index 79b6d208189f..000000000000
--- a/deskutils/cairo-dock/files/patch-cairo-dock-applet-facility.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- ./src/gldit/cairo-dock-applet-facility.c.orig 2013-06-29 16:54:06.000000000 +0300
-+++ ./src/gldit/cairo-dock-applet-facility.c 2013-06-29 16:55:44.000000000 +0300
-@@ -225,14 +225,14 @@
- }
-
- gchar *cSoundCommand = NULL;
-- if (g_file_test ("/usr/bin/paplay", G_FILE_TEST_EXISTS))
-- cSoundCommand = g_strdup_printf("paplay --client-name=cairo-dock \"%s\"", cSoundPath);
-+ if (g_file_test ("%%LOCALBASE%%/bin/play", G_FILE_TEST_EXISTS))
-+ cSoundCommand = g_strdup_printf("play \"%s\"", cSoundPath);
-
-- else if (g_file_test ("/usr/bin/aplay", G_FILE_TEST_EXISTS))
-+ else if (g_file_test ("%%LOCALBASE%%/bin/paplay", G_FILE_TEST_EXISTS))
-+ cSoundCommand = g_strdup_printf("paplay --client-name=cairo-dock \"%s\"", cSoundPath);
-+
-+ else if (g_file_test ("%%LOCALBASE%%/bin/aplay", G_FILE_TEST_EXISTS))
- cSoundCommand = g_strdup_printf("aplay \"%s\"", cSoundPath);
--
-- else if (g_file_test ("/usr/bin/play", G_FILE_TEST_EXISTS))
-- cSoundCommand = g_strdup_printf("play \"%s\"", cSoundPath);
-
-
- cairo_dock_launch_command (cSoundCommand);
diff --git a/deskutils/cairo-dock/files/patch-cairo-dock-file-manager.c b/deskutils/cairo-dock/files/patch-cairo-dock-file-manager.c
new file mode 100644
index 000000000000..6a764949e1e8
--- /dev/null
+++ b/deskutils/cairo-dock/files/patch-cairo-dock-file-manager.c
@@ -0,0 +1,14 @@
+--- src/gldit/cairo-dock-file-manager.c.orig 2014-11-22 18:39:10.000000000 +0200
++++ src/gldit/cairo-dock-file-manager.c 2014-11-22 18:41:30.000000000 +0200
+@@ -21,7 +21,11 @@
+ #include <string.h> // memset
+ #include <sys/stat.h> // stat
+ #include <fcntl.h> // open
++#ifndef __FreeBSD__
+ #include <sys/sendfile.h> // sendfile
++#else
++#include <sys/socket.h>
++#endif
+ #include <errno.h> // errno
+
+ #include "gldi-config.h"
diff --git a/deskutils/cairo-dock/files/patch-cairo-dock-package-theme.sh b/deskutils/cairo-dock/files/patch-cairo-dock-package-theme.sh
deleted file mode 100644
index 0661ca5ec425..000000000000
--- a/deskutils/cairo-dock/files/patch-cairo-dock-package-theme.sh
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./data/scripts/cairo-dock-package-theme.sh.orig 2013-03-23 17:55:12.000000000 +0200
-+++ ./data/scripts/cairo-dock-package-theme.sh 2013-06-27 18:03:18.000000000 +0300
-@@ -125,7 +125,7 @@
- if test "x${theme}" != "x"; then
- #\__________ On cherche si ce theme est un theme officiel ou non.
- echo "un theme est present ($theme)"
-- wget "$THEME_SERVER/$3/list.conf" -O "liste.tmp" -t 3 -T 30
-+ fetch -o "liste.tmp" -T 30 "$THEME_SERVER/$3/list.conf"
- if test -f "liste.tmp" ; then
- grep "^\[${theme}\]" "liste.tmp"
- if test "$?" != "0" -a "$theme" != "Classic" -a "$theme" != "default"; then # pas un theme officiel
diff --git a/deskutils/cairo-dock/files/patch-src_gldit_gldi-config.h.in b/deskutils/cairo-dock/files/patch-src_gldit_gldi-config.h.in
deleted file mode 100644
index d5bca4ddaf09..000000000000
--- a/deskutils/cairo-dock/files/patch-src_gldit_gldi-config.h.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/gldit/gldi-config.h.in.orig 2013-05-04 16:23:45.000000000 +0300
-+++ ./src/gldit/gldi-config.h.in 2013-05-04 16:23:57.000000000 +0300
-@@ -12,7 +12,7 @@
- #cmakedefine HAVE_LIBCRYPT @HAVE_LIBCRYPT@
-
- /* Define to 1 if you have the `dl' library (-ldl). */
--#cmakedefine HAVE_LIBDL @HAVE_LIBDL@
-+//#cmakedefine HAVE_LIBDL @HAVE_LIBDL@
-
- /* Define to 1 if you have the <dlfcn.h> header file. */
- #cmakedefine HAVE_DLFCN_H @HAVE_DLFCN_H@
diff --git a/deskutils/cairo-dock/pkg-descr b/deskutils/cairo-dock/pkg-descr
index 4dabd5a3d8f2..acce8243648c 100644
--- a/deskutils/cairo-dock/pkg-descr
+++ b/deskutils/cairo-dock/pkg-descr
@@ -3,4 +3,4 @@ Cairo / OpenGL to render nice graphics (many in correlation with Compiz) with
hardware acceleration. It's fully configurable and customizable and can be a
taskbar too. You can easily plug applets into it or in a desklet mode.
-WWW: https://launchpad.net/cairo-dock
+WWW: http://www.glx-dock.org/
diff --git a/deskutils/cairo-dock/pkg-plist b/deskutils/cairo-dock/pkg-plist
index fc45e6478e9b..da9106850c21 100644
--- a/deskutils/cairo-dock/pkg-plist
+++ b/deskutils/cairo-dock/pkg-plist
@@ -1,7 +1,5 @@
bin/cairo-dock
include/cairo-dock/cairo-dock.h
-include/cairo-dock/gldit/cairo-dock-X-manager.h
-include/cairo-dock/gldit/cairo-dock-X-utilities.h
include/cairo-dock/gldit/cairo-dock-animations.h
include/cairo-dock/gldit/cairo-dock-applet-canvas.h
include/cairo-dock/gldit/cairo-dock-applet-facility.h
@@ -11,7 +9,7 @@ include/cairo-dock/gldit/cairo-dock-applet-single-instance.h
include/cairo-dock/gldit/cairo-dock-application-facility.h
include/cairo-dock/gldit/cairo-dock-applications-manager.h
include/cairo-dock/gldit/cairo-dock-backends-manager.h
-include/cairo-dock/gldit/cairo-dock-callbacks.h
+include/cairo-dock/gldit/cairo-dock-class-icon-manager.h
include/cairo-dock/gldit/cairo-dock-class-manager.h
include/cairo-dock/gldit/cairo-dock-config.h
include/cairo-dock/gldit/cairo-dock-container.h
@@ -21,6 +19,7 @@ include/cairo-dock/gldit/cairo-dock-data-renderer.h
include/cairo-dock/gldit/cairo-dock-dbus.h
include/cairo-dock/gldit/cairo-dock-desklet-factory.h
include/cairo-dock/gldit/cairo-dock-desklet-manager.h
+include/cairo-dock/gldit/cairo-dock-desktop-manager.h
include/cairo-dock/gldit/cairo-dock-dialog-factory.h
include/cairo-dock/gldit/cairo-dock-dialog-manager.h
include/cairo-dock/gldit/cairo-dock-dock-facility.h
@@ -43,9 +42,9 @@ include/cairo-dock/gldit/cairo-dock-keyfile-utilities.h
include/cairo-dock/gldit/cairo-dock-launcher-manager.h
include/cairo-dock/gldit/cairo-dock-log.h
include/cairo-dock/gldit/cairo-dock-manager.h
-include/cairo-dock/gldit/cairo-dock-module-factory.h
+include/cairo-dock/gldit/cairo-dock-menu.h
+include/cairo-dock/gldit/cairo-dock-module-instance-manager.h
include/cairo-dock/gldit/cairo-dock-module-manager.h
-include/cairo-dock/gldit/cairo-dock-notifications.h
include/cairo-dock/gldit/cairo-dock-object.h
include/cairo-dock/gldit/cairo-dock-opengl-font.h
include/cairo-dock/gldit/cairo-dock-opengl-path.h
@@ -54,24 +53,25 @@ include/cairo-dock/gldit/cairo-dock-overlay.h
include/cairo-dock/gldit/cairo-dock-packages.h
include/cairo-dock/gldit/cairo-dock-particle-system.h
include/cairo-dock/gldit/cairo-dock-separator-manager.h
+include/cairo-dock/gldit/cairo-dock-stack-icon-manager.h
include/cairo-dock/gldit/cairo-dock-struct.h
+include/cairo-dock/gldit/cairo-dock-style-facility.h
+include/cairo-dock/gldit/cairo-dock-style-manager.h
include/cairo-dock/gldit/cairo-dock-surface-factory.h
include/cairo-dock/gldit/cairo-dock-task.h
include/cairo-dock/gldit/cairo-dock-themes-manager.h
+include/cairo-dock/gldit/cairo-dock-user-icon-manager.h
+include/cairo-dock/gldit/cairo-dock-utils.h
+include/cairo-dock/gldit/cairo-dock-windows-manager.h
include/cairo-dock/gldit/gldi-config.h
-include/cairo-dock/icon-factory/cairo-dock-applet-factory.h
-include/cairo-dock/icon-factory/cairo-dock-application-factory.h
-include/cairo-dock/icon-factory/cairo-dock-desktop-file-factory.h
-include/cairo-dock/icon-factory/cairo-dock-launcher-factory.h
-include/cairo-dock/icon-factory/cairo-dock-separator-factory.h
+include/cairo-dock/gldit/gldi-icon-names.h
include/cairo-dock/implementations/cairo-dock-gauge.h
include/cairo-dock/implementations/cairo-dock-graph.h
include/cairo-dock/implementations/cairo-dock-progressbar.h
lib/cairo-dock/libcd-Help.so
lib/libgldi.so
lib/libgldi.so.3
-lib/libgldi.so.3.2.1
-libdata/pkgconfig/cairo-dock.pc
+lib/libgldi.so.3.4.0
libdata/pkgconfig/gldi.pc
man/man1/cairo-dock.1.gz
share/applications/cairo-dock-cairo.desktop
@@ -108,9 +108,10 @@ share/applications/cairo-dock.desktop
%%DATADIR%%/icons/icon-close.svg
%%DATADIR%%/icons/icon-connection.svg
%%DATADIR%%/icons/icon-controler.svg
-%%DATADIR%%/icons/icon-desklets.png
+%%DATADIR%%/icons/icon-desklets.svg
%%DATADIR%%/icons/icon-desktop.svg
%%DATADIR%%/icons/icon-dialogs.svg
+%%DATADIR%%/icons/icon-docks.svg
%%DATADIR%%/icons/icon-extensions.svg
%%DATADIR%%/icons/icon-files.svg
%%DATADIR%%/icons/icon-frame.png
@@ -130,6 +131,8 @@ share/applications/cairo-dock.desktop
%%DATADIR%%/icons/icon-plug-ins.svg
%%DATADIR%%/icons/icon-position.svg
%%DATADIR%%/icons/icon-restore.svg
+%%DATADIR%%/icons/icon-shortkeys.svg
+%%DATADIR%%/icons/icon-style.svg
%%DATADIR%%/icons/icon-subdock.png
%%DATADIR%%/icons/icon-system.svg
%%DATADIR%%/icons/icon-taskbar.png
@@ -277,6 +280,7 @@ share/locale/sr@latin/LC_MESSAGES/cairo-dock.mo
share/locale/sv/LC_MESSAGES/cairo-dock.mo
share/locale/tr/LC_MESSAGES/cairo-dock.mo
share/locale/uk/LC_MESSAGES/cairo-dock.mo
+share/locale/uz/LC_MESSAGES/cairo-dock.mo
share/locale/vi/LC_MESSAGES/cairo-dock.mo
share/locale/zh_CN/LC_MESSAGES/cairo-dock.mo
share/locale/zh_TW/LC_MESSAGES/cairo-dock.mo