aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2009-07-23 17:51:27 +0800
committergahr <gahr@FreeBSD.org>2009-07-23 17:51:27 +0800
commitf340af734d3c852e55c2b78840071c327112d0ac (patch)
tree9c1bdc1762a953e837c612b172f0a5e7d1fc21a8 /deskutils
parent9e4c4be7557abebd93d5691f3cdc9b1fe090d019 (diff)
downloadfreebsd-ports-gnome-f340af734d3c852e55c2b78840071c327112d0ac.tar.gz
freebsd-ports-gnome-f340af734d3c852e55c2b78840071c327112d0ac.tar.zst
freebsd-ports-gnome-f340af734d3c852e55c2b78840071c327112d0ac.zip
- Fix build on 32-bit platforms (temporary quick & dirty fix)
PR: 137028 Submitted by: Charlie Kester <corky1951@comcast.net>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/taskwarrior/Makefile8
-rw-r--r--deskutils/taskwarrior/files/extra-32bit25
2 files changed, 32 insertions, 1 deletions
diff --git a/deskutils/taskwarrior/Makefile b/deskutils/taskwarrior/Makefile
index dbae78cd2102..ac17dcb274d0 100644
--- a/deskutils/taskwarrior/Makefile
+++ b/deskutils/taskwarrior/Makefile
@@ -21,6 +21,12 @@ GNU_CONFIGURE= yes
MAN1= task.1
MAN5= taskrc.5 task-tutorial.5
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+EXTRA_PATCHES= ${PATCHDIR}/extra-32bit
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|%%DOCSDIR%%|${DOCSDIR}|; s|%%DATADIR%%|${DATADIR}|' \
${WRKSRC}/Makefile.in
@@ -28,4 +34,4 @@ post-patch:
${REINPLACE_CMD} -e '341,348d' ${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/taskwarrior/files/extra-32bit b/deskutils/taskwarrior/files/extra-32bit
new file mode 100644
index 000000000000..1e8e3a297697
--- /dev/null
+++ b/deskutils/taskwarrior/files/extra-32bit
@@ -0,0 +1,25 @@
+--- src/Duration.h.orig 2009-07-23 11:41:40.000000000 +0200
++++ src/Duration.h 2009-07-23 11:51:08.000000000 +0200
+@@ -40,7 +40,6 @@
+ bool operator> (const Duration&);
+ ~Duration (); // Destructor
+
+- operator int ();
+ operator time_t ();
+ operator std::string ();
+
+--- src/Duration.cpp.orig 2009-07-23 11:41:44.000000000 +0200
++++ src/Duration.cpp 2009-07-23 11:51:28.000000000 +0200
+@@ -52,12 +52,6 @@
+ }
+
+ ////////////////////////////////////////////////////////////////////////////////
+-Duration::operator int ()
+-{
+- return (int) mDays;
+-}
+-
+-////////////////////////////////////////////////////////////////////////////////
+ Duration::operator time_t ()
+ {
+ return mDays;