aboutsummaryrefslogtreecommitdiffstats
path: root/devel/adacurses/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-10-09 10:58:20 +0800
committermarino <marino@FreeBSD.org>2016-10-09 10:58:20 +0800
commit5e1a24c6cb6b7831b982143badb8b9d1a42373f7 (patch)
tree5449fa12c7f022071b8defe919a0de8490c5cef0 /devel/adacurses/Makefile
parent3aec778846463bdeb23aaa7a767d79dd61cdbce4 (diff)
downloadfreebsd-ports-gnome-5e1a24c6cb6b7831b982143badb8b9d1a42373f7.tar.gz
freebsd-ports-gnome-5e1a24c6cb6b7831b982143badb8b9d1a42373f7.tar.zst
freebsd-ports-gnome-5e1a24c6cb6b7831b982143badb8b9d1a42373f7.zip
devel/adacurses: Prevent building with base ncurses headers
It turns out that the C source files were getting built with the headers from the base ncurses. The recent update in Synth's display exposed a resulting problem with the add chtype routines, resulting in garbled output. Since adacurses is a static library, synth requires a revbump.
Diffstat (limited to 'devel/adacurses/Makefile')
-rw-r--r--devel/adacurses/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/adacurses/Makefile b/devel/adacurses/Makefile
index dbdb188973b1..054501e22b54 100644
--- a/devel/adacurses/Makefile
+++ b/devel/adacurses/Makefile
@@ -3,7 +3,7 @@
PORTNAME= adacurses
PORTVERSION= 20150808
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= ftp://invisible-island.net/AdaCurses/
DISTNAME= AdaCurses-${PORTVERSION}
@@ -13,10 +13,11 @@ COMMENT= Ada95 bindings for ncurses
LICENSE= MIT
-USES= ada gmake ncurses:port tar:tgz
+USES= ada gmake pkgconfig ncurses:port tar:tgz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ada-include=${PREFIX}/include/adacurses \
--with-ada-objects=${PREFIX}/lib/adacurses \
+ --with-curses-dir=${NCURSESBASE} \
--libdir=${PREFIX}/lib/adacurses \
--enable-widec
PORTDOCS= ada Ada95.html
@@ -41,7 +42,7 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/gen/adacurses-config \
${STAGEDIR}${PREFIX}/bin/
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat
- ${SED} "s|@PREFIX@|${PREFIX}|g" ${FILESDIR}/adacurses.gpr.in > \
+ ${SED} "s|@PREFIX@|${NCURSESBASE}|g" ${FILESDIR}/adacurses.gpr.in > \
${STAGEDIR}${PREFIX}/lib/gnat/adacurses.gpr
do-install-DOCS-on: