aboutsummaryrefslogtreecommitdiffstats
path: root/devel/android-tools-fastboot
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-06-18 09:46:34 +0800
committerjbeich <jbeich@FreeBSD.org>2015-06-18 09:46:34 +0800
commit6d77e4f0d0fa5e1daccde822c69897f59b44cd81 (patch)
treea555ca0fa47706d536ddaade4e5b8f1e01359e42 /devel/android-tools-fastboot
parent149654c0cf4bd86374f2598bfcb4986c6b40004a (diff)
downloadfreebsd-ports-gnome-6d77e4f0d0fa5e1daccde822c69897f59b44cd81.tar.gz
freebsd-ports-gnome-6d77e4f0d0fa5e1daccde822c69897f59b44cd81.tar.zst
freebsd-ports-gnome-6d77e4f0d0fa5e1daccde822c69897f59b44cd81.zip
devel/android-tools-fastboot: shuffle CFLAGS to unbreak DragonFly
Avoid stepping into OS X platform code with off64_t workaround. cc ... -D__APPLE__ -D__MACH__ .../ext4_utils/ext4_utils.c In file included from .../ext4_utils/ext4_utils.c:43:0: /usr/include/sys/disk.h:49:2: error: #error "This file should not be included by userland programs." #error "This file should not be included by userland programs." ^ *** [ext4_utils.o] Error code 1 Reported by: DPorts
Diffstat (limited to 'devel/android-tools-fastboot')
-rw-r--r--devel/android-tools-fastboot/files/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/android-tools-fastboot/files/Makefile b/devel/android-tools-fastboot/files/Makefile
index fc74fe740f86..b2830f1471b4 100644
--- a/devel/android-tools-fastboot/files/Makefile
+++ b/devel/android-tools-fastboot/files/Makefile
@@ -36,6 +36,7 @@ SRCS+= init.c
SRCS+= label.c
SRCS+= label_android_property.c
SRCS+= label_file.c
+CFLAGS.init.c+= -DDARWIN # statfs
.PATH: ${.CURDIR}/../libsparse
SRCS+= backed_block.c
@@ -48,10 +49,13 @@ SRCS+= sparse_read.c
.PATH: ${.CURDIR}/../libzipfile
SRCS+= centraldir.c
SRCS+= zipfile.c
+CFLAGS.centraldir.c+= -Ulseek64 # utils/Compat.h
CFLAGS+=-D_FILE_OFFSET_BITS=64 # utils/Compat.h
-CFLAGS+=-D__APPLE__ -D__MACH__ # off64_t
-CFLAGS+=-DDARWIN # statfs
+CFLAGS+=-Doff64_t=off_t
+CFLAGS+=-Dftruncate64=ftruncate
+CFLAGS+=-Dlseek64=lseek
+CFLAGS+=-Dmmap64=mmap
CFLAGS+=-I${.CURDIR}
CFLAGS+=-I${.CURDIR}/../include
CFLAGS+=-I${.CURDIR}/../mkbootimg
@@ -59,6 +63,7 @@ CFLAGS+=-I${.CURDIR}/../ext4_utils
CFLAGS+=-I${.CURDIR}/../f2fs_utils
CFLAGS+=-I${.CURDIR}/../libselinux/include
CFLAGS+=-I${.CURDIR}/../libsparse/include
+CFLAGS+=${CFLAGS.${.IMPSRC:T}}
LDADD+= -lpcre -lusb -lz
DPADD+= ${LIBPCRE} ${LIBUSB} ${LIBZ}