aboutsummaryrefslogtreecommitdiffstats
path: root/devel/apr2
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2006-02-28 13:56:43 +0800
committerade <ade@FreeBSD.org>2006-02-28 13:56:43 +0800
commit7b4c5cc839964fd826138e897e2fcace1cec21a9 (patch)
tree0e66decbeab2776738a6ac95425f3887eca31e59 /devel/apr2
parent483fe24a4ffe1e2dc1914067bf0bb3f3825b0f66 (diff)
downloadfreebsd-ports-gnome-7b4c5cc839964fd826138e897e2fcace1cec21a9.tar.gz
freebsd-ports-gnome-7b4c5cc839964fd826138e897e2fcace1cec21a9.tar.zst
freebsd-ports-gnome-7b4c5cc839964fd826138e897e2fcace1cec21a9.zip
Fix build when bash is installed, by changing the (incorrect) usage
of SCRIPTS_ENV to CONFIGURE_ENV. This works around the problem and makes this port build now, but there is almost certainly something very strange going on with any one of the recent updates to ports/shells/bash and it's handling of arguments passed to configure scripts, since this most definitely used to work. Detective work by: Ion-Mihai Tetcu <itetcu@people.tecnik93.com> Approved by: portmgr (implicit)
Diffstat (limited to 'devel/apr2')
-rw-r--r--devel/apr2/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 6c71689bba09..ef33fce9f6bb 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -143,16 +143,17 @@ pre-configure:
.endfor
run-autotools::
- cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf
+ cd ${WRKDIR}/apr-${PORTVERSION} ; \
+ ${SETENV} ${CONFIGURE_ENV} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
- ${RM} -fr xml/expat
+ ${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
- ${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf \
+ ${SETENV} ${CONFIGURE_ENV} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
cd ${WRKDIR}/apr-${PORTVERSION}; \
- ${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
+ ${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
cd ${WRKDIR}/apr-util-${PORTVERSION}; \
- ${SETENV} ${SCRIPTS_ENV} ${SH} \
+ ${SETENV} ${CONFIGURE_ENV} ${SH} \
./configure ${CONFIGURE_ARGS} ${APR_UTIL_CONF_ARGS}
do-configure: