aboutsummaryrefslogtreecommitdiffstats
path: root/devel/asl
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-21 04:20:33 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-21 04:20:33 +0800
commit5da6577550a0f7b3e964b5c419615a5d0bafd5ff (patch)
tree1bd34bc29214fc257c337b460ce0a95914b73ee8 /devel/asl
parent304aa2585c79c9a05265a62538fd0015d1801d0e (diff)
downloadfreebsd-ports-gnome-5da6577550a0f7b3e964b5c419615a5d0bafd5ff.tar.gz
freebsd-ports-gnome-5da6577550a0f7b3e964b5c419615a5d0bafd5ff.tar.zst
freebsd-ports-gnome-5da6577550a0f7b3e964b5c419615a5d0bafd5ff.zip
- Resurrect devel/asl: Assembler for a variety of microcontrollers/-processors
- Stagify - Pass maintainership to submitter ASL can generate code for totally different processors. These are implemented: Motorola 68000..68030,683xx including math co-processor and MMU; DSP56000; Motorola/IBM MPC601/MPC505/PPC403; 6800, 6805, 6809, 68(HC)11 and Hitachi 6301 Hitachi 6309, H8 and SH7000/7600 Rockwell 6502 and 65(S)C02 CMD 65816 Mitsubishi MELPS-740; MELPS-7700; MELPS-4500 and M16 Intel MCS-48/41, MCS-51, MCS-96 and 8080/8085 AMD 29K Siemens 80C166/167 Zilog Z80, Z180, Z380 and Z8 Toshiba TLCS-900(L), TLCS-90, TLCS-870, TLCS-47 and TLCS-9000 Microchip PIC16C54..16C57, PIC16C84/PIC16C64 and PIC17C42 SGS-Thomson ST62xx and 6804 Texas Instruments TMS32010/32015, TMS3202x, TMS320C3x and TMS370xxx NEC uPD 78(C)1x and uPD 75xxx (a.k.a. 75K0) WWW: http://john.ccac.rwth-aachen.de:8000/as/ PR: 189648 Submitted by: "Daniel O'Connor" <doconnor@gsoft.com.au>
Diffstat (limited to 'devel/asl')
-rw-r--r--devel/asl/Makefile28
-rw-r--r--devel/asl/distinfo2
-rw-r--r--devel/asl/files/Makefile.def33
-rw-r--r--devel/asl/files/patch-Makefile11
-rw-r--r--devel/asl/files/patch-as.c16
-rw-r--r--devel/asl/files/patch-sysdefs.h68
-rw-r--r--devel/asl/pkg-descr20
-rw-r--r--devel/asl/pkg-plist61
8 files changed, 239 insertions, 0 deletions
diff --git a/devel/asl/Makefile b/devel/asl/Makefile
new file mode 100644
index 000000000000..8b7e96881a41
--- /dev/null
+++ b/devel/asl/Makefile
@@ -0,0 +1,28 @@
+# Created by: Thomas Gellekum <tg@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= asl
+PORTVERSION= 1.41r8
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ ftp://john.ccac.rwth-aachen.de/pub/as/source/c_version/
+MASTER_SITE_SUBDIR= devel/lang/assemblers
+
+MAINTAINER= doconnor@gsoft.com.au
+COMMENT= Assembler for a variety of microcontrollers/-processors
+
+ONLY_FOR_ARCHS= i386 alpha amd64
+
+MAKE_ENV+= STAGEDIR=${STAGEDIR}
+
+post-extract:
+ ${CP} ${FILESDIR}/Makefile.def ${WRKSRC}
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/mkdirhier/mkdir \-p/' ${WRKSRC}/install.sh
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/asl
+ ${INSTALL_DATA} ${WRKSRC}/doc_EN/* ${STAGEDIR}${PREFIX}/share/doc/asl
+
+.include <bsd.port.mk>
diff --git a/devel/asl/distinfo b/devel/asl/distinfo
new file mode 100644
index 000000000000..23f377a4c2d6
--- /dev/null
+++ b/devel/asl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (asl-1.41r8.tar.gz) = 22ff3f3ccf7c3005b6f8f9014773905b309e3a8942a3a6a8fc911c8648a42345
+SIZE (asl-1.41r8.tar.gz) = 1411331
diff --git a/devel/asl/files/Makefile.def b/devel/asl/files/Makefile.def
new file mode 100644
index 000000000000..c0124fde3a8d
--- /dev/null
+++ b/devel/asl/files/Makefile.def
@@ -0,0 +1,33 @@
+# -------------------------------------------------------------------------
+# choose your compiler (must be ANSI-compliant!) and linker command, plus
+# any additionally needed flags
+
+LD = ${CC}
+LDFLAGS = -s
+
+# -------------------------------------------------------------------------
+# directories where binaries and includes should go during installation
+
+BINDIR = ${STAGEDIR}/${PREFIX}/bin
+# *INST are where things are installed to, vs where they are searched for
+INCDIR = ${PREFIX}/share/asl
+INCDIRINST = ${STAGEDIR}/${PREFIX}/share/asl
+LIBDIR = ${PREFIX}/share/asl
+LIBDIRINST = ${STAGEDIR}/${PREFIX}/share/asl
+MANDIR = ${STAGEDIR}/${PREFIX}/man
+DOCDIR =
+
+# -------------------------------------------------------------------------
+# language AS will speak to you
+# implemented so far:
+# lang_DE = german
+# lang_EN = english
+
+LANGRSC = lang_EN
+
+# -------------------------------------------------------------------------
+# character encoding to use (choose one of them)
+
+# CHARSET = CHARSET_ASCII7
+# CHARSET = CHARSET_IBM437
+CHARSET = CHARSET_ISO8859_1
diff --git a/devel/asl/files/patch-Makefile b/devel/asl/files/patch-Makefile
new file mode 100644
index 000000000000..bcc969767de2
--- /dev/null
+++ b/devel/asl/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 1999-08-01 07:11:01.000000000 +0930
++++ Makefile 2014-05-11 14:46:32.794473751 +0930
+@@ -60,7 +60,7 @@
+ cd tests; ./testall
+
+ install: $(ALLTARGETS)
+- ./install.sh $(BINDIR) $(INCDIR) $(MANDIR) $(LIBDIR) $(DOCDIR)
++ ./install.sh $(BINDIR) $(INCDIRINST) $(MANDIR) $(LIBDIRINST) $(DOCDIR)
+
+ clean:
+ rm -f $(ALLTARGETS) $(RESCOMPTARGET) $(TEX2DOCTARGET) $(TEX2HTMLTARGET) *.$(OBJEXTENSION) *.p *.rsc tests/testlog
diff --git a/devel/asl/files/patch-as.c b/devel/asl/files/patch-as.c
new file mode 100644
index 000000000000..404d3b9cc65d
--- /dev/null
+++ b/devel/asl/files/patch-as.c
@@ -0,0 +1,16 @@
+--- as.c.orig Sat May 9 15:13:05 1998
++++ as.c Fri Dec 11 17:14:47 1998
+@@ -2577,6 +2577,13 @@
+
+ ParamCount=argc-1; ParamStr=argv;
+
++ if (ParamCount == 0)
++ BEGIN
++ fprintf(stderr, "Usage: %s [ option(s) ] file(s) [ option(s) ] file(s)\n",
++ argv[0]);
++ exit(0);
++ END
++
+ if (First)
+ BEGIN
+ endian_init(); nls_init(); bpemu_init(); stdhandl_init();
diff --git a/devel/asl/files/patch-sysdefs.h b/devel/asl/files/patch-sysdefs.h
new file mode 100644
index 000000000000..ebc688f7fbc4
--- /dev/null
+++ b/devel/asl/files/patch-sysdefs.h
@@ -0,0 +1,68 @@
+--- sysdefs.h.orig 1998-11-03 23:12:15.000000000 +0100
++++ sysdefs.h 2009-03-17 14:25:05.000000000 +0100
+@@ -524,6 +524,26 @@
+ #define LOCALE_NLS
+ #endif
+
++#ifdef __FreeBSD__
++#define ARCHSYSNAME "unknown-freebsd"
++#define DEFSMADE
++#define OPENRDMODE "r"
++#define OPENWRMODE "w"
++#define OPENUPMODE "r+"
++#define IEEEFLOAT
++typedef signed char Integ8;
++typedef unsigned char Card8;
++typedef signed short Integ16;
++typedef unsigned short Card16;
++#define HAS16
++typedef signed int Integ32;
++typedef unsigned int Card32;
++typedef signed long Integ64;
++typedef unsigned long Card64;
++#define HAS64
++#define NO_NLS
++#endif
++
+ #endif /* __alpha */
+
+ /*===========================================================================*/
+@@ -725,6 +745,38 @@
+ #endif /* __i386 */
+
+ /*===========================================================================*/
++/* AMD opteron/athlon64/k8 platforms */
++
++#ifdef __amd64__
++
++#define ARCHPRNAME "amd64"
++
++/*---------------------------------------------------------------------------*/
++/* amd64 with FreeBSD and GCC: */
++
++#ifdef __FreeBSD__
++#define ARCHSYSNAME "unknown-freebsd"
++#define DEFSMADE
++#define OPENRDMODE "r"
++#define OPENWRMODE "w"
++#define OPENUPMODE "r+"
++#define IEEEFLOAT
++typedef signed char Integ8;
++typedef unsigned char Card8;
++typedef signed short Integ16;
++typedef unsigned short Card16;
++#define HAS16
++typedef signed int Integ32;
++typedef unsigned int Card32;
++typedef signed long Integ64;
++typedef unsigned long Card64;
++#define HAS64
++#define LOCALE_NLS
++#endif
++
++#endif /* __amd64__ */
++
++/*===========================================================================*/
+ /* Misc... */
+
+ /*---------------------------------------------------------------------------*/
diff --git a/devel/asl/pkg-descr b/devel/asl/pkg-descr
new file mode 100644
index 000000000000..6d5c0bc2d2b4
--- /dev/null
+++ b/devel/asl/pkg-descr
@@ -0,0 +1,20 @@
+ASL can generate code for totally different processors. These are implemented:
+
+Motorola 68000..68030,683xx including math co-processor and MMU; DSP56000;
+ Motorola/IBM MPC601/MPC505/PPC403; 6800, 6805, 6809, 68(HC)11 and
+ Hitachi 6301
+Hitachi 6309, H8 and SH7000/7600
+Rockwell 6502 and 65(S)C02
+CMD 65816
+Mitsubishi MELPS-740; MELPS-7700; MELPS-4500 and M16
+Intel MCS-48/41, MCS-51, MCS-96 and 8080/8085
+AMD 29K
+Siemens 80C166/167
+Zilog Z80, Z180, Z380 and Z8
+Toshiba TLCS-900(L), TLCS-90, TLCS-870, TLCS-47 and TLCS-9000
+Microchip PIC16C54..16C57, PIC16C84/PIC16C64 and PIC17C42
+SGS-Thomson ST62xx and 6804
+Texas Instruments TMS32010/32015, TMS3202x, TMS320C3x and TMS370xxx
+NEC uPD 78(C)1x and uPD 75xxx (a.k.a. 75K0)
+
+WWW: http://john.ccac.rwth-aachen.de:8000/as/
diff --git a/devel/asl/pkg-plist b/devel/asl/pkg-plist
new file mode 100644
index 000000000000..dd835fcae742
--- /dev/null
+++ b/devel/asl/pkg-plist
@@ -0,0 +1,61 @@
+bin/asl
+bin/p2hex
+bin/p2bin
+bin/pbind
+bin/plist
+man/man1/asl.1.gz
+man/man1/p2bin.1.gz
+man/man1/p2hex.1.gz
+man/man1/pbind.1.gz
+man/man1/plist.1.gz
+share/asl/80c50x.inc
+share/asl/80c552.inc
+share/asl/as.msg
+share/asl/bitfuncs.inc
+share/asl/cmdarg.msg
+share/asl/ctype.inc
+share/asl/h8_3048.inc
+share/asl/ioerrs.msg
+share/asl/p2bin.msg
+share/asl/p2hex.msg
+share/asl/pbind.msg
+share/asl/plist.msg
+share/asl/reg166.inc
+share/asl/reg251.inc
+share/asl/reg29k.inc
+share/asl/reg53x.inc
+share/asl/reg683xx.inc
+share/asl/reg7000.inc
+share/asl/reg78k0.inc
+share/asl/reg96.inc
+share/asl/regavr.inc
+share/asl/regcop8.inc
+share/asl/reghc12.inc
+share/asl/regm16c.inc
+share/asl/regmsp.inc
+share/asl/regst9.inc
+share/asl/regz380.inc
+share/asl/stddef04.inc
+share/asl/stddef16.inc
+share/asl/stddef17.inc
+share/asl/stddef18.inc
+share/asl/stddef2x.inc
+share/asl/stddef37.inc
+share/asl/stddef3x.inc
+share/asl/stddef47.inc
+share/asl/stddef51.inc
+share/asl/stddef56k.inc
+share/asl/stddef5x.inc
+share/asl/stddef60.inc
+share/asl/stddef62.inc
+share/asl/stddef75.inc
+share/asl/stddef87.inc
+share/asl/stddef90.inc
+share/asl/stddef96.inc
+share/asl/stddefxa.inc
+share/asl/stddefz8.inc
+share/asl/tools.msg
+share/doc/asl/Makefile
+share/doc/asl/as.tex
+@dirrm share/asl
+@dirrm share/doc/asl