aboutsummaryrefslogtreecommitdiffstats
path: root/devel/bicyclerepair/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-12 15:30:13 +0800
committerpav <pav@FreeBSD.org>2005-09-12 15:30:13 +0800
commitb3e663f9c3c4aa066a17758cc23183a47e5dd5cb (patch)
tree087f658beecc91a152bf1cc6f77337318f822edb /devel/bicyclerepair/Makefile
parentd66d519ba1b47c49fcbcc16bedbea9c612663d4e (diff)
downloadfreebsd-ports-gnome-b3e663f9c3c4aa066a17758cc23183a47e5dd5cb.tar.gz
freebsd-ports-gnome-b3e663f9c3c4aa066a17758cc23183a47e5dd5cb.tar.zst
freebsd-ports-gnome-b3e663f9c3c4aa066a17758cc23183a47e5dd5cb.zip
- Update to 0.9
PR: ports/85999 Submitted by: Mike Meyer <mwm@mired.org> (maintainer)
Diffstat (limited to 'devel/bicyclerepair/Makefile')
-rw-r--r--devel/bicyclerepair/Makefile31
1 files changed, 14 insertions, 17 deletions
diff --git a/devel/bicyclerepair/Makefile b/devel/bicyclerepair/Makefile
index cb46a5046cd1..61a434b2736d 100644
--- a/devel/bicyclerepair/Makefile
+++ b/devel/bicyclerepair/Makefile
@@ -6,35 +6,32 @@
#
PORTNAME= bicyclerepair
-PORTVERSION= 0.7.1
+PORTVERSION= 0.9
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
+PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
MAINTAINER= mwm@mired.org
COMMENT= A python refactoring tool
-USE_PYTHON= yes
+USE_PYTHON= 2.2+
USE_PYDISTUTILS=yes
-USE_PYTHON_PREFIX=yes
-DOCDIR= ${PYTHONBASE}/share/bicyclerepairman
-
-PYVERSION= ${PYTHON_VERSION:S/^python//}
-.if defined(PYTHON_VERSION) && ${PYVERSION:S/.//} < 22
-.undef NO_IGNORE
-BROKEN= This port requires python 2.2 or later
-.endif # defined(PYVERSION) && ${PYVERSION:S/.//} < 22
+.if defined(EMACS_PORT_NAME)
+RUN_DEPENDS+= ${LOCALBASE}/bin/pymacs-services:${PORTSDIR}/devel/pymacs
+.endif
+.if !defined(NOPORTDOCS)
post-install:
- @${RM} ${PYTHONBASE}/bin/bikeemacs.bat
- @${MKDIR} ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/ide-integration/bike.el ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.emacs ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.idle ${DOCDIR}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ide-integration/bike.vim ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.emacs ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.idle ${DOCSDIR}
@${ECHO} "================================================================"
- @${ECHO} "* See" ${DOCDIR} "for instructions on configuring IDLE"
- @${ECHO} "* and emacs to use Bicycle Repair Man."
+ @${ECHO} "* See" ${DOCSDIR} "for instructions on configuring IDLE"
+ @${ECHO} "* and vim to use Bicycle Repair Man."
@${ECHO} "================================================================"
+.endif
.include <bsd.port.mk>