aboutsummaryrefslogtreecommitdiffstats
path: root/devel/binutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-08-30 07:22:53 +0800
committerbapt <bapt@FreeBSD.org>2014-08-30 07:22:53 +0800
commitfe120cfe60223672283739b49709bb5573136e51 (patch)
tree6e6712cdbc30c6d24ed7cfca325404d391c3922a /devel/binutils
parentdc8df4bcb6576e6b2c5d9e26f9dec9676bc220a2 (diff)
downloadfreebsd-ports-gnome-fe120cfe60223672283739b49709bb5573136e51.tar.gz
freebsd-ports-gnome-fe120cfe60223672283739b49709bb5573136e51.tar.zst
freebsd-ports-gnome-fe120cfe60223672283739b49709bb5573136e51.zip
Make the port ready to have slave ports for cross building targets
Diffstat (limited to 'devel/binutils')
-rw-r--r--devel/binutils/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index b85f9e484c21..009b5dc078fc 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -3,13 +3,13 @@
PORTNAME= binutils
PORTVERSION= 2.24
-PORTREVISION= 1
+PORTREVISION?= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
MAINTAINER= bapt@FreeBSD.org
-COMMENT= GNU binary tools
+COMMENT?= GNU binary tools
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
@@ -27,14 +27,18 @@ LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING3.LIB
USES= bison gmake libtool tar:bzip2
GNU_CONFIGURE= yes
+.if defined(PKGNAMEPREFIX)
+OPTIONS_EXCLUDE= NLS
+INFO_PATH= ${PKGNAMEPREFIX:S/-$//}/info
+CONFIGURE_ARGS+= --disable-shared \
+ --target=${PKGNAMEPREFIX}${OPSYS:tl}
+.else
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-system-zlib \
--with-sysroot=/ \
- --disable-werror \
--with-gmp=${LOCALBASE} \
--with-mpfr=${LOCALBASE}
-
INFO= as \
binutils \
standards \
@@ -42,6 +46,9 @@ INFO= as \
bfd \
configure \
ld
+.endif
+
+CONFIGURE_ARGS+= --disable-werror
OPTIONS_SUB= yes
NLS_USES= gettext
@@ -50,7 +57,7 @@ NLS_CONFIGURE_ENABLE= nls
.include <bsd.port.options.mk>
# Actual earliest version may differ slightly
-.if ${ARCH} != ia64 && ${OSVERSION} >= 900044
+.if ${ARCH} != ia64 && ${OSVERSION} >= 900044 && !defined(PKGNAMEPREFIX)
CONFIGURE_ARGS+= --enable-gold --enable-plugins
PLIST_SUB+= GOLD=""
.else
@@ -64,6 +71,7 @@ CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
post-install:
+.if !defined(PKGNAMEPREFIX)
.if ${OSVERSION} >= 900044
${INSTALL_DATA} ${WRKSRC}/include/plugin-api.h ${STAGEDIR}${PREFIX}/include/
.endif
@@ -73,5 +81,8 @@ post-install:
${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
${RM} ${STAGEDIR}${PREFIX}/include/ansidecl.h
${REINPLACE_CMD} '/#include "ansidecl.h"/d' ${STAGEDIR}${PREFIX}/include/bfd.h
+.else
+ ${RM} -rf ${STAGEDIR}${PREFIX}/${PKGNAMEPREFIX:S/-$//}
+.endif
.include <bsd.port.mk>