aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boost-all
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2013-05-11 07:15:18 +0800
committermi <mi@FreeBSD.org>2013-05-11 07:15:18 +0800
commit7dee905d2d83e588576171a4f614dcb2c68d083e (patch)
tree5bb93c5309acf03790f97a88105de849c28269c0 /devel/boost-all
parent7461e38d428c6cba6333698e83e87a7d483f1f84 (diff)
downloadfreebsd-ports-gnome-7dee905d2d83e588576171a4f614dcb2c68d083e.tar.gz
freebsd-ports-gnome-7dee905d2d83e588576171a4f614dcb2c68d083e.tar.zst
freebsd-ports-gnome-7dee905d2d83e588576171a4f614dcb2c68d083e.zip
Respect the locally set CXXFLAGS (and CFLAGS) -- except for optimization
level (-O*), which Boost sets to -O3 automatically. Approved by: maintainer (bapt)
Diffstat (limited to 'devel/boost-all')
-rw-r--r--devel/boost-all/compiled.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index 50f7e7ef72ad..4166ceca6670 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -16,6 +16,11 @@ BJAM_ARGS= --layout=system \
BJAM_ARGS+= cxxflags=-fPIC
.endif
+# Our compiler-flags will be added AFTER those set by bjam. We remove
+# the optimization level, because Boost sets it itself (to -O3 in case
+# of gcc/g++):
+BJAM_ARGS+= cxxflags="${CXXFLAGS:N-O*}" cflags="${CFLAGS:N-O*}"
+
NO_CCACHE= yes
.if ${CC:T:Mgcc*}
BOOST_TOOLSET:= gcc