aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boost-libs
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2015-09-27 16:33:59 +0800
committertruckman <truckman@FreeBSD.org>2015-09-27 16:33:59 +0800
commitb81f7a07a185e6f99a4abccfb1e2052f826b656e (patch)
treeb4836c49a19f6485a9927ebd04f94fe1d553f537 /devel/boost-libs
parenta47068a5c5f08cbdf5bf40f945458dfcc57221e4 (diff)
downloadfreebsd-ports-gnome-b81f7a07a185e6f99a4abccfb1e2052f826b656e.tar.gz
freebsd-ports-gnome-b81f7a07a185e6f99a4abccfb1e2052f826b656e.tar.zst
freebsd-ports-gnome-b81f7a07a185e6f99a4abccfb1e2052f826b656e.zip
Unbreak the build when the ICU option is unset on FreeBSD 9.3.
USES must be set before including bsd.port.pre.mk, which is included by boost-all/compiled.mk. The easiest fix for the conditional USES+=iconv being too late seems to be to use an option helper. For consistency use an option helper for the LIB_DEPENDS. PR: 203285
Diffstat (limited to 'devel/boost-libs')
-rw-r--r--devel/boost-libs/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index bcad1a0f5288..9299ef984b6d 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -13,6 +13,9 @@ OPTIONS_DEFAULT= ICU
VERBOSE_BUILD_DESC= Show compiler messages
ICU_DESC= Boost.Regex with ICU unicode support
+ICU_LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu
+ICU_USES_OFF= iconv
+
.include "${.CURDIR}/../boost-all/common.mk"
.include "${.CURDIR}/../boost-all/compiled.mk"
@@ -28,11 +31,9 @@ PLIST_SUB+= COROUTINE="" CONTEXT="" LOCALE="" LOG=""
.endif
.if ${PORT_OPTIONS:MICU}
-LIB_DEPENDS+= libicuuc.so:${PORTSDIR}/devel/icu
BJAM_ARGS+= -sICU_PATH=${LOCALBASE}
.else
-USES+= iconv
-BJAM_ARGS+= -sICONV_PATH=${LOCALBASE}
+BJAM_ARGS+= -sICONV_PATH=${ICONV_PREFIX}
.endif
do-build: