aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boost/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2006-09-23 06:22:19 +0800
committermi <mi@FreeBSD.org>2006-09-23 06:22:19 +0800
commit232842fd2ccf99d0809ede3f6afef9fa79e43295 (patch)
treef9e9671fca8b833107bbc32576e9f4010d345c15 /devel/boost/Makefile
parent49ee1d68ef5d7247edc6418a131bbbf951d4ea50 (diff)
downloadfreebsd-ports-gnome-232842fd2ccf99d0809ede3f6afef9fa79e43295.tar.gz
freebsd-ports-gnome-232842fd2ccf99d0809ede3f6afef9fa79e43295.tar.zst
freebsd-ports-gnome-232842fd2ccf99d0809ede3f6afef9fa79e43295.zip
Upgrade ICU from 3.4.1 to 3.6. Build WITHOUT_THREADS by default -- using
threads is broken on ia64 (marcel is investigating) and seems useless elsewhere. Filter `-funroll-loops' out of CFLAGS for now -- it seems to cause miscompilation occasionally. Correct the dependencies to stop requiring a particular version number of the ICU's libraries to ease future upgrades.
Diffstat (limited to 'devel/boost/Makefile')
-rw-r--r--devel/boost/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/boost/Makefile b/devel/boost/Makefile
index 1cdb985a0c99..c615b95a7804 100644
--- a/devel/boost/Makefile
+++ b/devel/boost/Makefile
@@ -175,7 +175,7 @@ BOOST_LIBS+= thread
.endif
.if defined (WITH_ICU)
-LIB_DEPENDS+= icuuc.34:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu
BOOST_ICU_OPTS= "-sICU_PATH=${LOCALBASE}"
.endif