aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ccache
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-11-16 04:03:33 +0800
committerahze <ahze@FreeBSD.org>2005-11-16 04:03:33 +0800
commit7b402c7f4e89e80e36d115082097e9fcab41dac9 (patch)
tree3166257d01af12cc7a5b44040215b462ed134f77 /devel/ccache
parentc53422ebcb1d82ec51de145deff51b21745bef83 (diff)
downloadfreebsd-ports-gnome-7b402c7f4e89e80e36d115082097e9fcab41dac9.tar.gz
freebsd-ports-gnome-7b402c7f4e89e80e36d115082097e9fcab41dac9.tar.zst
freebsd-ports-gnome-7b402c7f4e89e80e36d115082097e9fcab41dac9.zip
- Add support to turn off hasing the compiler size and mtime via a
enviroment variable, this aids in 'buildworld' and 'buildkernel'. CCACHE_NOHASH_SIZE_MTIME This tells ccache to not hash the real compiler's size and modi- fication time. Normally this is the mechanism to detect compiler upgrades. There are situations however, where even though the compiler's size or modification time has changed you can safely use the cached objects (e.g. if as part of your build system the compiler is built as well and the compiler's source has not changed; or if the compiler has only changes that do not affect code generation). Use this feature only if you know what you are doing. Submitted by: schweikh
Diffstat (limited to 'devel/ccache')
-rw-r--r--devel/ccache/Makefile2
-rw-r--r--devel/ccache/files/patch-ccache.119
-rw-r--r--devel/ccache/files/patch-ccache.c15
3 files changed, 35 insertions, 1 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index 280a16b784bb..85ba6d4c9694 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ccache
PORTVERSION= 2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://ccache.samba.org/ftp/ccache/
diff --git a/devel/ccache/files/patch-ccache.1 b/devel/ccache/files/patch-ccache.1
new file mode 100644
index 000000000000..83addd79e9d9
--- /dev/null
+++ b/devel/ccache/files/patch-ccache.1
@@ -0,0 +1,19 @@
+--- ccache.1.orig Mon Sep 13 06:38:30 2004
++++ ccache.1 Tue Nov 15 14:59:46 2005
+@@ -234,6 +234,16 @@
+ incorrect setting of this debug info rarely causes problems\&. If you
+ strike problems with gdb not using the correct directory then enable
+ this option\&.
++.IP
++.IP "\fBCCACHE_NOHASH_SIZE_MTIME\fP"
++This tells ccache to not hash the real compiler's size and modification
++time. Normally this is the mechanism to detect compiler upgrades.
++There are situations however, where even though the compiler's size or
++modification time has changed you can safely use the cached objects
++(e.g. if as part of your build system the compiler is built as well
++and the compiler's source has not changed; or if the compiler has only
++changes that do not affect code generation). Use this feature only if
++you know what you are doing.
+ .IP
+ .IP "\fBCCACHE_UNIFY\fP"
+ If you set the environment variable CCACHE_UNIFY
diff --git a/devel/ccache/files/patch-ccache.c b/devel/ccache/files/patch-ccache.c
new file mode 100644
index 000000000000..7ee069ace02b
--- /dev/null
+++ b/devel/ccache/files/patch-ccache.c
@@ -0,0 +1,15 @@
+--- ccache.c.orig Mon Sep 13 06:38:30 2004
++++ ccache.c Tue Nov 15 14:59:46 2005
+@@ -331,8 +331,10 @@
+ hash_string(str_basename(args->argv[0]));
+ }
+
+- hash_int(st.st_size);
+- hash_int(st.st_mtime);
++ if (!getenv("CCACHE_NOHASH_SIZE_MTIME")) {
++ hash_int(st.st_size);
++ hash_int(st.st_mtime);
++ }
+
+ /* possibly hash the current working directory */
+ if (getenv("CCACHE_HASHDIR")) {