aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cdialog
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-23 19:10:46 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-23 19:10:46 +0800
commit7db26d9385f0d5233d78f71fc9c98ffefadfe02e (patch)
tree1844fc6bdaedffda314450977ea52bf4048dd911 /devel/cdialog
parent86f745e5e50219aec13975450b54167debe52747 (diff)
downloadfreebsd-ports-gnome-7db26d9385f0d5233d78f71fc9c98ffefadfe02e.tar.gz
freebsd-ports-gnome-7db26d9385f0d5233d78f71fc9c98ffefadfe02e.tar.zst
freebsd-ports-gnome-7db26d9385f0d5233d78f71fc9c98ffefadfe02e.zip
Fix build without ncurses port installed
Reported by: olgeni
Diffstat (limited to 'devel/cdialog')
-rw-r--r--devel/cdialog/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/cdialog/Makefile b/devel/cdialog/Makefile
index 832ce35f167c..292a77002ce9 100644
--- a/devel/cdialog/Makefile
+++ b/devel/cdialog/Makefile
@@ -24,13 +24,18 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-widec \
--includedir=${PREFIX}/include/${PORTNAME} \
--with-libtool \
- --with-curses-dir=${NCURSESBASE} \
--with-ncursesw \
--with-package=${PORTNAME}
MAKEFILE= makefile
INSTALL_TARGET= install-strip install-man install-lib
+.include <bsd.port.pre.mk>
+
+.if ${NCURSESBASE} != /usr
+CONFIGURE_ARGS= --with-curses-dir=${NCURSESBASE}
+.endif
+
post-patch:
@${FIND} ${WRKSRC}/samples/ -type f -exec ${REINPLACE_CMD} -i "" "s|dialog|cdialog|g" {} \;
@@ -38,4 +43,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>