aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cdialog
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-23 08:21:11 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-23 08:21:11 +0800
commit8a3499d057fb212dc6abc314716d1ce34e4d0af2 (patch)
treed0aa6607c804665a2b1d2718b3a0bea071e9194b /devel/cdialog
parenta63b9de3d5dce019de69790499757a3e09d6d7d7 (diff)
downloadfreebsd-ports-gnome-8a3499d057fb212dc6abc314716d1ce34e4d0af2.tar.gz
freebsd-ports-gnome-8a3499d057fb212dc6abc314716d1ce34e4d0af2.tar.zst
freebsd-ports-gnome-8a3499d057fb212dc6abc314716d1ce34e4d0af2.zip
Support stage
Fix build with ports ncurses
Diffstat (limited to 'devel/cdialog')
-rw-r--r--devel/cdialog/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/devel/cdialog/Makefile b/devel/cdialog/Makefile
index e2164bfa157b..832ce35f167c 100644
--- a/devel/cdialog/Makefile
+++ b/devel/cdialog/Makefile
@@ -10,35 +10,32 @@ DISTNAME= ${PORTNAME:S|^c||}-${PORTVERSION:R}-${PORTVERSION:E}
EXTRACT_SUFX= .tgz
MAINTAINER= sylvio@FreeBSD.org
-COMMENT= An enhanced version of 'dialog' to work with ncurses
+COMMENT= Enhanced version of 'dialog' to work with ncurses
+
+OPTIONS_DEFINE= EXAMPLES
LICENSE= LGPL21
+USES= ncurses
+
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-widec \
--includedir=${PREFIX}/include/${PORTNAME} \
--with-libtool \
+ --with-curses-dir=${NCURSESBASE} \
--with-ncursesw \
--with-package=${PORTNAME}
MAKEFILE= makefile
-MAN1= cdialog.1
-MAN3= cdialog.3
-MANCOMPRESSED= no
-
INSTALL_TARGET= install-strip install-man install-lib
-NO_STAGE= yes
-.if !defined(NOPORTEXAMPLES)
post-patch:
@${FIND} ${WRKSRC}/samples/ -type f -exec ${REINPLACE_CMD} -i "" "s|dialog|cdialog|g" {} \;
post-install:
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/samples && ${FIND} . | \
- ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>