aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cflow
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-05-24 22:12:03 +0800
committervanilla <vanilla@FreeBSD.org>2014-05-24 22:12:03 +0800
commit9bdfb9473966400207abe2a7b616e021aa6dd33e (patch)
tree0adc7e943d496b6d5c28bfd65df2c45c055a8c70 /devel/cflow
parenta2ad4e64e6b72b5f86a050d2ad2a1e676c8dd5c9 (diff)
downloadfreebsd-ports-gnome-9bdfb9473966400207abe2a7b616e021aa6dd33e.tar.gz
freebsd-ports-gnome-9bdfb9473966400207abe2a7b616e021aa6dd33e.tar.zst
freebsd-ports-gnome-9bdfb9473966400207abe2a7b616e021aa6dd33e.zip
Stageify.
Approved by: portmgr@
Diffstat (limited to 'devel/cflow')
-rw-r--r--devel/cflow/Makefile5
-rw-r--r--devel/cflow/files/patch-Makefile72
-rw-r--r--devel/cflow/files/patch-aa115
-rw-r--r--devel/cflow/pkg-plist1
4 files changed, 74 insertions, 119 deletions
diff --git a/devel/cflow/Makefile b/devel/cflow/Makefile
index 0252a0463ece..d161ed3616a8 100644
--- a/devel/cflow/Makefile
+++ b/devel/cflow/Makefile
@@ -13,9 +13,6 @@ COMMENT= A call graph generator for C code
CONFLICTS= bsdcflow-[0-9]* gnucflow-[0-9]*
-USE_GMAKE= yes
-MAN1= cflow.1
-MANCOMPRESSED= yes
+USES= gmake
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/cflow/files/patch-Makefile b/devel/cflow/files/patch-Makefile
new file mode 100644
index 000000000000..9d605dfe3a15
--- /dev/null
+++ b/devel/cflow/files/patch-Makefile
@@ -0,0 +1,72 @@
+--- Makefile.orig 1995-03-06 22:00:20.000000000 +0800
++++ Makefile 2014-05-24 22:09:47.087270512 +0800
+@@ -5,19 +5,20 @@ CC=gcc
+ endif
+
+ # use cp backup option if you have gnu cp
+-CP=cp
+-CP=cp -b
++#CP=cp
++#CP=cp -b
++INSTALL_CMD= install -c -o bin -g bin
+
+ # where you want to install
+ ifndef PREFIX
+-PREFIX=$(HOME)
++PREFIX=/usr/local
+ endif
+
+ # which shell do we use for the cflow to script?
+ # I know it works on bash on unix, it also should work with
+ # msh on ms-dog
+ ifndef CFLOW_SHELL
+-CFLOW_SHELL=/bin/bash
++CFLOW_SHELL=$(PREFIX)/bin/bash
+ endif
+
+ # actual location of prcc
+@@ -39,12 +40,13 @@ ifdef MALLOC_DEBUG
+ LOADLIBES=-L$(HOME)/lib -ldmalloc
+ endif
+
+-DEBUG=-g
+-OPT=-O
+-CFLAGS=-Wall $(DEBUG) $(OPT) $(DEFS)
++#DEBUG=-g
++#OPT=-O
++CFLAGS+=$(DEBUG) $(OPT) $(DEFS)
+
+ # set this to where to install
+-BINDIR=$(PREFIX)/bin
++BINDIR=$(DESTDIR)$(PREFIX)/bin
++MANDIR=$(DESTDIR)$(PREFIX)/man/man1
+
+ SRCS=cflow.sh prcc.c prcg.c
+
+@@ -64,17 +66,23 @@ PROTOTYPES= prcc.prototypes.h prcg.proto
+ prototypes: $(PROTOTYPES)
+
+
+-install: install-cflow install-bins
++install: install-cflow install-bins install-man
+
+ install-bins: $(BINDIR)/prcc $(BINDIR)/prcg
+
+ install-cflow: $(BINDIR)/cflow
+
++install-man: $(MANDIR)/cflow.1.gz
++
+ $(BINDIR)/prcc $(BINDIR)/prcg: $(BINDIR)/%: %
+- $(CP) $^ $@
++ $(INSTALL_CMD) $^ $@
+
+ $(BINDIR)/cflow: cflow
+- $(CP) $^ $@
++ $(INSTALL_CMD) -m0755 $^ $@
++
++$(MANDIR)/cflow.1.gz: cflow.1
++ $(INSTALL_CMD) -m 0644 $^ $(MANDIR)
++ gzip -9nf $(MANDIR)/cflow.1
+
+ cflow: cflow.sh
+ sed -e "s;@CFLOW_SHELL@;$(CFLOW_SHELL);g" \
diff --git a/devel/cflow/files/patch-aa b/devel/cflow/files/patch-aa
deleted file mode 100644
index f4dac4dcfd5f..000000000000
--- a/devel/cflow/files/patch-aa
+++ /dev/null
@@ -1,115 +0,0 @@
-*** Makefile.orig Mon Mar 6 15:00:20 1995
---- Makefile Tue Jan 25 23:25:46 2000
-***************
-*** 5,23 ****
- endif
-
- # use cp backup option if you have gnu cp
-! CP=cp
-! CP=cp -b
-
- # where you want to install
- ifndef PREFIX
-! PREFIX=$(HOME)
- endif
-
- # which shell do we use for the cflow to script?
- # I know it works on bash on unix, it also should work with
- # msh on ms-dog
- ifndef CFLOW_SHELL
-! CFLOW_SHELL=/bin/bash
- endif
-
- # actual location of prcc
---- 5,24 ----
- endif
-
- # use cp backup option if you have gnu cp
-! #CP=cp
-! #CP=cp -b
-! INSTALL_CMD= install -c -o bin -g bin
-
- # where you want to install
- ifndef PREFIX
-! PREFIX=/usr/local
- endif
-
- # which shell do we use for the cflow to script?
- # I know it works on bash on unix, it also should work with
- # msh on ms-dog
- ifndef CFLOW_SHELL
-! CFLOW_SHELL=$(PREFIX)/bin/bash
- endif
-
- # actual location of prcc
-***************
-*** 39,50 ****
- LOADLIBES=-L$(HOME)/lib -ldmalloc
- endif
-
-! DEBUG=-g
-! OPT=-O
-! CFLAGS=-Wall $(DEBUG) $(OPT) $(DEFS)
-
- # set this to where to install
- BINDIR=$(PREFIX)/bin
-
- SRCS=cflow.sh prcc.c prcg.c
-
---- 40,52 ----
- LOADLIBES=-L$(HOME)/lib -ldmalloc
- endif
-
-! #DEBUG=-g
-! #OPT=-O
-! CFLAGS+=$(DEBUG) $(OPT) $(DEFS)
-
- # set this to where to install
- BINDIR=$(PREFIX)/bin
-+ MANDIR=$(PREFIX)/man/man1
-
- SRCS=cflow.sh prcc.c prcg.c
-
-***************
-*** 64,80 ****
- prototypes: $(PROTOTYPES)
-
-
-! install: install-cflow install-bins
-
- install-bins: $(BINDIR)/prcc $(BINDIR)/prcg
-
- install-cflow: $(BINDIR)/cflow
-
- $(BINDIR)/prcc $(BINDIR)/prcg: $(BINDIR)/%: %
-! $(CP) $^ $@
-
- $(BINDIR)/cflow: cflow
-! $(CP) $^ $@
-
- cflow: cflow.sh
- sed -e "s;@CFLOW_SHELL@;$(CFLOW_SHELL);g" \
---- 66,88 ----
- prototypes: $(PROTOTYPES)
-
-
-! install: install-cflow install-bins install-man
-
- install-bins: $(BINDIR)/prcc $(BINDIR)/prcg
-
- install-cflow: $(BINDIR)/cflow
-
-+ install-man: $(MANDIR)/cflow.1.gz
-+
- $(BINDIR)/prcc $(BINDIR)/prcg: $(BINDIR)/%: %
-! $(INSTALL_CMD) $^ $@
-
- $(BINDIR)/cflow: cflow
-! $(INSTALL_CMD) -m0755 $^ $@
-!
-! $(MANDIR)/cflow.1.gz: cflow.1
-! $(INSTALL_CMD) -m 0644 $^ $(MANDIR)
-! gzip -9nf $(MANDIR)/cflow.1
-
- cflow: cflow.sh
- sed -e "s;@CFLOW_SHELL@;$(CFLOW_SHELL);g" \
diff --git a/devel/cflow/pkg-plist b/devel/cflow/pkg-plist
index 6985a2d9cc43..786d521ca2a8 100644
--- a/devel/cflow/pkg-plist
+++ b/devel/cflow/pkg-plist
@@ -1,3 +1,4 @@
bin/cflow
bin/prcc
bin/prcg
+man/man1/cflow.1.gz