aboutsummaryrefslogtreecommitdiffstats
path: root/devel/chruby
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-05-27 11:07:20 +0800
committerswills <swills@FreeBSD.org>2013-05-27 11:07:20 +0800
commit2d4312da90d5024034568c9328a41edde23e7798 (patch)
treedc3d9090bb4959d5a1ee5529db171daacd799540 /devel/chruby
parent39e30fbc5d6dc3de7d28d365cc94bf243d7c29de (diff)
downloadfreebsd-ports-gnome-2d4312da90d5024034568c9328a41edde23e7798.tar.gz
freebsd-ports-gnome-2d4312da90d5024034568c9328a41edde23e7798.tar.zst
freebsd-ports-gnome-2d4312da90d5024034568c9328a41edde23e7798.zip
Changes the current Ruby.
WWW: https://github.com/postmodern/chruby PR: ports/175552 Submitted by: Ross Timson <ross@rosstimson.com>
Diffstat (limited to 'devel/chruby')
-rw-r--r--devel/chruby/Makefile37
-rw-r--r--devel/chruby/distinfo2
-rw-r--r--devel/chruby/files/pkg-message.in27
-rw-r--r--devel/chruby/pkg-descr3
4 files changed, 69 insertions, 0 deletions
diff --git a/devel/chruby/Makefile b/devel/chruby/Makefile
new file mode 100644
index 000000000000..ad2eee6acaa3
--- /dev/null
+++ b/devel/chruby/Makefile
@@ -0,0 +1,37 @@
+# Created by: Ross Timson <ross@rosstimson.com>
+# $FreeBSD$
+
+PORTNAME= chruby
+PORTVERSION= 0.3.2
+CATEGORIES= devel ruby
+MASTER_SITES= GH
+
+MAINTAINER= ross@rosstimson.com
+COMMENT= Changes the current Ruby
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+PLIST_FILES= bin/chruby-exec share/chruby/auto.sh share/chruby/chruby.sh
+PLIST_DIRS= share/chruby
+
+SUB_FILES= pkg-message
+
+USE_GITHUB= yes
+GH_ACCOUNT= postmodern
+GH_PROJECT= chruby
+GH_COMMIT= 872cd1b
+GH_TAGNAME= v${PORTVERSION}
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/chruby-exec ${PREFIX}/bin
+ ( cd ${WRKSRC}/share/chruby && ${COPYTREE_BIN} \* ${PREFIX}/share/chruby )
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/devel/chruby/distinfo b/devel/chruby/distinfo
new file mode 100644
index 000000000000..47eabd57870e
--- /dev/null
+++ b/devel/chruby/distinfo
@@ -0,0 +1,2 @@
+SHA256 (chruby-0.3.2.tar.gz) = 9d3d73fbf9d19acccdb5d3ba9377a6bd81eb0a27c436472ed44084ef6f4a1567
+SIZE (chruby-0.3.2.tar.gz) = 13385
diff --git a/devel/chruby/files/pkg-message.in b/devel/chruby/files/pkg-message.in
new file mode 100644
index 000000000000..4038d9dc905b
--- /dev/null
+++ b/devel/chruby/files/pkg-message.in
@@ -0,0 +1,27 @@
+======================================================================
+
+Add the following to the /etc/profile.d/chruby.sh, ~/.bash_profile or
+~/.zprofile file:
+
+source %%PREFIX%%/share/chruby/chruby.sh
+
+By default chruby will search for Rubies installed into /opt/rubies/ or
+~/.rubies/. For non-standard installation locations, simply set the RUBIES
+variable:
+
+RUBIES=(
+ /opt/jruby-1.7.0
+ $HOME/src/rubinius
+)
+
+If you are migrating from another Ruby manager, set `RUBIES` accordingly:
+
+RVM: RUBIES=(~/.rvm/rubies/*)
+rbenv: RUBIES=(~/.rbenv/versions/*)
+rbfu: RUBIES=('~/.rbfu/rubies/*)
+
+To enable auto-switching of Rubies specified by .ruby-version files:
+
+source %%PREFIX%%/share/chruby/auto.sh
+
+======================================================================
diff --git a/devel/chruby/pkg-descr b/devel/chruby/pkg-descr
new file mode 100644
index 000000000000..e32d4634a6e0
--- /dev/null
+++ b/devel/chruby/pkg-descr
@@ -0,0 +1,3 @@
+Changes the current Ruby.
+
+WWW: https://github.com/postmodern/chruby