aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cil
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>2006-08-05 21:00:16 +0800
committerjkoshy <jkoshy@FreeBSD.org>2006-08-05 21:00:16 +0800
commit18ee725fd4b518d5890805d90e6874daea229419 (patch)
tree9a0af5d1f0c33b532345e30b681e0d6cd8ee276d /devel/cil
parentdad06d0c2a6f4f16e2186bd7ad38700b5a84e684 (diff)
downloadfreebsd-ports-gnome-18ee725fd4b518d5890805d90e6874daea229419.tar.gz
freebsd-ports-gnome-18ee725fd4b518d5890805d90e6874daea229419.tar.zst
freebsd-ports-gnome-18ee725fd4b518d5890805d90e6874daea229419.zip
- Fix Perl paths to allow "bin/cilly" to work. [1]
- Enable this port on FreeBSD/amd64. PR: ports/101312 [1] Submitted by: Li-Wen Hsu <lwhsu at lwhsu.org>
Diffstat (limited to 'devel/cil')
-rw-r--r--devel/cil/Makefile11
-rw-r--r--devel/cil/files/patch-configure22
2 files changed, 30 insertions, 3 deletions
diff --git a/devel/cil/Makefile b/devel/cil/Makefile
index dbdb112e876b..07c1c79fbe7f 100644
--- a/devel/cil/Makefile
+++ b/devel/cil/Makefile
@@ -7,10 +7,11 @@
PORTNAME= cil
PORTVERSION= 1.3.5
+PORTREVISION= 1
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://manju.cs.berkeley.edu/cil/distrib/
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jkoshy@FreeBSD.org
COMMENT= Infrastructure for C Program Analysis and Transformation
@@ -19,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/ocamlopt:${PORTSDIR}/lang/ocaml
CONFLICTS= ccured-*
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
USE_PERL5= yes
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -38,6 +39,10 @@ IGNORE= does not work with perl < 5.6.1
post-patch:
@${REINPLACE_CMD} -e 's:@CILHOME@/lib:${SITE_PERL}/CIL:g; s:\@CILHOME\@:${PREFIX}:g' ${WRKSRC}/bin/CilConfig.pm.in
@${REINPLACE_CMD} -e 's|$$::cilhome|${PREFIX}|g; s|obj/$$::archos|libexec/cil|g' ${WRKSRC}/bin/cilly
+ @${REINPLACE_CMD} -e 's|^use Cilly;|use CIL::Cilly|' ${WRKSRC}/bin/cilly
+ @${REINPLACE_CMD} -e 's|^use KeptFile;|use CIL::KeptFile;|; s|^use OutputFile;|use CIL::OutputFile;|; s|^use TempFile;|use CIL::TempFile;|' ${WRKSRC}/lib/Cilly.pm
+ @${REINPLACE_CMD} -e 's|^use OutputFile;|use CIL::OutputFile;|' ${WRKSRC}/lib/KeptFile.pm
+ @${REINPLACE_CMD} -e 's|^use OutputFile;|use CIL::OutputFile;|' ${WRKSRC}/lib/TempFile.pm
do-install:
.if !defined(NOPORTDOCS)
@@ -55,7 +60,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/bin/CilConfig.pm ${SITE_PERL}/
${MKDIR} ${PREFIX}/libexec/cil
.for f in ${EXECFILES}
- ${INSTALL} ${WRKSRC}/obj/x86_LINUX/${f} ${PREFIX}/libexec/cil/
+ ${INSTALL} ${WRKSRC}/obj/${ARCH}_FREEBSD/${f} ${PREFIX}/libexec/cil/
.endfor
.include <bsd.port.post.mk>
diff --git a/devel/cil/files/patch-configure b/devel/cil/files/patch-configure
new file mode 100644
index 000000000000..d6f5a615c201
--- /dev/null
+++ b/devel/cil/files/patch-configure
@@ -0,0 +1,22 @@
+--- configure.orig Sun May 21 09:44:15 2006
++++ configure Fri Aug 4 08:56:05 2006
+@@ -4202,11 +4202,18 @@
+ # $target is typically processor-vendor-os
+ case "$target" in
+ # linux
+- *86*linux*|*86*freebsd*|*86*openbsd*|*86*darwin*)
++ *86*linux*|*86*openbsd*|*86*darwin*)
+ echo "$as_me:$LINENO: result: configuring for linux/x86" >&5
+ echo "${ECHO_T}configuring for linux/x86" >&6
+
+ ARCHOS=x86_LINUX
++ ;;
++
++ *amd64*freebsd*|*i386*freebsd*)
++ echo "$as_me:$LINENO: result: configuring for freebsd/${ARCH}" >&5
++echo "${ECHO_T}configuring for freebsd/${ARCH}" >&6
++
++ ARCHOS=`uname -p`_FREEBSD
+ ;;
+
+ # Mac OS X