aboutsummaryrefslogtreecommitdiffstats
path: root/devel/clanlib/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-09-25 14:58:43 +0800
committersobomax <sobomax@FreeBSD.org>2000-09-25 14:58:43 +0800
commit64b0d060a688175da3c013e5ee9c46d0cd987bbc (patch)
treee68e52b6481fc8a46aa6922e4fde222c62a36888 /devel/clanlib/Makefile
parent1d71d2f7e02152db58f5244f19818a9e6345b339 (diff)
downloadfreebsd-ports-gnome-64b0d060a688175da3c013e5ee9c46d0cd987bbc.tar.gz
freebsd-ports-gnome-64b0d060a688175da3c013e5ee9c46d0cd987bbc.tar.zst
freebsd-ports-gnome-64b0d060a688175da3c013e5ee9c46d0cd987bbc.zip
Add clanlib - a cross-platform game SDK (yes, it works with svgalib :-> ).
Diffstat (limited to 'devel/clanlib/Makefile')
-rw-r--r--devel/clanlib/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
new file mode 100644
index 000000000000..e626bc708733
--- /dev/null
+++ b/devel/clanlib/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: clanlib
+# Date created: 10 May 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clanlib
+PORTVERSION= 0.4.4
+CATEGORIES= devel
+MASTER_SITES= http://dark.x.dtu.dk/~mbn/clanlib/download/
+DISTNAME= ClanLib-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= Hermes.1:${PORTSDIR}/graphics/Hermes \
+ png.4:${PORTSDIR}/graphics/png \
+ vga.1:${PORTSDIR}/graphics/svgalib
+
+.if defined(WITHOUT_GL)
+CONFIGURE_ARGS+= --disable-opengl
+.else
+USE_MESA= yes
+CONFIGURE_ARGS+= --enable-opengl
+PLIST= ${WRKDIR}/PLIST
+.endif
+
+USE_GMAKE= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+CFLAGS+= -fpermissive
+ALL_TARGET+= clanPNG clanGL
+
+.if !defined(WITHOUT_GL)
+pre-install:
+ @cat ${PKGDIR}/PLIST.glx ${PKGDIR}/PLIST > ${PLIST}
+.endif
+
+.include <bsd.port.mk>