aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cmake
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-07-20 06:04:44 +0800
committerbapt <bapt@FreeBSD.org>2015-07-20 06:04:44 +0800
commitaa8eec71600875a323d98c0f3bce478e51762f05 (patch)
treed14494b07d89b3519c6c3cda6a5387365833c31d /devel/cmake
parent10d81b14c70a86c9f0ed611b70b63745ed8ed16e (diff)
downloadfreebsd-ports-gnome-aa8eec71600875a323d98c0f3bce478e51762f05.tar.gz
freebsd-ports-gnome-aa8eec71600875a323d98c0f3bce478e51762f05.tar.zst
freebsd-ports-gnome-aa8eec71600875a323d98c0f3bce478e51762f05.zip
Enforce libarchive from ports
This reduces the patching level on some ports and make it simpler to maintainer over all supported version of freebsd
Diffstat (limited to 'devel/cmake')
-rw-r--r--devel/cmake/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index ce1241ec2a91..e3753aa2c1b5 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cmake
PORTVERSION= 3.2.3
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= devel
MASTER_SITES= http://www.cmake.org/files/v3.2/
@@ -25,6 +25,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
OPTIONS_DEFINE= DOCS MANPAGES
OPTIONS_DEFAULT=MANPAGES
OPTIONS_SUB= yes
+USES+= libarchive
HAS_CONFIGURE= yes
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
@@ -42,14 +43,6 @@ MANPAGES_CONFIGURE_ON= --sphinx-man
INSTALL_TARGET= install/strip
.endif
-.if !defined(CMAKE_MODULES)
-# CMake >= 3.1.0 needs libarchive3 because it calls
-# archive_entry_copy_sourcepath_w and archive_write_set_format_7zip.
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000009
-LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
-.endif # ${OPSYS} == FreeBSD && ${OSVERSION} < 1000009
-.endif # !defined(CMAKE_MODULES)
-
post-patch:
@(${FIND} ${WRKSRC}/Modules -name "*.cmake" -print0; \
${FIND} ${WRKSRC}/Tests -name "CMakeLists.txt" -print0 ) | \