aboutsummaryrefslogtreecommitdiffstats
path: root/devel/configgen
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-09-15 15:09:38 +0800
committerahze <ahze@FreeBSD.org>2005-09-15 15:09:38 +0800
commit577ee00e152cb17b31fc865743402a55256e89cd (patch)
tree10e5907323085709e3e9072f14a67c2792f789c2 /devel/configgen
parent583ff7e0fb0c32493b0951d80738b1fa9454aa14 (diff)
downloadfreebsd-ports-gnome-577ee00e152cb17b31fc865743402a55256e89cd.tar.gz
freebsd-ports-gnome-577ee00e152cb17b31fc865743402a55256e89cd.tar.zst
freebsd-ports-gnome-577ee00e152cb17b31fc865743402a55256e89cd.zip
- Add configgen
Simple script that makes life a little easier with gnu-autotools on FreeBSD. Configgen takes all the guess work out of figuring out paths, gnu-autotools versions, and more. Configgen can simply be run in a source directory and it will figure out which versions of autotools to use and the best way to auto-generate a configure script or you can specify a command below. -gnu Create generic gnu configure script -gnome Create gnome specific configure script -bsd Use FreeBSD auto-tools (versions: libtool15, automake15, autoconf253) -bsd14 Use FreeBSD auto-tools (versions: libtool13, automake14, autoconf213) -bsd19 Use FreeBSD auto-tools (versions: libtool15, automake19, autoconf259) <config> Specify a auto-gen configure script
Diffstat (limited to 'devel/configgen')
-rw-r--r--devel/configgen/Makefile49
-rw-r--r--devel/configgen/distinfo2
-rw-r--r--devel/configgen/pkg-descr16
3 files changed, 67 insertions, 0 deletions
diff --git a/devel/configgen/Makefile b/devel/configgen/Makefile
new file mode 100644
index 000000000000..dcd6788cd8e8
--- /dev/null
+++ b/devel/configgen/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: configgen
+# Date created: 2005-09-15
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= configgen
+PORTVERSION= 1.12
+CATEGORIES= devel
+MASTER_SITES= http://www.marcuscom.com:8080/cgi-bin/cvsweb.cgi/portstools/
+DISTNAME= ${PORTNAME}.sh?rev=${PORTVERSION}
+EXTRACT_SUFX= # empty
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Script that makes life a little easier with gnu-autotools
+
+PLIST_FILES= bin/${PORTNAME}.sh
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GNUTOOLS)
+.for tool in autoconf213 autoconf253 autoconf259 automake14 automake15 automake19 \
+ libtool13 libtool15
+RUN_DEPENDS+= ${tool}:${PORTSDIR}/devel/${tool}
+.endfor
+.for tool in autoconf automake libtool
+RUN_DEPENDS+= ${LOCALBASE}/gnu-autotools/bin/${tool}:${PORTSDIR}/devel/gnu-${tool}
+.endfor
+RUN_DEPENDS+= gnome-autogen.sh:${PORTSDIR}/devel/gnomecommon
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_GNUTOOLS)
+ @${ECHO_MSG} "You can disable the dependency of gnu-autotools by"
+ @${ECHO_MSG} "defining WITHOUT_GNUTOOLS=yes"
+ @${ECHO_MSG} ""
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ ${SED} -e 's|/usr/local|${LOCALBASE}|g; s|/usr/X11R6|${X11BASE}|g' \
+ < ${DISTDIR}/${DISTNAME} > ${WRKSRC}/${PORTNAME}.sh
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/devel/configgen/distinfo b/devel/configgen/distinfo
new file mode 100644
index 000000000000..0aebb29aac4b
--- /dev/null
+++ b/devel/configgen/distinfo
@@ -0,0 +1,2 @@
+MD5 (configgen.sh?rev=1.12) = e42299724752bbd70e8c66a542ca5e0b
+SIZE (configgen.sh?rev=1.12) = 5838
diff --git a/devel/configgen/pkg-descr b/devel/configgen/pkg-descr
new file mode 100644
index 000000000000..402811bce416
--- /dev/null
+++ b/devel/configgen/pkg-descr
@@ -0,0 +1,16 @@
+Simple script that makes life a little easier with gnu-autotools
+on FreeBSD. Configgen takes all the guess work out of figuring out
+paths, gnu-autotools versions, and more. Configgen can simply be
+run in a source directory and it will figure out which versions of
+autotools to use and the best way to auto-generate a configure script
+or you can specify a command below.
+
+ -gnu Create generic gnu configure script
+ -gnome Create gnome specific configure script
+ -bsd Use FreeBSD auto-tools
+ (versions: libtool15, automake15, autoconf253)
+ -bsd14 Use FreeBSD auto-tools
+ (versions: libtool13, automake14, autoconf213)
+ -bsd19 Use FreeBSD auto-tools
+ (versions: libtool15, automake19, autoconf259)
+ <config> Specify a auto-gen configure script