aboutsummaryrefslogtreecommitdiffstats
path: root/devel/dasm
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-08-05 14:25:51 +0800
committerjgh <jgh@FreeBSD.org>2013-08-05 14:25:51 +0800
commit33d09614256c9cc296899a919359b525508ff442 (patch)
treed6f552844c3b9944d5e698d3bdd4406d88d05d85 /devel/dasm
parentdc87a88d89eee3964dd6691cad73bd7172f1cb29 (diff)
downloadfreebsd-ports-gnome-33d09614256c9cc296899a919359b525508ff442.tar.gz
freebsd-ports-gnome-33d09614256c9cc296899a919359b525508ff442.tar.zst
freebsd-ports-gnome-33d09614256c9cc296899a919359b525508ff442.zip
dasm is a versatile macro assembler with support
for several 8-bit microprocessors including: MOS 6502 & 6507 Motorola 6803, 68705 & 68HC11 Hitachi HD6303 (extended Motorola 6801) Fairchild F8 WWW: http://dasm-dillon.sourceforge.net/ PR: ports/180971 Submitted by: uffe@uffe.org
Diffstat (limited to 'devel/dasm')
-rw-r--r--devel/dasm/Makefile38
-rw-r--r--devel/dasm/distinfo2
-rw-r--r--devel/dasm/pkg-descr9
3 files changed, 49 insertions, 0 deletions
diff --git a/devel/dasm/Makefile b/devel/dasm/Makefile
new file mode 100644
index 000000000000..1f3a9e128e9b
--- /dev/null
+++ b/devel/dasm/Makefile
@@ -0,0 +1,38 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= dasm
+PORTVERSION= 2.20.11
+CATEGORIES= devel
+MASTER_SITES= SF/${PORTNAME}-dillon/${PORTNAME}-dillon/${PORTVERSION}
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Macro assembler for 8-bit microprocessors including MOS 6502, MC6803
+
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= DOCS
+
+USES= gmake
+
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKE_ARGS= CC="${CC}" LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}"
+
+PORTDOCS= *
+PLIST_FILES= bin/dasm \
+ bin/ftohex
+
+do-install:
+.for filename in dasm ftohex
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${filename} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/dasm/distinfo b/devel/dasm/distinfo
new file mode 100644
index 000000000000..5b67240a9bd3
--- /dev/null
+++ b/devel/dasm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dasm-2.20.11.tar.gz) = 5b09040ddcd04417f9be9462d45d5584bee6f09bf342e8a05e513136b99aa0c3
+SIZE (dasm-2.20.11.tar.gz) = 112184
diff --git a/devel/dasm/pkg-descr b/devel/dasm/pkg-descr
new file mode 100644
index 000000000000..9b689418678a
--- /dev/null
+++ b/devel/dasm/pkg-descr
@@ -0,0 +1,9 @@
+dasm is a versatile macro assembler with support
+for several 8-bit microprocessors including:
+
+MOS 6502 & 6507
+Motorola 6803, 68705 & 68HC11
+Hitachi HD6303 (extended Motorola 6801)
+Fairchild F8
+
+WWW: http://dasm-dillon.sourceforge.net/