aboutsummaryrefslogtreecommitdiffstats
path: root/devel/dmake/files
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1997-09-08 04:23:13 +0800
committermax <max@FreeBSD.org>1997-09-08 04:23:13 +0800
commit91716f7f397174c1e47578fe3830a684a9022262 (patch)
treeeb8146a18ec4b23fe41bd4b540a1338fb16589e7 /devel/dmake/files
parente3e22b144b7125b65bd4d2611661921c950a8254 (diff)
downloadfreebsd-ports-gnome-91716f7f397174c1e47578fe3830a684a9022262.tar.gz
freebsd-ports-gnome-91716f7f397174c1e47578fe3830a684a9022262.tar.zst
freebsd-ports-gnome-91716f7f397174c1e47578fe3830a684a9022262.zip
Upgrade, 4.0 -> 4.1.
As I do the upgrade, I made this port truely respect the setting of PREFIX, ie, now the executable looks for the config files in ${PREFIX}/lib/dmake. Also, instead of patching the makefile in the source distribution to add the install: target, define it in the port Makefile. And, move the scripts/post-patch into the port Makefile.
Diffstat (limited to 'devel/dmake/files')
-rw-r--r--devel/dmake/files/patch-aa102
-rw-r--r--devel/dmake/files/patch-ab12
-rw-r--r--devel/dmake/files/patch-ac10
3 files changed, 52 insertions, 72 deletions
diff --git a/devel/dmake/files/patch-aa b/devel/dmake/files/patch-aa
index 1ff5ad32213d..19aac5a1f520 100644
--- a/devel/dmake/files/patch-aa
+++ b/devel/dmake/files/patch-aa
@@ -1,72 +1,30 @@
-*** unix/bsd43/make.sh.orig Thu Oct 6 18:26:53 1994
---- unix/bsd43/make.sh Sat Aug 5 18:39:51 1995
-***************
-*** 1,3 ****
---- 1,5 ----
-+ if [ ! -x dmake ]
-+ then
- mkdir objects
- cc -c -I. -Iunix -Iunix/bsd43 -O infer.c
- mv infer.o objects
-***************
-*** 51,69 ****
- mv runargv.o objects
- cc -c -I. -Iunix -Iunix/bsd43 -O unix/dcache.c
- mv dcache.o objects
-- cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/putenv.c
-- mv putenv.o objects
-- cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/tempnam.c
-- mv tempnam.o objects
-- cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/utime.c
-- mv utime.o objects
-- cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/setvbuf.c
-- mv setvbuf.o objects
- cc -O -o dmake objects/infer.o objects/make.o objects/stat.o objects/expand.o \
- objects/dmstring.o objects/hash.o objects/dag.o objects/dmake.o objects/path.o \
- objects/imacs.o objects/sysintf.o objects/parse.o objects/getinp.o \
- objects/quit.o objects/state.o objects/dmdump.o objects/macparse.o \
- objects/rulparse.o objects/percent.o objects/function.o objects/arlib.o \
- objects/dirbrk.o objects/rmprq.o objects/ruletab.o objects/runargv.o \
-! objects/dcache.o objects/putenv.o objects/tempnam.o objects/utime.o objects/setvbuf.o
- cp unix/bsd43/startup.mk startup.mk
---- 53,64 ----
- mv runargv.o objects
- cc -c -I. -Iunix -Iunix/bsd43 -O unix/dcache.c
- mv dcache.o objects
- cc -O -o dmake objects/infer.o objects/make.o objects/stat.o objects/expand.o \
- objects/dmstring.o objects/hash.o objects/dag.o objects/dmake.o objects/path.o \
- objects/imacs.o objects/sysintf.o objects/parse.o objects/getinp.o \
- objects/quit.o objects/state.o objects/dmdump.o objects/macparse.o \
- objects/rulparse.o objects/percent.o objects/function.o objects/arlib.o \
- objects/dirbrk.o objects/rmprq.o objects/ruletab.o objects/runargv.o \
-! objects/dcache.o
- cp unix/bsd43/startup.mk startup.mk
-+ fi
-*** unix/runargv.c-dist Sat Aug 5 18:17:21 1995
---- unix/runargv.c Sat Aug 5 18:17:38 1995
-***************
-*** 77,83 ****
---- 77,85 ----
- char *cmd;
- {
- extern int errno;
-+ #ifndef __FreeBSD__
- extern char *sys_errlist[];
-+ #endif
- int pid;
- char **argv;
-
-*** makefile.orig Thu Oct 6 18:30:22 1994
---- makefile Sat Aug 5 18:58:26 1995
-***************
-*** 89,91 ****
---- 89,97 ----
- tccswp msc40swp msc50swp msc51swp msc60swp \
- bcc bccswp ztc ztcswp
- $(DOS_VER) :; make.bat $@
-+
-+ install:
-+ install -c -s -m 755 dmake ${PREFIX}/bin
-+ mkdir -p ${PREFIX}/lib/dmake
-+ chmod 755 ${PREFIX}/lib/dmake
-+ install -c -m 444 startup.mk ${PREFIX}/lib/dmake
+--- unix/bsd43/make.sh.orig Wed Jul 16 01:02:35 1997
++++ unix/bsd43/make.sh Mon Sep 8 03:01:42 1997
+@@ -1,3 +1,5 @@
++if [ ! -x dmake ]
++then
+ mkdir objects
+ cc -c -I. -Iunix -Iunix/bsd43 -O infer.c
+ mv infer.o objects
+@@ -51,19 +53,12 @@
+ mv runargv.o objects
+ cc -c -I. -Iunix -Iunix/bsd43 -O unix/dcache.c
+ mv dcache.o objects
+-cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/putenv.c
+-mv putenv.o objects
+-cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/tempnam.c
+-mv tempnam.o objects
+-cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/utime.c
+-mv utime.o objects
+-cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/setvbuf.c
+-mv setvbuf.o objects
+ cc -O -o dmake objects/infer.o objects/make.o objects/stat.o objects/expand.o \
+ objects/dmstring.o objects/hash.o objects/dag.o objects/dmake.o objects/path.o \
+ objects/imacs.o objects/sysintf.o objects/parse.o objects/getinp.o \
+ objects/quit.o objects/state.o objects/dmdump.o objects/macparse.o \
+ objects/rulparse.o objects/percent.o objects/function.o objects/arlib.o \
+ objects/dirbrk.o objects/rmprq.o objects/ruletab.o objects/runargv.o \
+-objects/dcache.o objects/putenv.o objects/tempnam.o objects/utime.o objects/setvbuf.o
++objects/dcache.o
+ cp unix/bsd43/template.mk startup/config.mk
++fi
diff --git a/devel/dmake/files/patch-ab b/devel/dmake/files/patch-ab
new file mode 100644
index 000000000000..5c67bcfbe6bb
--- /dev/null
+++ b/devel/dmake/files/patch-ab
@@ -0,0 +1,12 @@
+--- unix/runargv.c.orig Wed Jul 16 01:02:34 1997
++++ unix/runargv.c Mon Sep 8 03:01:42 1997
+@@ -68,7 +68,9 @@
+ char *cmd;
+ {
+ extern int errno;
++#ifndef __FreeBSD__
+ extern char *sys_errlist[];
++#endif
+ int pid;
+ char **argv;
+
diff --git a/devel/dmake/files/patch-ac b/devel/dmake/files/patch-ac
new file mode 100644
index 000000000000..ed21d6ae45e3
--- /dev/null
+++ b/devel/dmake/files/patch-ac
@@ -0,0 +1,10 @@
+--- unix/dcache.c.orig Wed Jul 16 01:02:34 1997
++++ unix/dcache.c Mon Sep 8 03:20:56 1997
+@@ -35,6 +35,7 @@
+ #undef __WIN32__
+ #endif
+
++#include <sys/types.h>
+ #include <dirent.h>
+ #include "extern.h"
+ #include "sysintf.h"