aboutsummaryrefslogtreecommitdiffstats
path: root/devel/e_dbus
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-03-12 05:13:53 +0800
committerstas <stas@FreeBSD.org>2008-03-12 05:13:53 +0800
commit7843035eea9d002a1991cf57b8c8c617c6f55b1f (patch)
tree5c186a065f2ed99e4bc9b28ae52aa862ee51b8e9 /devel/e_dbus
parent5ca76f49f1219351516746abab31c1305b88f628 (diff)
downloadfreebsd-ports-gnome-7843035eea9d002a1991cf57b8c8c617c6f55b1f.tar.gz
freebsd-ports-gnome-7843035eea9d002a1991cf57b8c8c617c6f55b1f.tar.zst
freebsd-ports-gnome-7843035eea9d002a1991cf57b8c8c617c6f55b1f.zip
- Update enlightenment-devel and EFL libraries to the latest snapshot
- Deprecate old unsupported apps and modules (entice, devian, eveil, engage) - Split evas and ecore to separate modules to handle dependencies properly - Disable PAM in enlightenment-devel as it don't work anyway (requires root privilegies) - Add DBUS support. Thanks to: az
Diffstat (limited to 'devel/e_dbus')
-rw-r--r--devel/e_dbus/Makefile56
-rw-r--r--devel/e_dbus/distinfo3
-rw-r--r--devel/e_dbus/pkg-descr3
-rw-r--r--devel/e_dbus/pkg-plist31
4 files changed, 93 insertions, 0 deletions
diff --git a/devel/e_dbus/Makefile b/devel/e_dbus/Makefile
new file mode 100644
index 000000000000..7a5faef3c5bf
--- /dev/null
+++ b/devel/e_dbus/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: e_dbus
+# Date created: 23 February 2008
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= e_dbus
+PORTVERSION= 20080223
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= EFL DBUS connectivity library
+
+LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_EFL= ecore
+USE_LDCONFIG= yes
+
+OPTIONS= EHAL "Build E HAL module" on \
+ ENM "Build E NM module" on \
+ ENOT "Build E notify module" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_EHAL)
+CONFIGURE_ARGS+= --enable-ehal
+PLIST_SUB+= EHAL=""
+.else
+CONFIGURE_ARGS+= --disable-ehal
+PLIST_SUB+= EHAL="@comment "
+.endif
+
+.if !defined(WITHOUT_ENM)
+CONFIGURE_ARGS+= --enable-enm
+PLIST_SUB+= ENM=""
+.else
+CONFIGURE_ARGS+= --disable-enm
+PLIST_SUB+= ENM="@comment "
+.endif
+
+.if !defined(WITHOUT_ENOT)
+CONFIGURE_ARGS+= --enable-enotify
+PLIST_SUB+= ENOT=""
+USE_EFL+= evas
+.else
+CONFIGURE_ARGS+= --disable-enotify
+PLIST_SUB+= ENOT="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/e_dbus/distinfo b/devel/e_dbus/distinfo
new file mode 100644
index 000000000000..486c69fb2ee8
--- /dev/null
+++ b/devel/e_dbus/distinfo
@@ -0,0 +1,3 @@
+MD5 (e_dbus-20080223.tar.bz2) = d709ffed87f71253a62cda1484b0aa64
+SHA256 (e_dbus-20080223.tar.bz2) = f27382a51c16f7d10b3e2757c4b8c3a483b3afc137cafae4321252b3d4cf59c0
+SIZE (e_dbus-20080223.tar.bz2) = 252568
diff --git a/devel/e_dbus/pkg-descr b/devel/e_dbus/pkg-descr
new file mode 100644
index 000000000000..141e4ab49806
--- /dev/null
+++ b/devel/e_dbus/pkg-descr
@@ -0,0 +1,3 @@
+Enlightenment DBUS compatibility layer.
+
+WWW: http://www.enlightenment.org/
diff --git a/devel/e_dbus/pkg-plist b/devel/e_dbus/pkg-plist
new file mode 100644
index 000000000000..5699855209ab
--- /dev/null
+++ b/devel/e_dbus/pkg-plist
@@ -0,0 +1,31 @@
+%%EHAL%%bin/e_dbus_hal
+%%ENM%%bin/e_dbus_nm
+%%ENOT%%bin/e_dbus_notification_daemon
+%%ENOT%%bin/e_dbus_notify
+bin/e_dbus_test
+bin/e_dbus_test_client
+include/E_DBus.h
+%%EHAL%%include/E_Hal.h
+%%ENM%%include/E_Nm.h
+%%ENOT%%include/E_Notification_Daemon.h
+%%ENOT%%include/E_Notify.h
+lib/libedbus.a
+lib/libedbus.la
+lib/libedbus.so
+lib/libedbus.so.1
+%%EHAL%%lib/libehal.a
+%%EHAL%%lib/libehal.la
+%%EHAL%%lib/libehal.so
+%%EHAL%%lib/libehal.so.1
+%%ENM%%lib/libenm.a
+%%ENM%%lib/libenm.la
+%%ENM%%lib/libenm.so
+%%ENM%%lib/libenm.so.1
+%%ENOT%%lib/libenotify.a
+%%ENOT%%lib/libenotify.la
+%%ENOT%%lib/libenotify.so
+%%ENOT%%lib/libenotify.so.1
+libdata/pkgconfig/edbus.pc
+%%EHAL%%libdata/pkgconfig/ehal.pc
+%%ENM%%libdata/pkgconfig/enm.pc
+%%ENOT%%libdata/pkgconfig/enotify.pc