aboutsummaryrefslogtreecommitdiffstats
path: root/devel/embb
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
commit49081780dbf920e309ccc96ab737f85e04f46c66 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /devel/embb
parent08b2e1c36dfd47eb173836d5b9826e537512dc18 (diff)
downloadfreebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.gz
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.zst
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'devel/embb')
-rw-r--r--devel/embb/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/embb/Makefile b/devel/embb/Makefile
index 42aa2c6e4883..a2f902c19ba3 100644
--- a/devel/embb/Makefile
+++ b/devel/embb/Makefile
@@ -16,7 +16,7 @@ LICENSE_COMB= multi
USE_GITHUB= yes
GH_ACCOUNT= siemens
-USES= cmake:outsource compiler:c++11-lib
+USES= cmake compiler:c++11-lib
CMAKE_ARGS= -DINSTALL_PREFIX=${PREFIX} \
-DUSE_C11_AND_CXX11:BOOL=true