aboutsummaryrefslogtreecommitdiffstats
path: root/devel/eric6
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2016-08-18 23:39:55 +0800
committerdbn <dbn@FreeBSD.org>2016-08-18 23:39:55 +0800
commit59b8cd082270a95c6733b34caede4a001e1429e3 (patch)
tree4136e7901b1eed6622707504e76f7e09c7a237e9 /devel/eric6
parent8d7da0b0a9ecea1438d82833c9a74ca43be7f051 (diff)
downloadfreebsd-ports-gnome-59b8cd082270a95c6733b34caede4a001e1429e3.tar.gz
freebsd-ports-gnome-59b8cd082270a95c6733b34caede4a001e1429e3.tar.zst
freebsd-ports-gnome-59b8cd082270a95c6733b34caede4a001e1429e3.zip
devel/eric6: add option to use PyQt5, fix PyQt4.
- Fix the use of PyQt4 when PyQt5 is installed: - Specify which version of PyQt to target on installation - Add support for switching between PyQt4 and PyQt5 for the GUI. - Fix stage-qa warning: - Make symlink to pixmap relative. - Take over maintainership PR: 211908
Diffstat (limited to 'devel/eric6')
-rw-r--r--devel/eric6/Makefile29
-rw-r--r--devel/eric6/Makefile.inc4
2 files changed, 22 insertions, 11 deletions
diff --git a/devel/eric6/Makefile b/devel/eric6/Makefile
index b8578561581b..8ddcedca777b 100644
--- a/devel/eric6/Makefile
+++ b/devel/eric6/Makefile
@@ -1,24 +1,34 @@
# Created by: Boris Samorodov <bsam@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= devel python
DISTNAME= ${PORTNAME}-${PORTVERSION}
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:x11-toolkits/py-qt4-gui \
- ${PYTHON_SITELIBDIR}/PyQt4/Qsci.so:devel/py-qt4-qscintilla2
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtGui.so:x11-toolkits/py-qt${PYQTVER}-gui \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/Qsci.so:devel/py-qt${PYQTVER}-qscintilla2
RUN_DEPENDS:= ${BUILD_DEPENDS} \
- ${PYTHON_SITELIBDIR}/PyQt4/QtNetwork.so:net/py-qt4-network \
- ${PYTHON_SITELIBDIR}/PyQt4/QtSvg.so:graphics/py-qt4-svg \
- ${PYTHON_SITELIBDIR}/PyQt4/QtSql.so:databases/py-qt4-sql \
- ${PYTHON_SITELIBDIR}/PyQt4/QtWebKit.so:www/py-qt4-webkit \
- ${PYTHON_SITELIBDIR}/PyQt4/QtHelp.so:devel/py-qt4-help \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtNetwork.so:net/py-qt${PYQTVER}-network \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtSvg.so:graphics/py-qt${PYQTVER}-svg \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtSql.so:databases/py-qt${PYQTVER}-sql \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtWebKit.so:www/py-qt${PYQTVER}-webkit \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtHelp.so:devel/py-qt${PYQTVER}-help \
${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:databases/py-sqlite3
USES= desktop-file-utils
-INSTALL_CMD= install.py -c -f eric6config.freebsd -i ${STAGEDIR}
+INSTALL_CMD= install.py -c -f eric6config.freebsd -i ${STAGEDIR} --pyqt=${PYQTVER}
PLIST_FILES=
SUB_FILES= eric6.desktop
OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFAULT=PYQT4
+OPTIONS_SINGLE= PYQT
+OPTIONS_SINGLE_PYQT= PYQT4 PYQT5
+PYQT_DESC= PyQt Version
+PYQT4_DESC= Python bindings for Qt4
+PYQT4_VARS= PYQTVER=4
+PYQT5_DESC= Python bindings for Qt5
+PYQT5_VARS= PYQTVER=5
+PYQT5_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt5/QtWebKitWidgets.so:www/py-qt5-webkitwidgets
EXTRA_PATCHES=
MASTERPORT=
@@ -37,7 +47,8 @@ do-configure:
post-install:
${INSTALL_DATA} ${WRKDIR}/eric6.desktop ${STAGEDIR}${PREFIX}/share/applications/
- ${LN} -sf ${DATADIR}/icons/default/eric.png ${STAGEDIR}${PREFIX}/share/pixmaps/eric6.png
+ ${LN} -sf ${DATADIR:C|${PREFIX}(/share(/pixmaps)?)?||:C|/[^/]+|../|g}icons/default/eric.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/eric6.png
@${MKDIR} ${STAGEDIR}${DATADIR}/i18n
.include "${.CURDIR}/../../devel/eric6/Makefile.inc"
diff --git a/devel/eric6/Makefile.inc b/devel/eric6/Makefile.inc
index 110f5cb2b336..907c71e9b572 100644
--- a/devel/eric6/Makefile.inc
+++ b/devel/eric6/Makefile.inc
@@ -11,8 +11,8 @@ MASTER_SITES= SF/eric-ide/${PORTNAME}/stable/${PORTVERSION}
DISTNAME?= ${PORTNAME}-i18n-${I18N_LANG}-${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAINTAINER?= bsam@FreeBSD.org
-COMMENT= Full featured Python and Ruby editor and IDE based on Qt4
+MAINTAINER?= dbn@FreeBSD.org
+COMMENT= Full featured Python and Ruby editor and IDE based on Qt
LICENSE= GPLv3