aboutsummaryrefslogtreecommitdiffstats
path: root/devel/fastcrc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-06 20:30:19 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-06 20:30:19 +0800
commit6c6a62798cf08e2e6eb8ae6820c888e7d8adc468 (patch)
tree987567b60d0fe90c15af3d457a22b910c03dc4f1 /devel/fastcrc
parentb464d5cdb956ca68000425b856f9b5e6a25fe0a8 (diff)
downloadfreebsd-ports-gnome-6c6a62798cf08e2e6eb8ae6820c888e7d8adc468.tar.gz
freebsd-ports-gnome-6c6a62798cf08e2e6eb8ae6820c888e7d8adc468.tar.zst
freebsd-ports-gnome-6c6a62798cf08e2e6eb8ae6820c888e7d8adc468.zip
- Support staging
- Define DOCS option
Diffstat (limited to 'devel/fastcrc')
-rw-r--r--devel/fastcrc/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/devel/fastcrc/Makefile b/devel/fastcrc/Makefile
index 64d5c0529ac6..58bb1029e9fb 100644
--- a/devel/fastcrc/Makefile
+++ b/devel/fastcrc/Makefile
@@ -15,20 +15,20 @@ ONLY_FOR_ARCHS= i386
USE_LDCONFIG= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
's|gcc|$${CC}| ; \
/strip/d' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/fc ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/fastcrc.h ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/libfcrc.so.1 ${PREFIX}/lib
- ${LN} -fs ${PREFIX}/lib/libfcrc.so.1 ${PREFIX}/lib/libfcrc.so
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/fc ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/fastcrc.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/libfcrc.so.1 ${STAGEDIR}${PREFIX}/lib
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libfcrc.so.1
+ ${LN} -fs libfcrc.so.1 ${STAGEDIR}${PREFIX}/lib/libfcrc.so
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>