aboutsummaryrefslogtreecommitdiffstats
path: root/devel/fb303
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2011-12-08 19:08:02 +0800
committerscheidell <scheidell@FreeBSD.org>2011-12-08 19:08:02 +0800
commit670a3e48785b9960bd05d027939bb2bc464afad8 (patch)
tree7d37082487f4db2784c7b8f14bcfdce80a015169 /devel/fb303
parentbe91ce6957596634cb9e29c36b29e4e45adda144 (diff)
downloadfreebsd-ports-gnome-670a3e48785b9960bd05d027939bb2bc464afad8.tar.gz
freebsd-ports-gnome-670a3e48785b9960bd05d027939bb2bc464afad8.tar.zst
freebsd-ports-gnome-670a3e48785b9960bd05d027939bb2bc464afad8.zip
-Update fb303 to version 0.7.0 [1]
-pet portlint PR: ports/162052 [1] Submitted by: Valery Komarov <komarov@valerka.net> [1] Approved by: gslin@gslin.org (maintainer timeout, 30 days), gabor (mentor) Feature safe: yes
Diffstat (limited to 'devel/fb303')
-rw-r--r--devel/fb303/Makefile13
-rw-r--r--devel/fb303/distinfo4
-rw-r--r--devel/fb303/pkg-plist41
3 files changed, 29 insertions, 29 deletions
diff --git a/devel/fb303/Makefile b/devel/fb303/Makefile
index e1042ba46712..bae8463e3aea 100644
--- a/devel/fb303/Makefile
+++ b/devel/fb303/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= fb303
-PORTVERSION= 20090908
-PORTREVISION= 1
+PORTVERSION= 0.7.0
+PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= bms
+MASTER_SITES= APACHE
DISTNAME= thrift-${PORTVERSION}
MAINTAINER= gslin@gslin.org
@@ -19,20 +18,20 @@ COMMENT= The Facebook Bassline
LIB_DEPENDS= boost_system:${PORTSDIR}/devel/boost-libs \
thrift:${PORTSDIR}/devel/thrift
-BROKEN= does not compile
-
ACLOCAL_ARGS= -I ./aclocal
AUTOMAKE_ARGS= -a
CONFIGURE_ARGS= PY_PREFIX="${PREFIX}"
PLIST_SUB+= PYTHON_VERSION_SHORTNAME="${PYTHON_VERSION_SHORTNAME}"
PYTHON_VERSION_SHORTNAME= ${PYTHON_VERSION:S/thon//}
USE_AUTOTOOLS= aclocal automake autoconf
-USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5_RUN= yes
USE_PYTHON= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/contrib/fb303
+pre-configure:
+ ${CHMOD} 774 ${WRKSRC}/../../install-sh
+
post-build:
(cd ${WRKSRC} && ${LOCALBASE}/bin/thrift --gen perl ${WRKSRC}/if/fb303.thrift)
diff --git a/devel/fb303/distinfo b/devel/fb303/distinfo
index 7be85576354c..6d10b1d384a2 100644
--- a/devel/fb303/distinfo
+++ b/devel/fb303/distinfo
@@ -1,2 +1,2 @@
-SHA256 (thrift-20090908.tar.bz2) = 8bc9174d8c5be03a92c487c62195f53644e76aef56fdf9d95294e439d19a7933
-SIZE (thrift-20090908.tar.bz2) = 524374
+SHA256 (thrift-0.7.0.tar.gz) = ca830156f6f1f94e77823eb5db6ff8f532ed5ccb9e913df83d0c3d6c4ddb9009
+SIZE (thrift-0.7.0.tar.gz) = 2248326
diff --git a/devel/fb303/pkg-plist b/devel/fb303/pkg-plist
index 2dcc7f725204..7ba1d889c75e 100644
--- a/devel/fb303/pkg-plist
+++ b/devel/fb303/pkg-plist
@@ -1,6 +1,13 @@
-@comment $FreeBSD$
-%%DATADIR%%/if/fb303.thrift
-%%PYTHON_SITELIBDIR%%/fb303-1.0-%%PYTHON_VERSION_SHORTNAME%%.egg-info
+include/thrift/fb303/FacebookBase.h
+include/thrift/fb303/FacebookService.h
+include/thrift/fb303/ServiceTracker.h
+include/thrift/fb303/fb303_constants.h
+include/thrift/fb303/fb303_types.h
+lib/libfb303.a
+%%SITE_PERL%%/Facebook/FB303/Constants.pm
+%%SITE_PERL%%/Facebook/FB303/FacebookService.pm
+%%SITE_PERL%%/Facebook/FB303/Types.pm
+%%PYTHON_SITELIBDIR%%/fb303-1.0-py2.7.egg-info
%%PYTHON_SITELIBDIR%%/fb303/FacebookBase.py
%%PYTHON_SITELIBDIR%%/fb303/FacebookBase.pyc
%%PYTHON_SITELIBDIR%%/fb303/FacebookService.py
@@ -15,20 +22,14 @@
%%PYTHON_SITELIBDIR%%/fb303_scripts/__init__.pyc
%%PYTHON_SITELIBDIR%%/fb303_scripts/fb303_simple_mgmt.py
%%PYTHON_SITELIBDIR%%/fb303_scripts/fb303_simple_mgmt.pyc
-%%SITE_PERL%%/Facebook/FB303/Constants.pm
-%%SITE_PERL%%/Facebook/FB303/FacebookService.pm
-%%SITE_PERL%%/Facebook/FB303/Types.pm
-include/thrift/fb303/FacebookBase.h
-include/thrift/fb303/FacebookService.h
-include/thrift/fb303/ServiceTracker.h
-include/thrift/fb303/fb303_constants.h
-include/thrift/fb303/fb303_types.h
-lib/libfb303.a
-@dirrmtry include/thrift/fb303
-@dirrmtry include/thrift
-@dirrmtry %%SITE_PERL%%/Facebook/FB303
-@dirrmtry %%SITE_PERL%%/Facebook
-@dirrmtry %%PYTHON_SITELIBDIR%%/fb303_scripts
-@dirrmtry %%PYTHON_SITELIBDIR%%/fb303
-@dirrmtry %%DATADIR%%/if
-@dirrmtry %%DATADIR%%
+%%DATADIR%%/if/fb303.thrift
+@dirrm %%DATADIR%%/if
+@dirrm %%DATADIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/fb303_scripts
+@dirrm %%PYTHON_SITELIBDIR%%/fb303
+@dirrm %%PYTHON_SITELIBDIR%%
+@dirrm lib/python2.7
+@dirrm %%SITE_PERL%%/Facebook/FB303
+@dirrm %%SITE_PERL%%/Facebook
+@dirrm include/thrift/fb303
+@dirrm include/thrift