aboutsummaryrefslogtreecommitdiffstats
path: root/devel/folly
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-06-17 01:55:50 +0800
committeryuri <yuri@FreeBSD.org>2019-06-17 01:55:50 +0800
commitbc4ad8a1729579927401acbedfd76b1ec5c2996f (patch)
tree4cbba035592a777be60e57eb2d8b2c4ebbc23360 /devel/folly
parent02a555be4d33fcbb60009831aa3388705ba1a707 (diff)
downloadfreebsd-ports-gnome-bc4ad8a1729579927401acbedfd76b1ec5c2996f.tar.gz
freebsd-ports-gnome-bc4ad8a1729579927401acbedfd76b1ec5c2996f.tar.zst
freebsd-ports-gnome-bc4ad8a1729579927401acbedfd76b1ec5c2996f.zip
devel/folly: Upstream patches; Fix bogus SYS_gettid-related code; Mark broken on i386
PR: 238608 Reported by: jbeich (bogus SYS_gettid and i386 failure)
Diffstat (limited to 'devel/folly')
-rw-r--r--devel/folly/Makefile6
-rw-r--r--devel/folly/distinfo2
-rw-r--r--devel/folly/files/patch-folly_Memory.h12
-rw-r--r--devel/folly/files/patch-folly_Subprocess.cpp27
-rw-r--r--devel/folly/files/patch-folly_Subprocess.h11
-rw-r--r--devel/folly/files/patch-folly_experimental_EnvUtil.cpp10
-rw-r--r--devel/folly/files/patch-folly_portability_Malloc.h11
-rw-r--r--devel/folly/files/patch-folly_portability_Stdlib.cpp10
-rw-r--r--devel/folly/files/patch-folly_portability_SysSyscall.h11
9 files changed, 8 insertions, 92 deletions
diff --git a/devel/folly/Makefile b/devel/folly/Makefile
index a3f1fb4d872f..1ac3b2bbe65d 100644
--- a/devel/folly/Makefile
+++ b/devel/folly/Makefile
@@ -3,14 +3,20 @@
PORTNAME= folly
DISTVERSIONPREFIX= v
DISTVERSION= 2019.06.10.00
+PORTREVISION= 1
CATEGORIES= devel
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
+PATCHFILES= 2461dea6d517515ebea623d162722910ede5e86f.patch:-p1
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= C++ library developed and used at Facebook
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_i386= error: use of undeclared identifier 'DCHECK': https://github.com/facebook/folly/issues/1168
+
LIB_DEPENDS= libboost_atomic.so:devel/boost-libs \
libdouble-conversion.so:devel/double-conversion \
libevent.so:devel/libevent \
diff --git a/devel/folly/distinfo b/devel/folly/distinfo
index 4692df1127a2..95b14ba8954c 100644
--- a/devel/folly/distinfo
+++ b/devel/folly/distinfo
@@ -1,3 +1,5 @@
TIMESTAMP = 1560670033
SHA256 (facebook-folly-v2019.06.10.00_GH0.tar.gz) = afecd68815a83865d95a3a6b861abe8096beefae45c89566e0d510279b631b57
SIZE (facebook-folly-v2019.06.10.00_GH0.tar.gz) = 2941638
+SHA256 (2461dea6d517515ebea623d162722910ede5e86f.patch) = eb55e3d3c696abfcb0f0e45e49e92df0772533b6eb62480187d72658291c8cae
+SIZE (2461dea6d517515ebea623d162722910ede5e86f.patch) = 4996
diff --git a/devel/folly/files/patch-folly_Memory.h b/devel/folly/files/patch-folly_Memory.h
deleted file mode 100644
index b570eb63a8a9..000000000000
--- a/devel/folly/files/patch-folly_Memory.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- folly/Memory.h.orig 2019-06-16 07:33:44 UTC
-+++ folly/Memory.h
-@@ -57,7 +57,8 @@ inline void deallocateBytes(void* p, size_t n) {
- (defined(__ANDROID__) && (__ANDROID_API__ > 16)) || \
- (defined(__APPLE__) && \
- (__MAC_OS_X_VERSION_MIN_REQUIRED >= __MAC_10_6 || \
-- __IPHONE_OS_VERSION_MIN_REQUIRED >= __IPHONE_3_0))
-+ __IPHONE_OS_VERSION_MIN_REQUIRED >= __IPHONE_3_0)) || \
-+ defined(__FreeBSD__)
-
- inline void* aligned_malloc(size_t size, size_t align) {
- // use posix_memalign, but mimic the behaviour of memalign
diff --git a/devel/folly/files/patch-folly_Subprocess.cpp b/devel/folly/files/patch-folly_Subprocess.cpp
deleted file mode 100644
index b4184fbf077c..000000000000
--- a/devel/folly/files/patch-folly_Subprocess.cpp
+++ /dev/null
@@ -1,27 +0,0 @@
---- folly/Subprocess.cpp.orig 2019-06-16 07:47:17 UTC
-+++ folly/Subprocess.cpp
-@@ -24,6 +24,7 @@
- #include <sys/prctl.h>
- #endif
- #include <fcntl.h>
-+#include <unistd.h>
-
- #include <algorithm>
- #include <array>
-@@ -394,6 +395,7 @@ void Subprocess::spawnInternal(
- envHolder = cloneStrings(*env);
- envVec = const_cast<char**>(envHolder.get());
- } else {
-+ extern char **environ;
- envVec = environ;
- }
-
-@@ -557,7 +559,7 @@ int Subprocess::prepareChild(
- #endif
-
- if (options.processGroupLeader_) {
-- if (setpgrp() == -1) {
-+ if (setpgrp(0, 0) == -1) {
- return errno;
- }
- }
diff --git a/devel/folly/files/patch-folly_Subprocess.h b/devel/folly/files/patch-folly_Subprocess.h
deleted file mode 100644
index f71fec27c34a..000000000000
--- a/devel/folly/files/patch-folly_Subprocess.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- folly/Subprocess.h.orig 2019-06-16 07:46:12 UTC
-+++ folly/Subprocess.h
-@@ -95,7 +95,7 @@
- #include <signal.h>
- #include <sys/types.h>
-
--#if __APPLE__
-+#if defined(__APPLE__) || defined(__FreeBSD__)
- #include <sys/wait.h>
- #else
- #include <wait.h>
diff --git a/devel/folly/files/patch-folly_experimental_EnvUtil.cpp b/devel/folly/files/patch-folly_experimental_EnvUtil.cpp
deleted file mode 100644
index 8bf1d2098bb3..000000000000
--- a/devel/folly/files/patch-folly_experimental_EnvUtil.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- folly/experimental/EnvUtil.cpp.orig 2019-06-16 07:49:05 UTC
-+++ folly/experimental/EnvUtil.cpp
-@@ -27,6 +27,7 @@ using namespace folly::experimental;
-
- EnvironmentState EnvironmentState::fromCurrentEnvironment() {
- std::unordered_map<std::string, std::string> data;
-+ extern char **environ;
- for (auto it = environ; it && *it; ++it) {
- std::string key, value;
- folly::StringPiece entry(*it);
diff --git a/devel/folly/files/patch-folly_portability_Malloc.h b/devel/folly/files/patch-folly_portability_Malloc.h
deleted file mode 100644
index 7727c45f1142..000000000000
--- a/devel/folly/files/patch-folly_portability_Malloc.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- folly/portability/Malloc.h.orig 2019-06-16 07:29:29 UTC
-+++ folly/portability/Malloc.h
-@@ -26,7 +26,7 @@
- // malloc_usable_size, and that's what we should be using.
- #include <jemalloc/jemalloc.h> // @manual
- #else
--#ifndef __APPLE__
-+#if !defined(__APPLE__) && !defined(__FreeBSD__)
- #include <malloc.h>
- #endif
-
diff --git a/devel/folly/files/patch-folly_portability_Stdlib.cpp b/devel/folly/files/patch-folly_portability_Stdlib.cpp
deleted file mode 100644
index 0d3f98b9e9c0..000000000000
--- a/devel/folly/files/patch-folly_portability_Stdlib.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- folly/portability/Stdlib.cpp.orig 2019-06-16 07:44:30 UTC
-+++ folly/portability/Stdlib.cpp
-@@ -149,6 +149,7 @@ int unsetenv(const char* name) {
-
- extern "C" int clearenv() {
- std::vector<std::string> data;
-+ extern char **environ;
- for (auto it = environ; it && *it; ++it) {
- std::string entry(*it);
- auto equalsPosition = entry.find('=');
diff --git a/devel/folly/files/patch-folly_portability_SysSyscall.h b/devel/folly/files/patch-folly_portability_SysSyscall.h
deleted file mode 100644
index 4a7c66442a36..000000000000
--- a/devel/folly/files/patch-folly_portability_SysSyscall.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- folly/portability/SysSyscall.h.orig 2019-06-16 07:32:11 UTC
-+++ folly/portability/SysSyscall.h
-@@ -21,6 +21,8 @@
-
- #if defined(__APPLE__)
- #define FOLLY_SYS_gettid SYS_thread_selfid
-+#elif defined(__FreeBSD__)
-+#define FOLLY_SYS_gettid SYS_thr_self
- #elif defined(SYS_gettid)
- #define FOLLY_SYS_gettid SYS_gettid
- #else